This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 811498 - [abrt] ktp-contact-list-0.3.1-1.fc17: Process /usr/bin/ktp-contactlist was killed by signal 11 (SIGSEGV)
[abrt] ktp-contact-list-0.3.1-1.fc17: Process /usr/bin/ktp-contactlist was ki...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ktp-contact-list (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jaroslav Reznik
Fedora Extras Quality Assurance
abrt_hash:d4844c7c27b47ec730e096de3ac...
:
: 817259 824410 827427 827480 834969 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-04-11 05:27 EDT by Karel Volný
Modified: 2012-07-05 12:05 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-07-05 12:05:28 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
File: backtrace (778.80 KB, text/plain)
2012-04-11 05:27 EDT, Karel Volný
no flags Details
File: smolt_data (2.47 KB, text/plain)
2012-04-11 05:27 EDT, Karel Volný
no flags Details
File: maps (53.79 KB, text/plain)
2012-04-11 05:27 EDT, Karel Volný
no flags Details
File: dso_list (12.96 KB, text/plain)
2012-04-11 05:27 EDT, Karel Volný
no flags Details


External Trackers
Tracker ID Priority Status Summary Last Updated
KDE Software Compilation 293886 None None None 2012-07-05 12:01:12 EDT

  None (edit)
Description Karel Volný 2012-04-11 05:27:34 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        /usr/bin/ktp-contactlist
comment:        I've just trie to view offline contacts, then after hovering over the first offline one the contactlist disappeared with this crash ...
core_backtrace: 
crash_function: QCoreApplication::removePostedEvents
executable:     /usr/bin/ktp-contactlist
kernel:         3.3.1-3.fc17.x86_64
pid:            13018
pwd:            /home/zlatuska/Dokumenty
remote_result:  NOTFOUND
time:           St 11. apríl 2012, 11:06:16 CEST
uid:            1000
username:       zlatuska
var_log_messages: Apr 11 11:06:17 lentilka abrt[13116]: Saved core dump of pid 13018 (/usr/bin/ktp-contactlist) to /var/spool/abrt/ccpp-2012-04-11-11:06:16-13018 (21692416 bytes)

backtrace:      Text file, 797489 bytes
dso_list:       Text file, 13266 bytes
maps:           Text file, 55079 bytes
smolt_data:     Binary file, 2532 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/zlatuska/1

environ:
:XDG_VTNR=1
:SSH_AGENT_PID=1004
:XDG_SESSION_ID=1
:DM_CONTROL=/var/run/xdmctl
:HOSTNAME=lentilka
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:XDG_MENU_PREFIX=kde4-
:SHELL=/bin/bash
:TERM=dumb
:XDM_MANAGED=method=classic,auto
:HISTSIZE=1000
:GTK2_RC_FILES=/etc/gtk-2.0/gtkrc:/home/zlatuska/.gtkrc-2.0:/home/zlatuska/.gtkrc-2.0-kde4:/home/zlatuska/.kde/share/config/gtkrc-2.0
:GS_LIB=
:QTDIR=/usr/lib64/qt-3.3
:QTINC=/usr/lib64/qt-3.3/include
:KDE_FULL_SESSION=true
:IMSETTINGS_MODULE=none
:USER=zlatuska
:SSH_AUTH_SOCK=/tmp/ssh-PyChUhlRD610/agent.610
:DESKTOP_SESSION=kde-plasma
:PATH=/usr/lib64/qt-3.3/bin:/usr/local/bin:/usr/bin:/bin:/usr/games:/usr/local/sbin:/usr/sbin:/home/zlatuska/.local/bin:/home/zlatuska/bin
:MAIL=/var/spool/mail/zlatuska
:QT_IM_MODULE=xim
:PWD=/home/zlatuska
:XMODIFIERS=@im=none
:KDE_SESSION_UID=1000
:LANG=sk_SK.UTF-8
:KDE_IS_PRELINKED=1
:KDEDIRS=/usr
:SSH_ASKPASS=/usr/bin/ksshaskpass
:HISTCONTROL=ignoredups
:SHLVL=2
:XDG_SEAT=seat0
:HOME=/home/zlatuska
:KDE_SESSION_VERSION=4
:LOGNAME=zlatuska
:QTLIB=/usr/lib64/qt-3.3/lib
:XDG_DATA_DIRS=/usr/share/kde-settings/kde-profile/default/share:/usr/local/share:/usr/share
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-iJSGFDvDpf,guid=ea280002a5efac88fd9460e70000001b
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/zlatuska
:DISPLAY=:0
:QT_PLUGIN_PATH=/home/zlatuska/.kde/lib64/kde4/plugins/:/usr/lib64/kde4/plugins/:/usr/lib/kde4/plugins
:GTK_IM_MODULE=gtk-im-context-simple
:XAUTHORITY=/tmp/kde-zlatuska/xauth-1000-_0
:_=/usr/libexec/kde4/start_kdeinit_wrapper
:KDE_MULTIHEAD=false
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1175,unix/unix:/tmp/.ICE-unix/1175
:GTK_RC_FILES=/etc/gtk/gtkrc:/home/zlatuska/.gtkrc:/home/zlatuska/.kde/share/config/gtkrc
:XCURSOR_THEME=default
:DESKTOP_STARTUP_ID=lentilka;1334134900;753312;1188_TIME10998829

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 14664                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       14664                14664                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:pipe:[18159]
:pos:	0
:flags:	00
:1:/home/zlatuska/.xsession-errors
:pos:	81054
:flags:	0100001
:2:/home/zlatuska/.xsession-errors
:pos:	81054
:flags:	0100001
:3:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:4:pipe:[115280]
:pos:	0
:flags:	02004000
:5:socket:[116196]
:pos:	0
:flags:	02004002
:6:pipe:[115280]
:pos:	0
:flags:	02004001
:7:socket:[116202]
:pos:	0
:flags:	02004002
:8:socket:[116203]
:pos:	0
:flags:	02000002

xsession_errors:
:ktp-contactlist(13018) KPixmapSequence::Private::loadSequence: Invalid framesize. 
:ktp-contactlist(13018) KPixmapSequence::Private::loadSequence: Invalid framesize. 
:ktp-contactlist(13146) KPixmapSequence::Private::loadSequence: Invalid framesize. 
:ktp-contactlist(13146) KPixmapSequence::Private::loadSequence: Invalid framesize.
Comment 1 Karel Volný 2012-04-11 05:27:44 EDT
Created attachment 576726 [details]
File: backtrace
Comment 2 Karel Volný 2012-04-11 05:27:46 EDT
Created attachment 576727 [details]
File: smolt_data
Comment 3 Karel Volný 2012-04-11 05:27:49 EDT
Created attachment 576728 [details]
File: maps
Comment 4 Karel Volný 2012-04-11 05:27:51 EDT
Created attachment 576729 [details]
File: dso_list
Comment 5 Shawn Q 2012-06-06 14:10:32 EDT
Dual monitors, usually keep contact list on the left screen. Just clicked on titlebar, while rdesktop was running on right screen. Suddenly crashed.  First time ktp-contactlist crashed since F17 install.

backtrace_rating: 4
Package: ktp-contact-list-0.3.1-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 6 Rex Dieter 2012-07-05 12:02:22 EDT
*** Bug 817259 has been marked as a duplicate of this bug. ***
Comment 7 Rex Dieter 2012-07-05 12:02:44 EDT
*** Bug 824410 has been marked as a duplicate of this bug. ***
Comment 8 Rex Dieter 2012-07-05 12:03:09 EDT
*** Bug 827427 has been marked as a duplicate of this bug. ***
Comment 9 Rex Dieter 2012-07-05 12:03:31 EDT
*** Bug 827480 has been marked as a duplicate of this bug. ***
Comment 10 Rex Dieter 2012-07-05 12:03:57 EDT
*** Bug 834969 has been marked as a duplicate of this bug. ***
Comment 11 Rex Dieter 2012-07-05 12:05:28 EDT
I've confirmed with upstream devs that this issue should be fixed in the recent ktp-0.4 bugfix release made to fedora updates recently,

F-16: https://admin.fedoraproject.org/updates/FEDORA-2012-9558

F-17: https://admin.fedoraproject.org/updates/FEDORA-2012-9573

Note You need to log in before you can comment on or make changes to this bug.