Bug 817421 - pm-utils rpm info speaks about Fedora
Summary: pm-utils rpm info speaks about Fedora
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: pm-utils
Version: 5.8
Hardware: Unspecified
OS: Unspecified
urgent
urgent
Target Milestone: rc
: ---
Assignee: Jaroslav Škarvada
QA Contact: Desktop QE
URL:
Whiteboard:
: 800636 (view as bug list)
Depends On: 800630
Blocks: 835096
TreeView+ depends on / blocked
 
Reported: 2012-04-29 23:27 UTC by Jaroslav Škarvada
Modified: 2014-09-13 19:00 UTC (History)
4 users (show)

Fixed In Version: pm-utils-0.99.3-13.el5
Doc Type: Bug Fix
Doc Text:
Fedora Core was mentioned in the description and summary of the package. The description and summary was updated to be more general.
Clone Of: 800630
: 835096 (view as bug list)
Environment:
Last Closed: 2012-08-07 10:20:13 UTC
Target Upstream Version:


Attachments (Terms of Use)


Links
System ID Private Priority Status Summary Last Updated
Red Hat Product Errata RHBA-2012:1145 0 normal SHIPPED_LIVE pm-utils bug fix update 2012-08-07 14:18:52 UTC

Description Jaroslav Škarvada 2012-04-29 23:27:35 UTC
+++ This bug was initially created as a clone of Bug #800630 +++

+++ This bug was initially created as a clone of Bug #800454 +++

Description of problem:
I can see:
"Summary     : Power management utilities and scripts for Fedora"

when rpm -qi pm-utils

Version-Release number of selected component (if applicable):
pm-utils-1.4.1-12.el7.x86_64


Actual results:
Fedora

Expected results:
RHEL

Additional info:

--- Additional comment from jskarvad@redhat.com on 2012-03-06 15:25:42 CET ---

It seems this issue is there at least since rhel-5.

Comment 1 Jaroslav Škarvada 2012-04-30 18:18:25 UTC
    Technical note added. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    New Contents:
Fedora Core was mentioned in the description of the package. The description was updated to be more general.

Comment 3 Jaroslav Škarvada 2012-04-30 18:58:13 UTC
    Technical note updated. If any revisions are required, please edit the "Technical Notes" field
    accordingly. All revisions will be proofread by the Engineering Content Services team.
    
    Diffed Contents:
@@ -1 +1 @@
-Fedora Core was mentioned in the description of the package. The description was updated to be more general.+Fedora Core was mentioned in the description and summary of the package. The description and summary was updated to be more general.

Comment 4 Martin 2012-06-21 15:35:39 UTC
I installed (rpm -i) pm-utils-0.99.3-14.el5 from Brew and removed old version (rpm -e). Specfile in src.rpm is correct, same as info in Brew, but installed package not. yum info and rpm -qi still contains "Fedora Core" in summary and description.

Comment 5 Jaroslav Škarvada 2012-06-25 09:18:12 UTC
Strange, same with rpm -U. The desription in RPMs are wrong and different from Brew info and spec. It doesn't happen for mock builds, so probably some build system weirdness and the package will require rebuilt. It is 100% reproducible with scratch builds, no idea why this happen.

Comment 6 Jaroslav Škarvada 2012-06-25 10:54:06 UTC
Hexview confirmed that there are correct data in the RPM package, seems like rpm (caching ?) issue, ccing jnovy. But the build seems to be OK.

Comment 7 Jaroslav Škarvada 2012-06-25 14:17:55 UTC
I probably got it, the wrong text is in specspo internationalization package.

BTW not even the specspo content is wrong, also its own summary/description is wrong:
# rpm -qi specspo
Name        : specspo                      Relocations: (not relocatable)
Version     : 13                                Vendor: Red Hat, Inc.
Release     : 1.el5                         Build Date: Čt 30. listopad 2006, 21:58:17 CET
Install Date: Ne 17. červenec 2011, 23:14:27 CEST      Build Host: devel8.z900.redhat.com
Group       : Documentation                 Source RPM: specspo-13-1.el5.src.rpm
Size        : 20486218                         License: GPL
Signature   : DSA/SHA1, St 17. leden 2007, 21:38:56 CET, Key ID 5326810137017186
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Summary     : Fedora package descriptions, summaries, and groups.
Description :
The specspo package contains the portable object catalogues used to
internationalize Fedora packages.

Notice the word Fedora :)

Clonning to specspo.

Comment 8 Jaroslav Škarvada 2012-06-25 14:23:58 UTC
Clonned as bug 835096

Comment 9 Jaroslav Škarvada 2012-06-25 14:28:07 UTC
# yum remove specspo
# rpm -qi pm-utils

Name        : pm-utils                     Relocations: (not relocatable)
Version     : 0.99.3                            Vendor: Red Hat, Inc.
Release     : 14.el5                        Build Date: Po 30. duben 2012, 20:58:05 CEST
Install Date: Po 25. červen 2012, 16:27:08 CEST      Build Host: x86-007.build.bos.redhat.com
Group       : System Environment/Base       Source RPM: pm-utils-0.99.3-14.el5.src.rpm
Size        : 293786                           License: GPL
Signature   : (none)
Packager    : Red Hat, Inc. <http://bugzilla.redhat.com/bugzilla>
Summary     : Power management utilities and scripts
Description :
The pm-utils package contains utilities and scripts useful for tasks
related to power management.

Comment 10 Jaroslav Škarvada 2012-06-25 23:31:14 UTC
*** Bug 800636 has been marked as a duplicate of this bug. ***

Comment 11 Jaroslav Škarvada 2012-06-25 23:33:32 UTC
Also filled rpm bug 835310.

Comment 12 Martin 2012-08-01 13:00:43 UTC
Verified with workaround in comment #9

Comment 14 errata-xmlrpc 2012-08-07 10:20:13 UTC
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2012-1145.html


Note You need to log in before you can comment on or make changes to this bug.