Bug 823375 - Abort gives "fatal: XML-RPC(0): (null)" when reporting a bug
Abort gives "fatal: XML-RPC(0): (null)" when reporting a bug
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: abrt (Show other bugs)
15
Unspecified Linux
unspecified Severity medium
: ---
: ---
Assigned To: abrt
Fedora Extras Quality Assurance
: Reopened
: 828294 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-21 01:07 EDT by Noel Duffy
Modified: 2013-11-02 17:08 EDT (History)
16 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-06-01 23:56:04 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Noel Duffy 2012-05-21 01:07:08 EDT
User-Agent:       Mozilla/5.0 (X11; Linux x86_64; rv:10.0.1) Gecko/20100101 Firefox/10.0.1
Build Identifier: 

Abort gives "fatal: XML-RPC(0): (null)" when reporting a bug. I'm running Fedora 15 (Lovelock)

$ rpm -qa |grep abrt
abrt-plugin-bugzilla-2.0.3-6.fc15.x86_64
abrt-addon-ccpp-2.0.3-6.fc15.x86_64
abrt-plugin-logger-2.0.3-6.fc15.x86_64
abrt-2.0.3-6.fc15.x86_64
abrt-addon-kerneloops-2.0.3-6.fc15.x86_64
abrt-desktop-2.0.3-6.fc15.x86_64
abrt-libs-2.0.3-6.fc15.x86_64
abrt-gui-2.0.3-6.fc15.x86_64
abrt-addon-python-2.0.3-6.fc15.x86_64

The following output is shown in the abrt window when attempt to submit the bug:

--- Running report_Bugzilla ---
Logging into Bugzilla at https://bugzilla.redhat.com
Checking for duplicates
fatal: XML-RPC(0): (null)
(exited with 1)


Reproducible: Always

Steps to Reproduce:
1.Start abrt, attempt to report a bug to bugzilla
2. Click forward until it attempts to submit output.

Actual Results:  
--- Running report_Bugzilla ---
Logging into Bugzilla at https://bugzilla.redhat.com
Checking for duplicates
fatal: XML-RPC(0): (null)
(exited with 1)

Expected Results:  
Should check for duplicates and create a new bug in bugzilla, if necessary.
Comment 1 Nikola Pajkovsky 2012-05-21 04:56:13 EDT
commit 460d25bb22006a09870c59da570b2870b2da96af
Author: Nikola Pajkovsky <npajkovs@redhat.com>
Date:   Mon May 21 10:39:59 2012 +0200

    rhbz: die if missing mandatory member
    
    Signed-off-by: Nikola Pajkovsky <npajkovs@redhat.com>

commit 386bcecdff5eeea2f0855e9b91b73f862fa11860
Author: Nikola Pajkovsky <npajkovs@redhat.com>
Date:   Mon May 14 13:03:25 2012 +0200

    rhbz#820985 - bz 4.2 doesn't have 'bug_id' member; it's 'id'
    
    Signed-off-by: Nikola Pajkovsky <npajkovs@redhat.com>
Comment 2 Ian Laws 2012-05-21 15:47:15 EDT
I have got the same problem and I am running fc16,  I cannot report 2 bugs at this present time.

--- Running report_Bugzilla ---
Logging into Bugzilla at https://bugzilla.redhat.com
Checking for duplicates
fatal: XML-RPC(0): (null)
(exited with 1)


abrt-addon-ccpp-2.0.7-2.fc16.x86_64
abrt-desktop-2.0.7-2.fc16.x86_64
abrt-addon-vmcore-2.0.7-2.fc16.x86_64
abrt-gui-2.0.7-2.fc16.x86_64
abrt-retrace-client-2.0.7-2.fc16.x86_64
abrt-addon-kerneloops-2.0.7-2.fc16.x86_64
abrt-libs-2.0.7-2.fc16.x86_64
abrt-2.0.7-2.fc16.x86_64
abrt-addon-python-2.0.7-2.fc16.x86_64
[ilaws@Big-Brother ~]$
Comment 3 Nikola Pajkovsky 2012-05-22 06:25:58 EDT
abrt is affected on all releases. update should be asap.
Comment 4 Jiri Moskovcak 2012-05-22 08:36:51 EDT

*** This bug has been marked as a duplicate of bug 823706 ***
Comment 5 Fedora Update System 2012-05-22 08:46:54 EDT
abrt-2.0.3-7.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/abrt-2.0.3-7.fc15
Comment 6 Fedora Update System 2012-05-24 19:58:16 EDT
Package abrt-2.0.3-7.fc15:
* should fix your issue,
* was pushed to the Fedora 15 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing abrt-2.0.3-7.fc15'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-8356/abrt-2.0.3-7.fc15
then log in and leave karma (feedback).
Comment 7 Fedora Update System 2012-06-01 23:56:04 EDT
abrt-2.0.3-7.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 8 Simon Piette 2012-06-04 17:39:41 EDT
(In reply to comment #7)
> abrt-2.0.3-7.fc15 has been pushed to the Fedora 15 stable repository.  If
> problems still persist, please make note of it in this bug report.

I have the same problem in Fedora 16. I currently have: abrt-2.0.7-3.fc16.x86_64
Comment 9 Matthias Dieter Wallnöfer 2012-06-08 02:46:56 EDT
Exactly, for Fedora 16 it has not been fixed yet - bug should be reopened.
Comment 10 Nikola Pajkovsky 2012-06-08 08:04:42 EDT
what version of libreport do you have?
Comment 11 Matthias Dieter Wallnöfer 2012-06-08 08:39:50 EDT
I have libreport-2.0.8-4.fc16.x86_64.
Comment 12 Nikola Pajkovsky 2012-06-08 08:52:25 EDT
you should have libreport-2.0.10-3.fc16, which is in testing repository; pick abrt libreport and btparser from testing repo and it will fix your problem
Comment 13 Matthias Dieter Wallnöfer 2012-06-08 11:52:46 EDT
That does the trick - thx.
Comment 14 Szabo Akos 2012-06-13 17:56:51 EDT
It works me again too, with libreport-2.0.10-3.fc16. Thank You!
Comment 15 Jiri Moskovcak 2012-06-14 04:57:48 EDT
*** Bug 828294 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.