Bug 827258 - after install I see SYSFONT=True rather than a font name
after install I see SYSFONT=True rather than a font name
Status: CLOSED DUPLICATE of bug 799401
Product: Fedora
Classification: Fedora
Component: i18n (Show other bugs)
17
All Linux
unspecified Severity low
: ---
: ---
Assigned To: i18n Engineering List
http://forums.fedoraforum.org/showthr...
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-05-31 20:14 EDT by xset1980
Modified: 2012-05-31 22:53 EDT (History)
26 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 827229
Environment:
Last Closed: 2012-05-31 22:53:31 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description xset1980 2012-05-31 20:14:11 EDT
+++ This bug was initially created as a clone of Bug #827229 +++

+++ This bug was initially created as a clone of Bug #799401 +++

Description of problem:

After installing from f17 alpha x86_64 DVD, my /boot/grub2/grub.cfg
file, /etc/default/grub, and /etc/sysconfig/i18n files all say
SYSFONT=True rather than the normal SYSFONT=latarcyrheb-sun16 I
normally get all previous Fedora versions.

If it should say True, that raises the question of how the devil I
set the console font to something else (like latarcyrheb-sun32).


Version-Release number of selected component (if applicable):
whatever anaconda is on the f17 alpha DVD

How reproducible:
I only installed once, but I image the same thing would happen
every time

Steps to Reproduce:
1.see above
2.
3.
  
Actual results:
SYSFONT=True

Expected results:
SYSFONT= some console font name

Additional info:

--- Additional comment from horsley1953@gmail.com on 2012-03-03 08:46:53 EST ---

Experimenting does reveal that I can say latarcyrheb-sun32 instead of True
and it will really use that big enough to see font, but True still seems
weird.

--- Additional comment from dan.mashal@gmail.com on 2012-03-14 15:26:45 EDT ---

This happens in 16 and 17, both x86 and i386 archs. 

Can someone in the grub team look at this?

--- Additional comment from horsley1953@gmail.com on 2012-04-17 20:45:48 EDT ---

I just installed the F17 Beta DVD and still see this.

I do wonder if this has something to do with the kbd change to include
the latarcyrheb-sun32 along with the latarcyrheb-sun16 font (just a thought since that was a change for f17).

--- Additional comment from clumens@redhat.com on 2012-04-18 09:35:43 EDT ---

*** Bug 801552 has been marked as a duplicate of this bug. ***

--- Additional comment from johan.spee@coonsden.com on 2012-04-19 07:25:27 EDT ---

This problem just showed up here after an update of F17 (i.e. not an fresh install).
 
I certainly would not rate the severity as "low", though, because it keeps grub from booting and consequently renders the entire system useless. That's more like "urgent".

--- Additional comment from horsley1953@gmail.com on 2012-04-19 08:01:03 EDT ---

Hmmm... It didn't prevent the boot for me back when it first happened on f17 alpha, maybe preventing boot is new in f17 beta (I always fix it and a bunch of other junk before I firstboot now anyway, so I wouldn't have noticed).

--- Additional comment from andrew.g.dunn@gmail.com on 2012-04-21 08:46:30 EDT ---

(In reply to comment #5)
> This problem just showed up here after an update of F17 (i.e. not an fresh
> install).
> 
> I certainly would not rate the severity as "low", though, because it keeps grub
> from booting and consequently renders the entire system useless. That's more
> like "urgent".

This also appears to render my entire system useless. I ran into it yesterday and re-installed F17 completely thinking it was something I did.

The system will not boot.

--- Additional comment from mads@kiilerich.com on 2012-04-21 09:05:19 EDT ---

/etc/default/grub is generated/overwritten by anaconda ... and it did apparently for some reason put a bad value there.

It might be a dracut bug that this bad value prevents booting.

--- Additional comment from horsley1953@gmail.com on 2012-04-21 09:19:30 EDT ---

It also puts it in the /etc/sysconfig/i18n file, just to complete the list of files that need attention when you fix things.

--- Additional comment from horsley1953@gmail.com on 2012-04-22 20:27:06 EDT ---

Here's a new variation on this bug: In my f17 Beta partition, I had manually
changed grub.cfg, /etc/default/grub, and /etc/sysconfig/i18n to all say
latarcyrheb-sun32 instead of "True".

I just got a kernel update for f17 to kernel 3.3.2-8.fc17.x86_64 and the new entry in grub.cfg says SYSFONT=True instead of latarcyrheb-sun32.

I then looked at /etc/sysconfig/i18n and something somewhere seems to have changed it back to "True" as well (which is probably where the kernel update got it from).

I have no idea what package updates /etc/sysconfig/i18n because it isn't marked as being owned by any package.

I suppose there is a small chance that the original change to the i18n file didn't work, but I used the same sed script for that file as for all the others.

--- Additional comment from horsley1953@gmail.com on 2012-04-22 20:34:20 EDT ---

OK, I take it back - comment #10 is a red herring. The sed script wouldn't have worked on the i18n file the way it was written (it will work now). So the reverting to True for new kernel is because that was still in the i18n file.

--- Additional comment from vonbrand@inf.utfsm.cl on 2012-04-26 18:06:49 EDT ---

I see the same as comment #5 (kernel-3.4.0-0.rc4.git1.1.fc18.x86_64), but AFAICS the "system not booting" (really falling into dracut shell) is due to not finding the LVM volumes. Just deleting the nonsense "SYSFONT=True" gets kernel-3.4.0-0.rc3.git0.1.fc18.x86_64 to  boot OK (haven't tried others, machine isn't at hand to fool around).

--- Additional comment from ipilcher@redhat.com on 2012-05-10 16:51:36 EDT ---

I'm seeing the same thing when I install kernel updates on my system, which is still using grub 0.9.  This happens even though I've removed the SYSFONT=... bit from the kernel command line in grub.conf.

AFAIK, grubby is responsible for updating the config for both grub 2 and grub 0.9, so doesn't that make this a grubby bug?

--- Additional comment from mads@kiilerich.com on 2012-05-10 17:48:25 EDT ---

(In reply to comment #13)

grubby will do what anaconda told it to do.

I assume you still have a wrong SYSFONT=True setting somewhere - probably /etc/sysconfig/i18n .

--- Additional comment from ipilcher@redhat.com on 2012-05-10 23:41:12 EDT ---

(In reply to comment #14)
> I assume you still have a wrong SYSFONT=True setting somewhere - probably
> /etc/sysconfig/i18n .

Spot on.  And that file was presumably created by anaconda.

Back to my hole now.

Thanks!

--- Additional comment from alen.siljak@gmail.com on 2012-05-11 12:14:59 EDT ---

Same here. F17 Beta installed from LiveUSB.

Applying solution at 
http://forums.fedoraforum.org/archive/index.php/t-277213.html
solves the issue.

--- Additional comment from clumens@redhat.com on 2012-05-11 12:55:15 EDT ---

This will be fixed in the next major release of Fedora.  If you need a fix in F17, at this point the bug needs to be made a blocker and discussed in the weekly meetings.

--- Additional comment from mads@kiilerich.com on 2012-05-11 13:16:52 EDT ---

I thought this already had been fixed?

--- Additional comment from horsley1953@gmail.com on 2012-05-11 13:22:58 EDT ---

So, we're dying of curiosity: Where did the True come from versus a valid font name?

--- Additional comment from clumens@redhat.com on 2012-05-11 15:22:54 EDT ---

http://git.fedorahosted.org/git/?p=anaconda.git;a=commit;h=92d596fb667b43024986d18a20e1eb50d7e7fd0e

--- Additional comment from michael.monreal+bugs@gmail.com on 2012-05-11 16:20:11 EDT ---

So for those of us with affected installations, what is the correct way to fix this, to get to the same state the fixed anaconda would get you after a F17 final installation?

--- Additional comment from mads@kiilerich.com on 2012-05-11 16:26:30 EDT ---

You should fix it manually. You helped testing anaconda and unfortunately it made a minor error. It is easy for you to fix and there is no way anaconda can fix it on your system now.

--- Additional comment from horsley1953@gmail.com on 2012-05-11 16:49:29 EDT ---

Just manually change True every place it is used as a font name in the
following 3 files:

/boot/grub2/grub.cfg
/etc/sysconfig/i18n
/etc/default/grub

Typically it was latarcyrheb-sun16 on most systems.

You could use latarcyrheb-sun32 if you want a bigger font for boot messages
and in console screens.

--- Additional comment from mads@kiilerich.com on 2012-05-12 07:08:53 EDT ---

*** Bug 821108 has been marked as a duplicate of this bug. ***

--- Additional comment from mads@kiilerich.com on 2012-05-12 07:10:21 EDT ---

I assume this would be a f17 blocker if it was something all users saw. What decides when it shows up?

--- Additional comment from sheldonh@starjuice.net on 2012-05-30 06:03:04 EDT ---

(In reply to comment #22)
> You should fix it manually. You helped testing anaconda and unfortunately it
> made a minor error. It is easy for you to fix and there is no way anaconda
> can fix it on your system now.

This happened to me with a fresh install of F17 Release, from the x86_64 Live CD. I'm surprised this wasn't deemed worth fixing; it's visually jarring.

--- Additional comment from gilboad@gmail.com on 2012-05-31 05:02:26 EDT ---

Reopening bug.
I hit it on two freshly installed machines. (The only two that didn't go through pre-upgrade).

- Gilboa

--- Additional comment from horsley1953@gmail.com on 2012-05-31 05:28:19 EDT ---

Yep. I did a fresh install of f17 from the DVD iso and got the same old True value in the grub.cfg file, the /etc/default/grub files and the /etc/sysconfig/i18n file.

--- Additional comment from gilboad@gmail.com on 2012-05-31 08:21:43 EDT ---

I should point out that at least in my case, as far as I could see it prevented dracut from booting.
Now, I'm not sure if the SYSFONT is the culprit (for the no-load), but the last dracut message was "bad font" and then console and when I fixed the problem and rebuilt the menu, the machine managed to boot (or semi-boot-and-then-blow, curtsy of 3.3.7-1.fc16/17 bug)

- Gilboa

--- Additional comment from gilboad@gmail.com on 2012-05-31 08:27:53 EDT ---

I should stress that I greatly doubt that its the cause of the no-boot. Most likely Anaconda left me with a completely busted grub + dracut.
... But in case someone else sees this, etc.

- Gilboa

--- Additional comment from clumens@redhat.com on 2012-05-31 10:10:33 EDT ---

And it will be fixed in the next major release of Fedora, hence the closed->rawhide status.

--- Additional comment from xset1980@hotmail.com on 2012-05-31 18:36:35 EDT ---

Fedora 17 Final release KDE spin, has the same bug, additional to bug 827187
Reopened, because the bug is present on F17 Final KDE spin

--- Additional comment from mads@kiilerich.com on 2012-05-31 19:27:26 EDT ---

Yes, the package maintainer has chosen to resolve Bug 799401 by fixing it in rawhide - not in f17.

*** This bug has been marked as a duplicate of bug 799401 ***

--- Additional comment from xset1980@hotmail.com on 2012-05-31 20:04:44 EDT ---

(In reply to comment #1)
> Yes, the package maintainer has chosen to resolve Bug 799401 by fixing it in
> rawhide - not in f17.
> 
> *** This bug has been marked as a duplicate of bug 799401 ***


But, F17 is final. So, explain me, HOW the manteiner want fix it on F17?, and, if he are no planned fix it on F17, what make the end user?. Thanks.
Comment 1 Chris Lumens 2012-05-31 22:53:31 EDT

*** This bug has been marked as a duplicate of bug 799401 ***

Note You need to log in before you can comment on or make changes to this bug.