This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 843201 - [abrt]: WARNING: at net/wireless/mlme.c:163 __cfg80211_send_disassoc+0xa4/0x140 [cfg80211]()
[abrt]: WARNING: at net/wireless/mlme.c:163 __cfg80211_send_disassoc+0xa4/0x1...
Status: CLOSED DUPLICATE of bug 862168
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
16
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: John W. Linville
Fedora Extras Quality Assurance
abrt_hash:ec0faf14be80b2cb1d52406ce2b...
:
: 858522 859445 860472 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-07-25 17:46 EDT by Andrei Gaponenko
Modified: 2012-10-05 08:57 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-10-05 08:57:33 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Andrei Gaponenko 2012-07-25 17:46:31 EDT
libreport version: 2.0.10
cmdline:        BOOT_IMAGE=/vmlinuz-3.4.4-4.fc16.x86_64 root=/dev/mapper/vg_t420-lv_f16 ro rd.md=0 rd.dm=0 KEYTABLE=us rd.lvm.lv=vg_t420/lv_f16 rd.lvm.lv=vg_t420/lv_swap SYSFONT=latarcyrheb-sun16 rd.luks=0 LANG=en_US.UTF-8

backtrace:
:[136328.872159] WARNING: at net/wireless/mlme.c:163 __cfg80211_send_disassoc+0xa4/0x140 [cfg80211]()
:[136328.872168] Hardware name: 4177CTO
:[136328.872173] Modules linked in: tcp_lp vfat fat usb_storage ppdev parport_pc lp parport fuse ipt_MASQUERADE iptable_nat nf_nat xt_CHECKSUM iptable_mangle bridge stp llc be2iscsi iscsi_boot_sysfs bnx2i cnic uio cxgb4i cxgb4 cxgb3i libcxgbi cxgb3 mdio ib_iser rdma_cm ib_cm iw_cm ib_sa ib_mad ib_core ib_addr iscsi_tcp libiscsi_tcp libiscsi scsi_transport_iscsi ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 nf_conntrack_ipv4 nf_defrag_ipv4 xt_state nf_conntrack ip6table_filter ip6_tables sha256_generic dm_crypt snd_hda_codec_hdmi snd_hda_codec_conexant snd_hda_intel arc4 snd_hda_codec snd_hwdep iwlwifi vhost_net tpm_tis mac80211 snd_seq snd_seq_device snd_pcm macvtap macvlan tun thinkpad_acpi snd_timer kvm_intel e1000e cfg80211 snd iTCO_wdt snd_page_alloc coretemp tpm i2c_i801 kvm iTCO_vendor_support rfkill soundcore tpm_bios microcode joydev nfsd lockd nfs_acl auth_rpcgss sunrpc uinput crc32c_intel ghash_clmulni_intel firewire_ohci firewire_core sdhci_pci sdhci crc_itu_t mmc_core wmi
:i915 drm_kms_helper drm i2c_algo_bit i2c_core video [last unloaded: scsi_wait_scan]
:[136328.872311] Pid: 23471, comm: kworker/u:2 Tainted: G        W    3.4.4-4.fc16.x86_64 #1
:[136328.872313] Call Trace:
:[136328.872321]  [<ffffffff8105807f>] warn_slowpath_common+0x7f/0xc0
:[136328.872325]  [<ffffffff810580da>] warn_slowpath_null+0x1a/0x20
:[136328.872333]  [<ffffffffa02fdc84>] __cfg80211_send_disassoc+0xa4/0x140 [cfg80211]
:[136328.872341]  [<ffffffffa02fdd67>] cfg80211_send_disassoc+0x47/0x70 [cfg80211]
:[136328.872358]  [<ffffffffa03ee304>] ieee80211_sta_rx_queued_mgmt+0x264/0x5c0 [mac80211]
:[136328.872368]  [<ffffffffa03c387b>] ieee80211_iface_work+0x25b/0x350 [mac80211]
:[136328.872378]  [<ffffffffa03c3620>] ? ieee80211_teardown_sdata+0xe0/0xe0 [mac80211]
:[136328.872382]  [<ffffffff81073cee>] process_one_work+0x11e/0x470
:[136328.872386]  [<ffffffff81074dcf>] worker_thread+0x15f/0x360
:[136328.872389]  [<ffffffff81074c70>] ? manage_workers+0x230/0x230
:[136328.872392]  [<ffffffff81079a83>] kthread+0x93/0xa0
:[136328.872397]  [<ffffffff816056e4>] kernel_thread_helper+0x4/0x10
:[136328.872401]  [<ffffffff810799f0>] ? kthread_freezable_should_stop+0x70/0x70
:[136328.872404]  [<ffffffff816056e0>] ? gs_change+0x13/0x13
Comment 1 John W. Linville 2012-07-26 15:07:49 EDT
Johannes, any interest in this?  What does that WARN_ON in __cfg80211_send_disassoc signify?
Comment 2 Johannes Berg 2012-07-26 15:18:54 EDT
Hmm. It means that we did a disassoc while we were associated, but the current_bss pointer didn't match. I guess we need to make that warning print out a lot more info to figure out what's going on.
Comment 3 Josh Boyer 2012-09-19 08:55:47 EDT
*** Bug 858522 has been marked as a duplicate of this bug. ***
Comment 4 Josh Boyer 2012-09-21 11:09:23 EDT
*** Bug 859445 has been marked as a duplicate of this bug. ***
Comment 5 Josh Boyer 2012-09-26 11:42:29 EDT
*** Bug 860472 has been marked as a duplicate of this bug. ***
Comment 6 Stanislaw Gruszka 2012-10-05 08:57:33 EDT

*** This bug has been marked as a duplicate of bug 862168 ***

Note You need to log in before you can comment on or make changes to this bug.