Bug 845782 - [abrt] crack-attack-1.1.14-20.fc17: Player_Start: Process /usr/bin/crack-attack was killed by signal 11 (SIGSEGV)
Summary: [abrt] crack-attack-1.1.14-20.fc17: Player_Start: Process /usr/bin/crack-atta...
Keywords:
Status: CLOSED ERRATA
Alias: None
Product: Fedora
Classification: Fedora
Component: libmikmod
Version: 17
Hardware: x86_64
OS: Unspecified
unspecified
unspecified
Target Milestone: ---
Assignee: Hans de Goede
QA Contact: Fedora Extras Quality Assurance
URL:
Whiteboard: abrt_hash:13af7148205ea0b8f57c2afdbe1...
: 845392 845707 845792 845998 846854 846967 847489 847904 847951 (view as bug list)
Depends On:
Blocks:
TreeView+ depends on / blocked
 
Reported: 2012-08-05 00:27 UTC by John Schneiderman
Modified: 2013-03-06 11:42 UTC (History)
11 users (show)

Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Clone Of:
Environment:
Last Closed: 2012-08-14 00:52:09 UTC
Type: ---


Attachments (Terms of Use)
File: backtrace (11.53 KB, text/plain)
2012-08-05 00:27 UTC, John Schneiderman
no flags Details
File: maps (34.73 KB, text/plain)
2012-08-05 00:27 UTC, John Schneiderman
no flags Details
File: dso_list (6.59 KB, text/plain)
2012-08-05 00:27 UTC, John Schneiderman
no flags Details

Description John Schneiderman 2012-08-05 00:27:49 UTC
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        /usr/bin/crack-attack --solo --easy --res 570 --name johnms
comment:        I started up the application, selected a solo game, and then it crashed.
crash_function: Player_Start
executable:     /usr/bin/crack-attack
kernel:         3.5.0-2.fc17.x86_64
pid:            11732
pwd:            /home/johnms
remote_result:  NOTFOUND
time:           Sat 04 Aug 2012 19:25:31 CDT
uid:            1000
username:       johnms
xsession_errors: 

backtrace:      Text file, 11810 bytes
dso_list:       Text file, 6747 bytes
maps:           Text file, 35561 bytes

build_ids:
:fc13956ed359736e6a145d384f112723fd62f20d
:8064812affe1df9a5ef65fc8cc7b5a95a07c1235
:f58f7f7a0f2c00780839246fd972e56e971e27d8
:72c9d0e973ad7f3b20f3883a199878da7f52c39f
:f69712fe393313f44607679e934bf5a67f39ec50
:faca16f15d87b83d2947a386e319b02f724dcbb5
:6086bff484a49cc8b80cb714d7e83a6391394800
:54a5cc118d928470da13565de8592b664a9868e0
:23d1440088fed14354e355ac2cbdba1f38fcf1a3
:d32cbeacfd9f41e3cd29b697dd111f44a2d9c127
:458118a56e4684bd51c51aee74e26a15161da7e3
:0339e448510e66ad611e6f5df08565db4fe4bc23
:b8bfc491895389962d926fdc99cbfbac571f2cf0
:5b4f3d35b4612be98f2bbb635b3eabf0ee7e437d
:f6173f877997ae18cbae81485926f36ca04ed246
:a8efbe1d263ad42afae74bc027eee88eaa754f55
:8f1ba572f27dfd702830fb5690824afb32c5f89f
:fd952473da735f9c0f50de231aa3d84d7855ef57
:b277af36744327e3d58eae76bcdaadcca71a28c6
:6088efab2ef3571c51fb041bb70b4ab626221ba4
:0e1267a4d81de05f053eeed7f2f61fb46cda9e7c
:6412f0f4d35ed15b1d728b05dcc0407b3e82fdf9
:02db68322dfc216e5403a39891cfcc2e1935f94a
:9d49f2f604fdc7a787f63c16cc08353956f2fd41
:7dc1c0c335214ab41492bd888c04d6f52819c961
:fa81176245f9e4370b3ffe6dd8db8a17646c70e9
:e91010b497ec024178c36f4365b21f668bada0ca
:602961bbc6a8c6f27b106252eefdd6d7ac18b8ed
:0aba7ec92cfe9227831c913e3ea7ccdc85c701e1
:edad49230923d07f38eaae337455a0d56f535f11
:f4c064df8745dff15466d705fb049138f9a5c949
:253afe744466fe7580bbb6040de6183dba9e2b02
:6ea05195018eb2e7efb545d3cbdec19ab3680ec4
:cef33edea3f2e21f5d52a9f9702019d4f9cfa350
:fb86c3a448f22bd68843d5aa0b35e74d20629e85
:8f7c190397d7c1f617e66f18f759714662b60367
:432673620d62333d4fd707b7bed13abe192f8b35
:516204cfc31148538d56b21e2f1b945ed50127d4
:b34676a7754197b3aa0ab7fba51844207d644e8d
:7b2764ec751ee57e9ba0827d2b16039549841179
:c4ec0971b2dcee71aaf8374975474054245fea00
:64b7a3f9dd8ef2158700ad4bb14255492c60fc5a
:d804f8ee47797da9213a92f00cd095ecada8d79f
:822e9b3523e8312240f41a25722d539bc77ed436
:b26a3acffde6a14576fe8b9bb2b73ff461f310b6
:ce246b3297de0d233ac2c5f9e50061e2b13a330c
:915e1b6a9e9b38aaf13a1d647d11751c3de5301b
:404cbecd24d186758ed474b345313da28b2990fa
:396fda5abd0de2132396c4a3e94f7a7173bc26e7
:7654433afd142a4699559f45f290cd0bcfb0f2d6
:3f0991d9a4679b6bdd8a78ab2d05ecf4cc995651
:e45258c755689bf1d66580f1c9a3f9d4d3f26235
:9dc7d977acebd2e8abf2d55bf2738ea2d89f7480
:6d13b4e8294bd29204ee566fd8ea1b67467d8ed5
:6e5d5649c704cd3a34cf145ccd2d08994f1e83ff
:7c35310fc506498c612d5d982ab03becc4b4817c
:6947e315f0765bf884ecc222d91945a1e2ed8767
:48c0fe9b8cd26b4d0b5bf1de0bc76da565bd7d27
:508cf66f72e70054a41215f80ed2385c6bb80030
:1dbad667ccf4b57aca057808b8a4a0871960b54f
:3c6dc46d7e711e68deb57ed5d6d980615c2f9ed4
:c24fd7404668fdbb57aec685a0f63cdd8a289d29
:67792c148d2b8f13f6732c9367e926c26d7376c5
:4b044fe80e4c1b69986abc4b160c303048005d4e
:d3b2370c611789a259d7f60137ab4568329dd838
:3bbeb82b3bc850005dc0f186e15b20b45df0cbaa
:c61e487cc8906c4f1bd85b39a4d751b414e423a0
:271a2d91cc3308783ff4a7ab45049f31aa42d8b7
:1309cbb736c7f597bc49f83e638fde856bfc0e11
:1d4df97fa6024b097b634a272447243c95c26d85
:8c083e0f61deb55917e5c7b193fe4d000a7375f1
:247132297f287226a24c12e683292f5c94013066
:af945724af42823d8f3ee175768dcb912e3c25a0
:726a299098b7695fc69d788f6b19468810c1ba6e
:41d17d4a5034f12665fbcbb2c80a4beca8bb0881
:5350b5972464f66f404861dc50225a114a2a5e7e

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/johnms/18

core_backtrace:
:8064812affe1df9a5ef65fc8cc7b5a95a07c1235 0x37c11 Player_Start libmikmod.so.3 -
:64b7a3f9dd8ef2158700ad4bb14255492c60fc5a 0xa5e9 - libSDL_mixer-1.2.so.0 -
:64b7a3f9dd8ef2158700ad4bb14255492c60fc5a 0xb086 Mix_FadeInMusicPos libSDL_mixer-1.2.so.0 -
:3c6dc46d7e711e68deb57ed5d6d980615c2f9ed4 0x2a648 - [exe] -
:3c6dc46d7e711e68deb57ed5d6d980615c2f9ed4 0x962f - [exe] -
:3c6dc46d7e711e68deb57ed5d6d980615c2f9ed4 0x7b98 - [exe] -

environ:
:XDG_VTNR=2
:XDG_SESSION_ID=18
:HOSTNAME=LinPavilion.LinGate.net
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:SHELL=/bin/bash
:TERM=dumb
:HISTSIZE=1000
:GNOME_KEYRING_CONTROL=/run/user/johnms/keyring-WF8BpX
:QT_GRAPHICSSYSTEM_CHECKED=1
:IMSETTINGS_MODULE=none
:USER=johnms
:USERNAME=johnms
:MAIL=/var/spool/mail/johnms
:PATH=/usr/lib64/ccache:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/johnms/.local/bin:/home/johnms/bin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/johnms
:XMODIFIERS=@im=none
:GNOME_KEYRING_PID=10316
:LANG=en_GB.utf8
:GDM_LANG=en_GB.utf8
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:XDG_SEAT=seat0
:HOME=/home/johnms
:SHLVL=1
:LOGNAME=johnms
:CVS_RSH=ssh
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-zGTo31iPgf,guid=6df580c88ac7677bf73086850000897e
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=2
:XDG_RUNTIME_DIR=/run/user/johnms
:DISPLAY=:0
:CCACHE_HASHDIR=
:XAUTHORITY=/var/run/gdm/auth-for-johnms-3nq7ZI/database
:_=/usr/bin/gnome-session
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/10318,unix/unix:/tmp/.ICE-unix/10318
:SSH_AUTH_SOCK=/run/user/johnms/keyring-WF8BpX/ssh
:GPG_AGENT_INFO=/run/user/johnms/keyring-WF8BpX/gpg:0:1
:LC_TIME=en_GB.utf8
:LC_NUMERIC=en_GB.utf8
:LC_MONETARY=en_GB.utf8
:LC_MEASUREMENT=en_GB.utf8
:GJS_DEBUG_OUTPUT=stderr
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/fedora-crack-attack.desktop
:GIO_LAUNCHED_DESKTOP_FILE_PID=11729

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 7792                 processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       7792                 7792                 signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:pipe:[1239221]
:pos:	0
:flags:	00
:1:pipe:[1239222]
:pos:	0
:flags:	01
:2:pipe:[1239223]
:pos:	0
:flags:	01
:3:socket:[1239229]
:pos:	0
:flags:	02004002
:4:/dev/dri/card0
:pos:	0
:flags:	0100002

smolt_data:
:
:
:General
:=================================
:UUID: 89e9df77-6bc1-4c0d-a91d-162d778828d4
:OS: Fedora release 17 (Beefy Miracle)
:Default run level: Unknown
:Language: en_GB.utf8
:Platform: x86_64
:BogoMIPS: 4787.86
:CPU Vendor: AuthenticAMD
:CPU Model: AMD Athlon(tm) 64 Processor 3700+
:CPU Stepping: 10
:CPU Family: 15
:CPU Model Num: 4
:Number of CPUs: 1
:CPU Speed: 2400
:System Memory: 995
:System Swap: 2015
:Vendor: Hewlett-Packard
:System: Pavilion zv5200 (DP523AV) F.34
:Form factor: Notebook
:Kernel: 3.5.0-2.fc17.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4318:218:4156:109) pci, snd_intel8x0, MULTIMEDIA_AUDIO, nForce3 Audio
:(4318:217:4156:109) pci, snd_intel8x0m, SIMPLE, nForce3 Audio
:(4318:221:0:0) pci, None, PCI/PCI, nForce3 PCI Bridge
:(4318:209:0:0) pci, agpgart-amd64, HOST/PCI, nForce3 Host Bridge
:(4318:212:4156:109) pci, nForce2_smbus, SERIAL, nForce3 SMBus
:(4318:208:4318:3200) pci, None, PCI/ISA, nForce3 LPC Bridge
:(5348:17184:4156:4852) pci, b43-pci-bridge, NETWORK, Broadcom 802.11b/g WLAN
:(4172:32806:4156:109) pci, firewire_ohci, FIREWIRE, TSB43AB21 IEEE-1394a-2000 Controller (PHY/Link)
:(4130:4352:0:0) pci, None, HOST/PCI, K8 [Athlon64/Opteron] HyperTransport Technology Configuration
:(4130:4355:0:0) pci, k8temp, HOST/PCI, K8 [Athlon64/Opteron] Miscellaneous Control
:(4130:4354:0:0) pci, None, HOST/PCI, K8 [Athlon64/Opteron] DRAM Controller
:(4172:44116:4156:109) pci, yenta_cardbus, PCI/CARDBUS, PCI1620 PC Card Controller
:(4332:33081:4332:33081) pci, 8139too, ETHERNET, RTL-8139/8139C/8139C+
:(4172:33281:4156:109) pci, None, BASE, PCI1620 Firmware Loading Function
:(4318:215:4318:3200) pci, ohci_hcd, USB, nForce3 USB 1.1
:(4318:215:4318:3200) pci, ohci_hcd, USB, nForce3 USB 1.1
:(4318:216:4318:3200) pci, ehci_hcd, USB, nForce3 USB 2.0
:(4172:44116:4156:109) pci, yenta_cardbus, PCI/CARDBUS, PCI1620 PC Card Controller
:(4318:377:4156:109) pci, nouveau, VIDEO, NV17 [GeForce4 440 Go 64M]
:(4318:213:4318:3200) pci, pata_amd, STORAGE, nForce3 IDE
:(4130:4353:0:0) pci, None, HOST/PCI, K8 [Athlon64/Opteron] Address Map
:(4318:210:0:0) pci, None, PCI/PCI, nForce3 AGP Bridge
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/vg_linpavilion-lv_root / ext4 4096 4096 9317328 6391391 5924447 2334720 2040559 2040559
:/dev/sda1 /boot ext4 1024 1024 508644 446810 421210 128016 127670 127670
:/dev/mapper/vg_linpavilion-lv_home /home ext4 4096 4096 4645365 3111811 2878749 1166880 1120842 1120842
:

var_log_messages:
:Aug  4 15:44:39 LinPavilion yum[3376]: Installed: crack-attack-1.1.14-20.fc17.x86_64
:Aug  4 19:25:32 LinPavilion abrt[11736]: Saved core dump of pid 11732 (/usr/bin/crack-attack) to /var/spool/abrt/ccpp-2012-08-04-19:25:31-11732 (27291648 bytes)

Comment 1 John Schneiderman 2012-08-05 00:27:52 UTC
Created attachment 602299 [details]
File: backtrace

Comment 2 John Schneiderman 2012-08-05 00:27:54 UTC
Created attachment 602300 [details]
File: maps

Comment 3 John Schneiderman 2012-08-05 00:27:55 UTC
Created attachment 602301 [details]
File: dso_list

Comment 4 Hans de Goede 2012-08-05 09:43:02 UTC
Thanks for the bugreport, I've managed to reproduce and fix it, an updated libmikmod package fixing this is on its way.

Note the actual crash is happening in libmikmod -> changing component.

Comment 5 Fedora Update System 2012-08-05 11:12:54 UTC
libmikmod-3.2.0-17.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/libmikmod-3.2.0-17.fc17

Comment 6 Fedora Update System 2012-08-05 21:28:24 UTC
Package libmikmod-3.2.0-17.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing libmikmod-3.2.0-17.fc17'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-11510/libmikmod-3.2.0-17.fc17
then log in and leave karma (feedback).

Comment 7 Nils Philippsen 2012-08-06 14:29:15 UTC
*** Bug 845792 has been marked as a duplicate of this bug. ***

Comment 8 Randall Bingham 2012-08-06 23:05:27 UTC
(In reply to comment #6)
> Package libmikmod-3.2.0-17.fc17:
> * should fix your issue,
> * was pushed to the Fedora 17 testing repository,
> * should be available at your local mirror within two days.
> Update it with:
> # su -c 'yum update --enablerepo=updates-testing libmikmod-3.2.0-17.fc17'
> as soon as you are able to.
> Please go to the following url:
> https://admin.fedoraproject.org/updates/FEDORA-2012-11510/libmikmod-3.2.0-17.
> fc17
> then log in and leave karma (feedback).

I tried this fix and the game still crashed. This time the game loaded before crashing, where as before it would crash before loading.

Comment 9 Hans de Goede 2012-08-07 07:39:17 UTC
(In reply to comment #8)
> I tried this fix and the game still crashed. This time the game loaded
> before crashing, where as before it would crash before loading.

I assume that with this game you mean tuxracer? I've just tried extreme tuxracer myself and it seems to trigger a bug in mesa (our opengl implementation).

Can you please try again and let abrt file a bug for the crash you are seeing?

Comment 10 Randall Bingham 2012-08-07 12:24:32 UTC
(In reply to comment #9)
> (In reply to comment #8)
> > I tried this fix and the game still crashed. This time the game loaded
> > before crashing, where as before it would crash before loading.
> 
> I assume that with this game you mean tuxracer? I've just tried extreme
> tuxracer myself and it seems to trigger a bug in mesa (our opengl
> implementation).
> 
> Can you please try again and let abrt file a bug for the crash you are
> seeing?

I did submit a report yesterday when it crashed if I remember correctly. This morning I tried it and was able to play 3 games without any problems. Hopefully it is fixed. 
Yes the game was ExtremeTux Racer.

Comment 11 Hans de Goede 2012-08-09 08:57:41 UTC
*** Bug 846854 has been marked as a duplicate of this bug. ***

Comment 12 Hans de Goede 2012-08-12 08:36:40 UTC
*** Bug 847489 has been marked as a duplicate of this bug. ***

Comment 13 Hans de Goede 2012-08-12 08:36:45 UTC
*** Bug 845998 has been marked as a duplicate of this bug. ***

Comment 14 happymcc 2012-08-12 10:10:00 UTC
Thanks guys I don't really play games but one or two and this is my favorite .
su -c 'yum update --enablerepo=updates-testing libmikmod-3.2.0-17.fc17'
This fixed my problem . This was my first time reporting a bug and again
THANK YOU ALL 
Keith

Comment 15 Gwyn Ciesla 2012-08-12 22:20:41 UTC
*** Bug 845707 has been marked as a duplicate of this bug. ***

Comment 16 Fedora Update System 2012-08-14 00:52:09 UTC
libmikmod-3.2.0-17.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Comment 17 Andrea Musuruane 2012-08-14 08:35:58 UTC
*** Bug 847951 has been marked as a duplicate of this bug. ***

Comment 18 Hans de Goede 2012-08-14 14:51:29 UTC
*** Bug 847904 has been marked as a duplicate of this bug. ***

Comment 19 Brad Hubbard 2012-08-21 10:37:07 UTC
*** Bug 845392 has been marked as a duplicate of this bug. ***

Comment 20 Hans de Goede 2013-03-06 11:42:11 UTC
*** Bug 846967 has been marked as a duplicate of this bug. ***


Note You need to log in before you can comment on or make changes to this bug.