Bug 852146 - [abrt] owncloud-client-1.0.5-4.fc17: XFreeColormap: Process /usr/bin/owncloud was killed by signal 11 (SIGSEGV)
[abrt] owncloud-client-1.0.5-4.fc17: XFreeColormap: Process /usr/bin/owncloud...
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: mirall (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Joseph Marrero
Fedora Extras Quality Assurance
abrt_hash:eb641673be81ca4c4d13d3c0776...
:
: 853577 858169 858688 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-08-27 13:32 EDT by graf.drakul
Modified: 2012-12-29 01:27 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-29 01:27:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: build_ids (4.84 KB, text/plain)
2012-08-27 13:32 EDT, graf.drakul
no flags Details
File: maps (59.28 KB, text/plain)
2012-08-27 13:32 EDT, graf.drakul
no flags Details
File: backtrace (36.41 KB, text/plain)
2012-08-27 13:32 EDT, graf.drakul
no flags Details

  None (edit)
Description graf.drakul 2012-08-27 13:32:01 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        owncloud
comment:        error occurs after start 
crash_function: XFreeColormap
executable:     /usr/bin/owncloud
kernel:         3.5.2-3.fc17.x86_64
pid:            1777
pwd:            /home/martin
time:           Mo 27 Aug 2012 12:02:05 CEST
uid:            1000

backtrace:      Text file, 37280 bytes
build_ids:      Text file, 4961 bytes
maps:           Text file, 60698 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/martin/2

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=2
:HOSTNAME=martin.laptop
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:SHELL=/bin/bash
:TERM=dumb
:HISTSIZE=1000
:GNOME_KEYRING_CONTROL=/run/user/martin/keyring-GaQ74m
:QT_GRAPHICSSYSTEM_CHECKED=1
:IMSETTINGS_MODULE=none
:USER=martin
:USERNAME=martin
:MAIL=/var/spool/mail/martin
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/martin/.local/bin:/home/martin/bin
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/martin
:XMODIFIERS=@im=none
:GNOME_KEYRING_PID=947
:LANG=de_DE.utf8
:GDM_LANG=de_DE.utf8
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:XDG_SEAT=seat0
:HOME=/home/martin
:SHLVL=1
:LOGNAME=martin
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-JqiHzKF0Ry,guid=5526f37bb53d59956f181bcf00000027
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/martin
:DISPLAY=:0
:XAUTHORITY=/var/run/gdm/auth-for-martin-5597CG/database
:_=/usr/bin/gnome-session
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/951,unix/unix:/tmp/.ICE-unix/951
:GPG_AGENT_INFO=/run/user/martin/keyring-GaQ74m/gpg:0:1
:SSH_AUTH_SOCK=/run/user/martin/keyring-GaQ74m/ssh
:GJS_DEBUG_OUTPUT=stderr
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/owncloud-client.desktop
:GIO_LAUNCHED_DESKTOP_FILE_PID=1777

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 30640                processes 
:Max open files            1024                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       30640                30640                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:pos:	0
:flags:	0100000
:1:/home/martin/.xsession-errors
:pos:	20913
:flags:	0102002
:2:/home/martin/.xsession-errors
:pos:	20913
:flags:	0102002
:3:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:4:pipe:[32059]
:pos:	0
:flags:	02004000
:5:pipe:[32059]
:pos:	0
:flags:	02004001
:6:anon_inode:[eventfd]
:pos:	0
:flags:	02004002
:7:socket:[32063]
:pos:	0
:flags:	02004002
:8:socket:[32067]
:pos:	0
:flags:	02004002

smolt_data:
:
:
:Allgemein
:=================================
:UUID: db96f9c6-0b22-4c5d-9cee-72f944d0c2c5
:OS: Fedora release 17 (Beefy Miracle)
:Standard-Runlevel: Unknown
:Sprache: de_DE.utf8
:Plattform: x86_64
:BogoMIPS: 4389.08
:CPU-Anbieter: GenuineIntel
:CPU-Modell: Intel(R) Core(TM)2 Duo CPU     T6670  @ 2.20GHz
:CPU-Stepping: 10
:CPU Familie: 6
:CPU-Modellnummer: 23
:Anzahl der CPUs: 2
:CPU-Geschwindigkeit: 2201
:Systemspeicher: 3851
:System-Swap: 7998
:Anbieter: LENOVO
:System: 744333G ThinkPad R400
:Form-Faktor: Notebook
:Kernel: 3.5.2-3.fc17.x86_64
:SELinux aktiviert: 0
:SELinux-Richtlinie: targeted
:SELinux erzwingen: Unknown
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Geräte
:=================================
:(32902:10816:6058:8416) pci, agpgart-intel, HOST/PCI, Mobile 4 Series Chipset Memory Controller Hub
:(32902:10544:6058:8441) pci, i801_smbus, SERIAL, 82801I (ICH9 Family) SMBus Controller
:(32902:10537:6058:8440) pci, ahci, STORAGE, ICH9M/M-E SATA AHCI Controller
:(32902:10521:6058:8438) pci, None, PCI/ISA, ICH9M LPC Interface Controller
:(32902:4287:6058:8430) pci, e1000e, ETHERNET, 82567LF Gigabit Network Connection
:(32902:9288:6058:8436) pci, None, PCI/PCI, 82801 Mobile PCI Bridge
:(32902:10566:6058:8435) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 4
:(32902:10549:6058:8432) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #2
:(32902:10548:6058:8432) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #1
:(32902:10553:6058:8432) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #6
:(32902:10550:6058:8432) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #3
:(32902:10554:6058:8433) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #1
:(32902:10556:6058:8433) pci, ehci_hcd, USB, 82801I (ICH9 Family) USB2 EHCI Controller #2
:(32902:16951:32902:4625) pci, iwlwifi, NETWORK, WiFi Link 5100 AGN
:(32902:10818:6058:8420) pci, i915, VIDEO, Mobile 4 Series Chipset Integrated Graphics Controller
:(32902:10819:6058:8420) pci, None, VIDEO, Mobile 4 Series Chipset Integrated Graphics Controller
:(32902:10560:6058:8435) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 1
:(32902:10562:6058:8435) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 2
:(32902:10820:6058:8422) pci, mei, SIMPLE, Mobile 4 Series Chipset MEI Controller
:(32902:10568:6058:8435) pci, pcieport, PCI/PCI, 82801I (ICH9 Family) PCI Express Port 5
:(32902:10558:6058:8434) pci, snd_hda_intel, MULTIMEDIA, 82801I (ICH9 Family) HD Audio Controller
:(32902:10551:6058:8432) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #4
:(32902:10552:6058:8432) pci, uhci_hcd, USB, 82801I (ICH9 Family) USB UHCI Controller #5
:(4480:1426:6058:8394) pci, r592, BASE, ThinkPad T61
:(4480:2130:6058:8395) pci, None, BASE, xD-Picture Card Controller
:(4480:1142:6058:8390) pci, yenta_cardbus, PCI/CARDBUS, RL5c476 II
:(4480:2098:6058:8391) pci, firewire_ohci, FIREWIRE, R5C832 IEEE 1394 Controller
:(4480:2082:6058:8392) pci, sdhci-pci, BASE, R5C822 SD/SDIO/MMC/MS/MSPro Host Adapter
:
:
:Dateisysteminformationen
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/sda3 / ext4 4096 4096 14229323 10949180 10804639 3620864 3258324 3258324
:/dev/mapper/luks-8a645fe9-48b3-4c4a-ab8b-38832120a159 /home ext4 4096 4096 31112687 15323483 13743042 7905280 7794598 7794598
:
Comment 1 graf.drakul 2012-08-27 13:32:06 EDT
Created attachment 607308 [details]
File: build_ids
Comment 2 graf.drakul 2012-08-27 13:32:09 EDT
Created attachment 607309 [details]
File: maps
Comment 3 graf.drakul 2012-08-27 13:32:12 EDT
Created attachment 607310 [details]
File: backtrace
Comment 4 Joseph Marrero 2012-08-27 13:51:02 EDT
owncloud-client runs? you can sync your files or wont open at all?
Comment 5 graf.drakul 2012-09-01 14:57:52 EDT
i can sync but i need to start several times owncloud aslong this messages not appears and then i am able to sync files in both directions....
Comment 6 Joseph Marrero 2012-09-03 02:14:03 EDT
Please test it seems to solve the problem on my machine (x86_64) and virtual Box i686 box

http://koji.fedoraproject.org/koji/buildinfo?buildID=351736

if work out please leave positive feedback here: 
https://admin.fedoraproject.org/updates/mirall-1.0.5-5.fc17
Comment 7 Joseph Marrero 2012-09-03 19:40:24 EDT
The updates are in the updates-testing repo.

Please test the latest update on owncloud-client and/or mirall
Use the following commands depending on which sync client are you using.

If you are using owncloud-client:
yum --enablerepo=updates-testing install mirall-common owncloud-client


If you are using mirall:
yum --enablerepo=updates-testing install mirall-common mirall

-- 
Joseph
Comment 8 Joseph Marrero 2012-09-15 13:36:11 EDT
*** Bug 853577 has been marked as a duplicate of this bug. ***
Comment 9 Joseph Marrero 2012-09-15 13:41:27 EDT
The problem is upstream, it has been notified, I am also looking for a solution.
Comment 10 graf.drakul 2012-09-16 18:25:45 EDT
since the update i haven't any problem so far so from my side this can be closed
Comment 11 Joseph Marrero 2012-09-24 09:49:38 EDT
*** Bug 858169 has been marked as a duplicate of this bug. ***
Comment 12 Joseph Marrero 2012-09-24 09:50:34 EDT
*** Bug 858688 has been marked as a duplicate of this bug. ***
Comment 13 Boricua 2012-10-10 05:00:36 EDT
ownCloud is set to autostart at loggin and it crashed.

backtrace_rating: 4
Package: owncloud-client-1.0.5-5.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 14 Boricua 2012-10-12 12:51:55 EDT
Just started the computer.

backtrace_rating: 4
Package: mirall-1.0.5-5.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 15 Joseph Marrero 2012-10-14 03:22:49 EDT
New Version of mirall/owncloudclient and owncloud-csync has been released, currently I am testing it in my machine, In a about two days it should be in the testing repositories. 

SO far all sagfault errors have been corrected, the bad news is that the new sync client only works with owncloud server 4.5 and up.

So if you are in a owncloud server < 4.5 you should stick with the current owncloud client until the 1.1 version works with the older servers or you upgrade to 4.5 owncloud.
Comment 16 Fedora Update System 2012-10-14 19:10:45 EDT
mirall-1.1.0-1.fc17,owncloud-csync-0.60.0-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/mirall-1.1.0-1.fc17,owncloud-csync-0.60.0-1.fc17
Comment 17 Fedora Update System 2012-10-14 19:17:08 EDT
mirall-1.1.0-1.fc18,owncloud-csync-0.60.0-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/mirall-1.1.0-1.fc18,owncloud-csync-0.60.0-1.fc18
Comment 18 Fedora Update System 2012-10-15 13:35:34 EDT
Package mirall-1.1.0-1.fc18, owncloud-csync-0.60.0-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing mirall-1.1.0-1.fc18 owncloud-csync-0.60.0-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16122/mirall-1.1.0-1.fc18,owncloud-csync-0.60.0-1.fc18
then log in and leave karma (feedback).
Comment 19 Joseph Marrero 2012-10-19 09:01:06 EDT
New version released upstream you should have it by Sunday/monday in the testing repos.

> The most important changes:
>
> * [GUI] Allow changing folder name in single folder mode
> * [GUI] Windows: Add license to installer
> * [GUI] owncloud ?logwindow will bring up the log window in an already running instance
> * [Fixes] Make sure SSL errors are always handled
> * [Fixes] Allow special characters in folder alias
> * [Fixes] Proper workaround for Menu bug in Ubuntu
> * [Fixes] csync: Fix improper memory cleanup which could cause memory leaks and crashes
> * [Fixes] csync: Fix memory leak
> * [Fixes] csync: Allow single quote (?) in file names
> * [Fixes] csync: Remove stray temporary files

I hope this fixes the new crashes
Comment 20 Fedora Update System 2012-10-19 22:35:11 EDT
owncloud-csync-0.60.1-1.fc17,mirall-1.1.1-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/owncloud-csync-0.60.1-1.fc17,mirall-1.1.1-1.fc17
Comment 21 Fedora Update System 2012-10-19 22:37:35 EDT
owncloud-csync-0.60.1-1.fc18,mirall-1.1.1-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/owncloud-csync-0.60.1-1.fc18,mirall-1.1.1-1.fc18
Comment 22 Shamar Droghetti 2012-11-08 12:14:01 EST
1) Open the client
2) Client crash


backtrace_rating: 4
Package: owncloud-client-1.1.1-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 23 Fedora Update System 2012-12-08 22:45:45 EST
owncloud-csync-0.60.3-1.fc18,mirall-1.1.3-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/owncloud-csync-0.60.3-1.fc18,mirall-1.1.3-1.fc18
Comment 24 Fedora Update System 2012-12-20 21:51:38 EST
owncloud-csync-0.60.4-1.fc17,mirall-1.1.4-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/owncloud-csync-0.60.4-1.fc17,mirall-1.1.4-1.fc17
Comment 25 Fedora Update System 2012-12-29 01:27:58 EST
owncloud-csync-0.60.4-1.fc17, mirall-1.1.4-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.