Bug 855658 - [abrt] ModemManager-0.6.0.0-1.fc17: supports_port: Process /usr/sbin/modem-manager was killed by signal 11 (SIGSEGV)
[abrt] ModemManager-0.6.0.0-1.fc17: supports_port: Process /usr/sbin/modem-ma...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: ModemManager (Show other bugs)
17
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Dan Williams
Fedora Extras Quality Assurance
abrt_hash:1ade39fa2192ff867a7f64d66eb...
:
: 872126 890379 894651 894652 909132 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-09 12:17 EDT by glihaenator
Modified: 2013-07-25 20:29 EDT (History)
10 users (show)

See Also:
Fixed In Version: ModemManager-0.6.2.0-1.fc17
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-08 23:31:45 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (1.62 KB, text/plain)
2012-09-09 12:17 EDT, glihaenator
no flags Details
File: environ (97 bytes, text/plain)
2012-09-09 12:17 EDT, glihaenator
no flags Details
File: limits (1.29 KB, text/plain)
2012-09-09 12:17 EDT, glihaenator
no flags Details
File: backtrace (15.68 KB, text/plain)
2012-09-09 12:17 EDT, glihaenator
no flags Details
File: cgroup (154 bytes, text/plain)
2012-09-09 12:17 EDT, glihaenator
no flags Details
File: maps (17.34 KB, text/plain)
2012-09-09 12:17 EDT, glihaenator
no flags Details
File: dso_list (3.74 KB, text/plain)
2012-09-09 12:17 EDT, glihaenator
no flags Details
File: var_log_messages (9.32 KB, text/plain)
2012-09-09 12:17 EDT, glihaenator
no flags Details
File: open_fds (1.06 KB, text/plain)
2012-09-09 12:17 EDT, glihaenator
no flags Details

  None (edit)
Description glihaenator 2012-09-09 12:17:04 EDT
Version-Release number of selected component:
ModemManager-0.6.0.0-1.fc17

Additional info:
libreport version: 2.0.13
abrt_version:   2.0.12
backtrace_rating: 4
cmdline:        /usr/sbin/modem-manager
crash_function: supports_port
kernel:         3.5.3-1.fc17.x86_64

truncated backtrace:
:Thread no. 1 (4 frames)
: #0 supports_port at mm-plugin-moto-c.c
: #2 try_supports_port at mm-manager.c
: #3 mm_plugin_base_supports_task_complete at mm-plugin-base.c
: #8 emit_probe_result at mm-plugin-base.c
Comment 1 glihaenator 2012-09-09 12:17:09 EDT
Created attachment 611250 [details]
File: core_backtrace
Comment 2 glihaenator 2012-09-09 12:17:11 EDT
Created attachment 611251 [details]
File: environ
Comment 3 glihaenator 2012-09-09 12:17:13 EDT
Created attachment 611252 [details]
File: limits
Comment 4 glihaenator 2012-09-09 12:17:16 EDT
Created attachment 611253 [details]
File: backtrace
Comment 5 glihaenator 2012-09-09 12:17:18 EDT
Created attachment 611254 [details]
File: cgroup
Comment 6 glihaenator 2012-09-09 12:17:21 EDT
Created attachment 611255 [details]
File: maps
Comment 7 glihaenator 2012-09-09 12:17:23 EDT
Created attachment 611256 [details]
File: dso_list
Comment 8 glihaenator 2012-09-09 12:17:26 EDT
Created attachment 611257 [details]
File: var_log_messages
Comment 9 glihaenator 2012-09-09 12:17:28 EDT
Created attachment 611258 [details]
File: open_fds
Comment 10 Andy Lawrence 2012-09-14 15:36:57 EDT
Plugged in a Samgsung Intensity (SCH-U450) via USB for charging.

backtrace_rating: 4
Package: ModemManager-0.6.0.0-1.fc17
OS Release: Fedora release 17 (Beefy Miracle)
Comment 11 Gianluca Sforna 2012-10-20 17:36:32 EDT
I just attached a USB 3G modem dongle and before I can use it the crahs was reported.
This is an Huawei E156G, lsusb recognize it as:
Bus 001 Device 005: ID 12d1:1003 Huawei Technologies Co., Ltd. E220 HSDPA Modem / E230/E270 HSDPA/HSUPA Modem


backtrace_rating: 4
Package: ModemManager-0.6.0.0-1.fc17
Architecture: i686
OS Release: Fedora release 17 (Beefy Miracle)
Comment 12 Dan Williams 2013-05-28 18:59:58 EDT
*** Bug 872126 has been marked as a duplicate of this bug. ***
Comment 13 Dan Williams 2013-05-28 19:00:18 EDT
*** Bug 894651 has been marked as a duplicate of this bug. ***
Comment 14 Dan Williams 2013-05-28 19:00:23 EDT
*** Bug 894652 has been marked as a duplicate of this bug. ***
Comment 15 Dan Williams 2013-05-28 19:00:36 EDT
*** Bug 890379 has been marked as a duplicate of this bug. ***
Comment 16 Dan Williams 2013-05-28 19:00:41 EDT
*** Bug 909132 has been marked as a duplicate of this bug. ***
Comment 17 Fedora Update System 2013-05-28 20:35:18 EDT
ModemManager-0.6.0.0-4.git20130528.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ModemManager-0.6.0.0-4.git20130528.fc17
Comment 18 Fedora Update System 2013-05-28 20:35:50 EDT
ModemManager-0.6.0.0-4.git20130528.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ModemManager-0.6.0.0-4.git20130528.fc18
Comment 19 Fedora Update System 2013-05-28 20:37:41 EDT
ModemManager-0.6.0.0-4.git20130528.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/ModemManager-0.6.0.0-4.git20130528.fc19
Comment 20 Fedora Update System 2013-05-29 23:03:48 EDT
Package ModemManager-0.6.0.0-4.git20130528.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing ModemManager-0.6.0.0-4.git20130528.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-9621/ModemManager-0.6.0.0-4.git20130528.fc18
then log in and leave karma (feedback).
Comment 21 Fedora Update System 2013-05-31 17:13:16 EDT
ModemManager-0.6.2.0-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/ModemManager-0.6.2.0-1.fc19
Comment 22 Fedora Update System 2013-05-31 17:14:40 EDT
ModemManager-0.6.2.0-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/ModemManager-0.6.2.0-1.fc18
Comment 23 Fedora Update System 2013-05-31 17:14:44 EDT
ModemManager-0.6.2.0-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/ModemManager-0.6.2.0-1.fc17
Comment 24 Fedora Update System 2013-06-08 23:31:45 EDT
ModemManager-0.6.2.0-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 25 Richard Shaw 2013-07-05 16:55:54 EDT
I would say this hasn't been fixed... Just happened on my fully updated f18 box. Even worse, it was trying to interrogate my ham radio and caused it to transmit sporadically, which is BAD.

How do I stop this? I don't have any modems connected to my computer.
Comment 26 Fedora Update System 2013-07-25 20:29:36 EDT
ModemManager-0.6.2.0-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 27 Fedora Update System 2013-07-25 20:29:58 EDT
ModemManager-0.6.2.0-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.