Bug 856863 - cfg80211_mlme_down while suspended
cfg80211_mlme_down while suspended
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
17
x86_64 Linux
unspecified Severity unspecified
: ---
: ---
Assigned To: Stanislaw Gruszka
Fedora Extras Quality Assurance
:
: 861875 871805 891019 896754 901860 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-12 21:58 EDT by Robert Hancock
Modified: 2013-03-21 20:13 EDT (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-03-16 21:05:14 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
cfg80211_mac80211_disconnect_on_suspend.patch (6.83 KB, text/plain)
2013-03-12 11:49 EDT, Stanislaw Gruszka
no flags Details
cfg80211_mac80211_disconnect_on_suspend_v3.8.patch (5.24 KB, text/plain)
2013-03-12 11:50 EDT, Stanislaw Gruszka
no flags Details

  None (edit)
Description Robert Hancock 2012-09-12 21:58:23 EDT
Description of problem:
Sporadically (maybe when disconnecting or changing wireless networks) I get this splat in dmesg with this wireless card:

02:00.0 Network controller: Ralink corp. Device 5390

Version-Release number of selected component (if applicable):
3.5.3-1.fc17

How reproducible:
Not on demand, unsure how to reproduce

Steps to Reproduce:
1. ?
2.
3.
  
Actual results:

Tainted by VirtualBox (I think) but I doubt it's related.

[24385.037427] ------------[ cut here ]------------
[24385.037447] WARNING: at net/mac80211/driver-ops.h:12 ieee80211_bss_info_change_notify+0x2b2/0x2c0 [mac80211]()
[24385.037448] Hardware name: K54C
[24385.037450] wlan0:  Failed check-sdata-in-driver check, flags: 0x4
[24385.037451] Modules linked in: nfnetlink_log nfnetlink vfat fat usb_storage tun fuse bnep lockd sunrpc bluetooth vboxpci(O) vboxnetadp(O) vboxnetflt(O) vboxdrv(O) nf_conntrack_ipv4 nf_defrag_ipv4 ip6t_REJECT nf_conntrack_ipv6 nf_defrag_ipv6 xt_state nf_conntrack ip6table_filter ip6_tables arc4 rt2800pci rt2800lib rt2x00pci rt2x00lib eeprom_93cx6 snd_hda_codec_hdmi mac80211 coretemp kvm_intel kvm snd_hda_codec_realtek cfg80211 uvcvideo atl1c videobuf2_vmalloc videobuf2_memops i2c_i801 snd_hda_intel crc_ccitt videobuf2_core videodev media mei lpc_ich mfd_core snd_hda_codec snd_hwdep snd_pcm microcode snd_page_alloc asus_nb_wmi serio_raw snd_timer snd soundcore asus_wmi sparse_keymap rfkill binfmt_misc uinput xts gf128mul dm_crypt crc32c_intel ghash_clmulni_intel wmi i915 video i2c_algo_bit drm_kms_helper drm i2c_core [last unloaded: scsi_wait_scan]
[24385.037497] Pid: 901, comm: NetworkManager Tainted: G         C O 3.5.3-1.fc17.x86_64 #1
[24385.037499] Call Trace:
[24385.037506]  [<ffffffff810584bf>] warn_slowpath_common+0x7f/0xc0
[24385.037510]  [<ffffffff810585b6>] warn_slowpath_fmt+0x46/0x50
[24385.037518]  [<ffffffffa03258d2>] ieee80211_bss_info_change_notify+0x2b2/0x2c0 [mac80211]
[24385.037526]  [<ffffffffa03259c3>] ieee80211_ifa_changed+0xe3/0x100 [mac80211]
[24385.037530]  [<ffffffff816108ad>] notifier_call_chain+0x4d/0x70
[24385.037533]  [<ffffffff81081748>] __blocking_notifier_call_chain+0x58/0x80
[24385.037536]  [<ffffffff81081786>] blocking_notifier_call_chain+0x16/0x20
[24385.037539]  [<ffffffff815664fc>] __inet_del_ifa+0x15c/0x2b0
[24385.037541]  [<ffffffff8156677a>] inet_rtm_deladdr+0x10a/0x160
[24385.037544]  [<ffffffff8150f084>] rtnetlink_rcv_msg+0x114/0x2f0
[24385.037547]  [<ffffffff8150ef70>] ? __rtnl_unlock+0x20/0x20
[24385.037550]  [<ffffffff81528191>] netlink_rcv_skb+0xa1/0xb0
[24385.037552]  [<ffffffff8150c3b5>] rtnetlink_rcv+0x25/0x40
[24385.037554]  [<ffffffff81527b0d>] netlink_unicast+0x19d/0x220
[24385.037557]  [<ffffffff81527e82>] netlink_sendmsg+0x2f2/0x370
[24385.037560]  [<ffffffff814e7e28>] sock_sendmsg+0xf8/0x130
[24385.037563]  [<ffffffff814e7c9d>] ? sock_recvmsg+0xfd/0x130
[24385.037567]  [<ffffffff81182d35>] ? mem_cgroup_bad_page_check+0x25/0x30
[24385.037571]  [<ffffffff8112cded>] ? free_pages_prepare+0x8d/0x130
[24385.037574]  [<ffffffff814e8ffa>] ? move_addr_to_kernel+0x5a/0xc0
[24385.037576]  [<ffffffff814f5346>] ? verify_iovec+0x56/0xd0
[24385.037579]  [<ffffffff814e826c>] __sys_sendmsg+0x3ac/0x3c0
[24385.037583]  [<ffffffff81063a7d>] ? __do_proc_dointvec.isra.5+0x2ad/0x360
[24385.037586]  [<ffffffff811c514b>] ? fsnotify+0x24b/0x340
[24385.037589]  [<ffffffff81173479>] ? kfree+0x49/0x160
[24385.037592]  [<ffffffff811a4d86>] ? mntput_no_expire+0x46/0x130
[24385.037595]  [<ffffffff814e9f39>] sys_sendmsg+0x49/0x90
[24385.037599]  [<ffffffff81614ae9>] system_call_fastpath+0x16/0x1b
[24385.037600] ---[ end trace 7efb1035c2db697e ]---


Expected results:


Additional info:
Comment 1 Stanislaw Gruszka 2012-10-22 07:00:31 EDT
*** Bug 861875 has been marked as a duplicate of this bug. ***
Comment 2 Stanislaw Gruszka 2012-10-22 07:04:40 EDT
I posed fix for this problem here:
http://marc.info/?l=linux-wireless&m=135039092111904&w=2

Josh, please apply it to fedora.
Comment 3 Stanislaw Gruszka 2012-10-22 08:26:44 EDT
I lunched kernel build with above patch here:
http://koji.fedoraproject.org/koji/taskinfo?taskID=4614857
Comment 4 Josh Boyer 2012-10-22 08:35:02 EDT
Applied F16-F18.
Comment 5 Fedora Update System 2012-10-22 14:39:16 EDT
kernel-3.6.3-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.6.3-1.fc17
Comment 6 Robert Hancock 2012-10-22 15:18:59 EDT
If I understand the patch correctly it is only affecting USB devices. This warning occurred with a PCI-E RT5390 device.
Comment 7 Robert Hancock 2012-10-22 15:21:19 EDT
It also occurred on an AP change, not on resume.
Comment 8 Fedora Update System 2012-10-22 21:54:33 EDT
Package kernel-3.6.3-1.fc17:
* should fix your issue,
* was pushed to the Fedora 17 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.6.3-1.fc17'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16669/kernel-3.6.3-1.fc17
then log in and leave karma (feedback).
Comment 9 Stanislaw Gruszka 2012-10-23 02:18:25 EDT
My fault(In reply to comment #6)
> If I understand the patch correctly it is only affecting USB devices. This
> warning occurred with a PCI-E RT5390 device.

My bad, doh. But perhaps some other patches we have in the update fix this. If not please reopen this bug.
Comment 10 Fedora Update System 2012-10-23 17:58:04 EDT
kernel-3.6.3-3.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kernel-3.6.3-3.fc18
Comment 11 Stanislaw Gruszka 2012-10-24 14:39:27 EDT
Josh, please revert the patch from comment 2. First it does not actually fix the problem, second it cause random crashes on rt2x00usb hardware. I NACKed it upstream too.

Anyway, reporters here are encourage to test updated kernel, perhaps it fix the problem by some different patch.
Comment 12 Josh Boyer 2012-10-24 14:42:11 EDT
Patch dropped.  Will take a bit to have it filter out in updates.
Comment 13 Robert Hancock 2012-10-24 14:57:56 EDT
I can't immediately test this as it seemed to be triggered by AP roaming in a WLAN with multiple access points and I don't normally have access to such a network. Hopefully one of the other CCed people can try out a later kernel build.
Comment 14 Josh Boyer 2012-11-28 10:26:16 EST
*** Bug 871805 has been marked as a duplicate of this bug. ***
Comment 15 Stanislaw Gruszka 2013-03-12 11:40:03 EDT
*** Bug 896754 has been marked as a duplicate of this bug. ***
Comment 16 Stanislaw Gruszka 2013-03-12 11:40:14 EDT
*** Bug 891019 has been marked as a duplicate of this bug. ***
Comment 17 Stanislaw Gruszka 2013-03-12 11:40:23 EDT
*** Bug 901860 has been marked as a duplicate of this bug. ***
Comment 18 Stanislaw Gruszka 2013-03-12 11:49:42 EDT
Created attachment 709033 [details]
cfg80211_mac80211_disconnect_on_suspend.patch

Proposed fix for 3.9+
Comment 19 Stanislaw Gruszka 2013-03-12 11:50:58 EDT
Created attachment 709034 [details]
cfg80211_mac80211_disconnect_on_suspend_v3.8.patch

Proposed fix for 3.8
Comment 20 Stanislaw Gruszka 2013-03-12 11:53:33 EDT
Josh, please apply above patches as fix for this bug. Fix is queued to 3.10, we do not cc -stable as it fundamentally change suspend behaviour, however that should be OK for Fedora.

https://git.kernel.org/cgit/linux/kernel/git/linville/wireless-testing.git/commit/?id=8125696991194aacb1173b6e8196d19098b44e17
Comment 21 Stanislaw Gruszka 2013-03-12 12:13:03 EDT
Please also apply this patch on 3.8, it is needed as part of solution:

https://git.kernel.org/cgit/linux/kernel/git/torvalds/linux.git/commit/?id=499218595a2e8296b7492af32fcca141b7b8184a

it is already on 3.9 and CCed stable.
Comment 22 Josh Boyer 2013-03-12 12:30:59 EDT
Applied both to F17/F18, and just the former to F19/rawhide.
Comment 23 Fedora Update System 2013-03-14 18:53:55 EDT
kernel-3.8.3-101.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/kernel-3.8.3-101.fc17
Comment 24 Fedora Update System 2013-03-14 22:56:14 EDT
kernel-3.8.3-201.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/kernel-3.8.3-201.fc18
Comment 25 Fedora Update System 2013-03-15 21:19:08 EDT
Package kernel-3.8.3-201.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing kernel-3.8.3-201.fc18'
as soon as you are able to, then reboot.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-3893/kernel-3.8.3-201.fc18
then log in and leave karma (feedback).
Comment 26 Fedora Update System 2013-03-16 21:05:17 EDT
kernel-3.8.3-201.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 27 Fedora Update System 2013-03-21 20:13:03 EDT
kernel-3.8.3-103.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.