This service will be undergoing maintenance at 00:00 UTC, 2016-08-01. It is expected to last about 1 hours
Bug 857412 - cannot set up time sync, couldn't write /etc/ntp.conf
cannot set up time sync, couldn't write /etc/ntp.conf
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: system-config-date (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
RejectedNTH
: Reopened
: 858636 859498 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-09-14 06:59 EDT by Jan Sedlák
Modified: 2013-01-12 10:01 EST (History)
10 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-12-10 09:27:31 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)

  None (edit)
Description Jan Sedlák 2012-09-14 06:59:26 EDT
Description of problem:
After installation of F18 Alpha RC3 I wanted to set up time synchronization over network. After clicking on "synchronize date and time over the network" and clicking on "Finish", error popped up with "Couldn't write either /etc/ntp.conf or /etc/sysconfig/network. Configuration unchanged.". I don't know if it matters, but the machine was offline.

How reproducible:
Always.

Steps to Reproduce:
1. Install F18 Alpha RC3
2. Reboot
3. Go to "Date and time" screen
4. Check "Synchronize date and time over the network"
  
Actual results:
Error pops up.

Expected results:
It should work.
Comment 1 Nathanael Noblet 2012-09-18 12:48:17 EDT
I can confirm this as well. My system was network connected I think (it was a VM)
Comment 2 Nathanael Noblet 2012-09-18 13:04:15 EDT
Changed from suggesting a beta blocker to a nice to have. As it doesn't seem to directly infringe on the release criteria, however would be nice to have fixed.
Comment 3 Brian Lane 2012-09-21 13:12:58 EDT
*** Bug 859498 has been marked as a duplicate of this bug. ***
Comment 4 Joe Thompson 2012-09-26 03:05:16 EDT
I ran into this as well.  Once I installed the ntp package (which created /etc/ntp.conf) and touched /etc/sysconfig/network, system-config-date was willing to play ball.  (All it wanted to write to the latter file was "NTPSERVERARGS=iburst".)
Comment 5 Steve Tyler 2012-10-11 00:58:47 EDT
I could not reproduce this bug with the F18-Beta-TC3 Gnome and KDE Live CDs. 
Details are in Bug 856090, Comment 9.

After installing:
$ cat /etc/sysconfig/network
# Generated by anaconda
NETWORKING=yes
HOSTNAME=localhost.localdomain
NTPSERVERARGS=iburst

/etc/chrony.conf exists. /etc/ntp.conf does not.

NB: chrony replaced NTP as of F16:

"3.8.2. Chrony"
"Fedora 16 uses Chrony as the default Network Time Protocol (NTP) client."

http://docs.fedoraproject.org/en-US/Fedora/16/html/Release_Notes/sect-Release_Notes-Changes_for_Sysadmin.html#id2975208
Comment 6 Steve Tyler 2012-10-11 12:29:18 EDT
(In reply to comment #0)
> Description of problem:
...
> ... error popped up with "Couldn't write either
> /etc/ntp.conf or /etc/sysconfig/network. Configuration unchanged.". ...

Bug 858636 has a screenshot showing this message. A dupe?
Comment 7 Adam Williamson 2012-10-11 14:18:21 EDT
Discussed at 2012-10-11 NTH review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-10-11/f18beta-blocker-review-3.1.2012-10-11-16.04.log.txt . Rejected as NTH - network time sync isn't a very crucial function, and this can be fixed perfectly well with a post-release update, so there's no need to break freeze for it.
Comment 8 Adam Williamson 2012-10-11 14:46:49 EDT
*** Bug 858636 has been marked as a duplicate of this bug. ***
Comment 9 Fedora Update System 2012-10-23 10:24:32 EDT
system-config-date-1.10.1-1.fc18, python-slip-0.2.21-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/FEDORA-2012-16696/system-config-date-1.10.1-1.fc18,python-slip-0.2.21-1.fc18
Comment 10 Fedora Update System 2012-10-23 15:45:58 EDT
Package system-config-date-1.10.1-1.fc18, python-slip-0.2.21-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing system-config-date-1.10.1-1.fc18 python-slip-0.2.21-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16696/system-config-date-1.10.1-1.fc18,python-slip-0.2.21-1.fc18
then log in and leave karma (feedback).
Comment 11 Fedora Update System 2012-10-26 15:24:52 EDT
Package system-config-date-1.10.2-1.fc18, python-slip-0.2.21-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing system-config-date-1.10.2-1.fc18 python-slip-0.2.21-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2012-16696/system-config-date-1.10.2-1.fc18,python-slip-0.2.21-1.fc18
then log in and leave karma (feedback).
Comment 12 Jan Sedlák 2012-10-31 05:40:42 EDT
I did't popped into this one in few recent TCs, so I assume that it's fixed.
Comment 13 Adam Williamson 2012-10-31 18:58:31 EDT
The update is still in -testing. Please don't close yet.
Comment 14 Nils Philippsen 2012-12-10 09:27:31 EST
This update was pushed to stable a while ago, closing.
Comment 15 Fedora Update System 2012-12-11 06:12:19 EST
system-config-date-1.10.5-1.fc16 has been submitted as an update for Fedora 16.
https://admin.fedoraproject.org/updates/system-config-date-1.10.5-1.fc16
Comment 16 Fedora Update System 2012-12-11 06:12:55 EST
system-config-date-1.10.5-1.fc17 has been submitted as an update for Fedora 17.
https://admin.fedoraproject.org/updates/system-config-date-1.10.5-1.fc17
Comment 17 Fedora Update System 2013-01-03 02:29:06 EST
system-config-date-1.10.5-1.fc16, python-slip-0.2.24-1.fc16 has been pushed to the Fedora 16 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 18 Fedora Update System 2013-01-12 10:01:39 EST
system-config-date-1.10.5-1.fc17, python-slip-0.2.24-1.fc17 has been pushed to the Fedora 17 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.