Bug 856090 - ntpd not installed, causes firstboot to hang when user selects "Sync date and time over network"
ntpd not installed, causes firstboot to hang when user selects "Sync date and...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: system-config-date (Show other bugs)
18
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Nils Philippsen
Fedora Extras Quality Assurance
AcceptedNTH
: Triaged
: 856093 883308 (view as bug list)
Depends On:
Blocks: F18Blocker/F18FinalBlocker F18Beta-accepted/F18BetaFreezeExcept
  Show dependency treegraph
 
Reported: 2012-09-11 03:56 EDT by Daniel Vrátil
Modified: 2015-11-01 20:36 EST (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2012-11-30 23:20:19 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Daniel Vrátil 2012-09-11 03:56:39 EDT
Description of problem:
After installing Fedora 18 Alpha RC2 from liveCD (KDE spin), no NTP deamon is present in the new installation. 

When user selects "Synchronize date and time over network" in firstboot and clicks "Forward", firstboot hangs trying to start a service that is not available and the only way out is to reboot the machine.

Version-Release number of selected component (if applicable):
Fedora 18 Alpha RC2 KDE Spin


How reproducible:
always

Steps to Reproduce:
1. install system from liveCD
2. reboot
3. select "Synchornize date and time over network" in firstboot
  
Actual results:
firstboot hangs, because there is no NTP service installed.


Expected results:
An NTP daemon is installed from liveCD.


Additional info:
Didn't test with regular DVD/netinst installation.
Comment 1 Martin Bříza 2012-09-11 08:06:18 EDT
This happened to me too right now while installing the Fedora 18 Alpha RC2 with KDE.
Comment 2 Daniel Vrátil 2012-09-11 08:10:39 EDT
Proposed as NTH for F18 Alpha.
Comment 3 Rex Dieter 2012-09-11 11:13:44 EDT
triaging to firstboot component, probably just needs a dependency added.

+Requires: chrony 
?
Comment 4 Martin Sivák 2012-09-12 15:29:47 EDT
Firstboot only includes that screen from system-config-date. Reassigning.
Comment 5 Adam Williamson 2012-09-12 15:33:20 EDT
Discussed at 2012-09-12 NTH review meeting. Accepted as NTH as hanging firstboot is obviously bad. It's not a blocker as, for Alpha, firstboot is only required to be able to create a user account.
Comment 6 Adam Williamson 2012-09-26 13:57:03 EDT
Discussed at 2012-09-26 blocker review meeting: http://meetbot.fedoraproject.org/fedora-qa/2012-09-26/f18-beta-blocker-review-1.2012-09-26-16.03.log.txt . Rejected as beta blocker but accepted as NTH, there are no stricter firstboot criteria for beta so it's still not a blocker. Obviously accepted as NTH again as it was for Alpha.

Re-proposing as Final blocker too: there are no stricter criteria for firstboot even in Final, but perhaps there should be.
Comment 7 Nathanael Noblet 2012-10-04 21:57:25 EDT
I feel like this is a duplicate of https://bugzilla.redhat.com/show_bug.cgi?id=857412. Different description, but isn't it caused by the same underlying issue?
Comment 8 Adam Williamson 2012-10-05 04:44:42 EDT
it does sound rather similar, but this bug refers to a hang while that one describes an error dialog, so I'm not 100% sure.
Comment 9 Steve Tyler 2012-10-11 00:41:07 EDT
I could not reproduce this bug with the F18-Beta-TC3 Gnome and KDE Live CDs.

During installation, defaults were to enable network time, and those were accepted. There were no obvious errors or hangs related to network time during installation or firstboot.

The chrony package was present in both the Live environment and on the installed system. Verified with "rpm -q chrony":
chrony-0:1.27-0.5.pre1.git1ca844.fc18.x86_64

chronyd was running in both the Live environment and on the installed system. Verified with "ps -ef | grep chrony".

Tested with:

$ qemu-kvm -m 2048 -hda f18-test-1.img -cdrom ~/xfr/fedora/F18/F18-Beta/TC3/Fedora-18-Beta-TC3-x86_64-Live-Desktop.iso -usb -vga qxl -boot menu=on

$ qemu-kvm -m 2048 -hda f18-test-2.img -cdrom ~/xfr/fedora/F18/F18-Beta/TC3/Fedora-18-Beta-TC3-x86_64-Live-KDE.iso -usb -vga qxl -boot menu=on

NB: With the KDE Live CD, the installer hub was blank, but the spoke links were sensitive, and the spokes were correctly rendered, so it was possible to set a timezone and to select default partitioning.
Comment 10 Adam Williamson 2012-10-11 00:58:50 EDT
"NB: With the KDE Live CD, the installer hub was blank, but the spoke links were sensitive, and the spokes were correctly rendered, so it was possible to set a timezone and to select default partitioning." - that's https://bugzilla.redhat.com/show_bug.cgi?id=864058 .
Comment 11 Martin Sivák 2012-10-17 08:30:44 EDT
*** Bug 856093 has been marked as a duplicate of this bug. ***
Comment 12 Tim Flink 2012-11-30 15:27:50 EST
Is this still an issue? There haven't been any new reports for a while. From c#9, it sounds like this might be fixed.
Comment 13 Adam Williamson 2012-11-30 23:20:19 EST
yeah, this was fixed long ago, I think. let's close it, re-open if we're wrong.
Comment 14 Martin Sivák 2012-12-05 09:23:03 EST
*** Bug 883308 has been marked as a duplicate of this bug. ***
Comment 15 Dev 2013-02-17 17:10:56 EST
Just had this happen to me when installing the Fedora 18 x86_86 lxde spin.
Comment 16 Nils Philippsen 2013-02-19 08:42:38 EST
"This" being (a bit more details please)? I'm asking because s-c-date has code to cope with missing ntpd/chrony (it should disable any NTP options if no ntp daemon is available).
Comment 17 Dev 2013-02-19 16:27:26 EST
Sorry, "this" being a repeat of the original bug report, but with the lxde x86_64 spin. I used the graphical installation. In the timezone localization, Network Time was on. I was upgrading from Fedora 16 i686, and kept my old /home partition (a real struggle with the new anaconda). After rebooting, at the Date and Time stage in Firstboot, I left all options at their default settings. A pop-up appeared saying "starting NTP service" (or something like that) and it just hung up.
Comment 18 Nils Philippsen 2013-02-20 06:01:20 EST
Thanks for the detailed explanation! Are either the ntpd or the chrony package installed on your system?
Comment 19 Dev 2013-02-22 13:49:40 EST
Sadly I've been tinkering since I did that install. I had some problems with another package and thought it might be easier to try the plain gnome fedora. I installed that, leaving the ntp box unticked, discovered that it didn't fix the problem and then reinstalled the lxde spin again. I left the ntp box ticked this time (just to see what would happen) and strangely it worked. It suggests to me that it's either a timing issue or a dependency on something in my home partition. ps aux says chrony is there. I've no idea whether it was installed the first time I tried it.

Note You need to log in before you can comment on or make changes to this bug.