Bug 85942 - up2date clist has fixed-width columns
up2date clist has fixed-width columns
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: up2date (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
: 106828 111892 120249 121579 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-03-11 03:12 EST by Mike A. Harris
Modified: 2007-11-30 17:10 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-03-06 15:57:28 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
Window screenshot showing cut off text in column headers (44.94 KB, image/png)
2003-03-11 03:14 EST, Mike A. Harris
no flags Details
Replace checklist.CheckList by GtkTreeView-based code (18.44 KB, patch)
2004-07-19 19:29 EDT, Miloslav Trmač
no flags Details | Diff

  None (edit)
Description Mike A. Harris 2003-03-11 03:12:49 EST
For a long time now I've noticed the up2date GUI has a few issues which
make it a bit user unfriendly as the UI widgets give you some false
impressions.  I must admit I should have possibly filed this report a
long time ago when I first noticed the problem, however I figured it
was something that everyone would notice and that perhaps someone would
have filed a report on it already.  (Also, I must admit that I have not
queried bugzilla first to see if someone has filed a similar report, as
I'm not completely sure what search criterion I'd use to find similar
reports).

Here is the problem:  On any of the screens which come up, in which the
user is presented a multi-columned list of packages to choose from, the
column names at the top are cut off.  This is on a default OS install,
with nothing modified, font sizes are unchanged, etc.  All defaults.

The column headers look like this:

___________________________________________________________________________
  |Package Name |Versio|Releas|Arch|Size
___________________________________________________________________________

I'll attach a screenshot to illustrate better, then continue my
explanation...
Comment 1 Mike A. Harris 2003-03-11 03:14:16 EST
Created attachment 90548 [details]
Window screenshot showing cut off text in column headers
Comment 2 Mike A. Harris 2003-03-11 03:33:20 EST
The cut off text is just a bad default setting for column width, and is
likely easily cured by making the default widths wider, or by autosizing
each column to be as big or bigger than the column header text.  That
would IMHO present a nicer more professional default look.

The bigger problem however, is that my first thought as a user when seeing
this, was to move the mouse over to the horizontal bar separators between
column header fields, in an attempt to resize them.  When you do this, the
mouse cursor properly changes to the expected "horizontal column resizer"
cursor, thus giving the user the visual cue "You may now click the mouse
and drag this bar to resize the column".  However when you try to do that,
2 bugs are triggered:

1) The column does not resize.  I tried left click and drag, right click
   and drag, middle click and drag, and none of them do anything.

2) If you click *any* mouse button while the mouse is in on the resizer
   bar in the column header, it actually selects or deselects a package
   in the underlying list of packages!  Totally unexpected and wrong
   behaviour.

As a result of these bugs, the user is unable to resize the columns, either
to have the column headers simply display their complete text, or more
importantly, to resize the columns to see the potentially much wider
package names, architecture names, version, release...

For example, while using up2date, many times I've wanted to drag resize
the "Package Name" column to the right in order to see the full name, since
part of the name was hidden, however the displayed portion was not
unambiguous.  Also, the architecture names get cut off.  If you look at
up2date running on x86_64, what you see in the GUI is "x86_6" and a cut
in half "4" as my attached screenshot shows.

The Version and Release fields also suffer from this problem in that they
assume that all packages Version and Release text content will be 6 or so
characters or less.  XFree86 4.2.99.902 gets cut off in the Version field
to "4.2.99", and there's also no indication that the field continues on
with hidden text (such as "4.2.99...".  The Release field is truncated
from 20030213.2 to "2003021" with the remainder not visible and no way
of resizing the columns to be visible.  This makes it appear that you're
downloading the same version over and over again every time you update,
at least until the visible digits change (like with 4.3.0 now).

Since I wanted to see the full name, version, release, arch, etc. I thought
perhaps if I "maximize" the window, it would show me wider columns.  Instead
though what happens is that the window maximizes ok, but most of the screen
real estate remains unused, and you're unable to resize the fields to
make the available screen resources used.

In summary, I think that the column widths should not be hard coded with
fixed sizes, and that they should be user resizeable, and that the default
column widths presented to a user should be at least wide enough to contain
the full column header text for each column.  The "Arch" field should IMHO
should default to be as large as the arch and subarches of the running machine
(so that x86_64 shows up by default rather than being cut off), since there
is ample screen real estate.

These changes are likely trivial, but IMHO will help to give the user a
better first impression, and make the tool more friendly.

Comment 3 Havoc Pennington 2003-03-11 12:24:35 EST
simplest fix is probably to go to treeview.
there's a larger-scope ui spec for up2date/r-c-packages in the works though 
so it may not be worth fooling with it for now.
Comment 4 Miloslav Trmac 2004-02-07 12:11:23 EST
*** Bug 106828 has been marked as a duplicate of this bug. ***
Comment 5 Warren Togami 2004-06-21 22:09:04 EDT
*** Bug 121579 has been marked as a duplicate of this bug. ***
Comment 6 Miloslav Trmač 2004-07-19 19:29:08 EDT
Created attachment 102060 [details]
Replace checklist.CheckList by GtkTreeView-based code

The attached patch
* replaces checklist.py by the corresponding file from Anaconda
* modifies it to be as compatible to the original up2date version as possible
* updates gui.py for cases where complete compatiblity was not easily doable
* allows column resizing for all CheckList columns by default

It is still possible to play with this problem more (reconsidering/removing
minimal column widths set in gui.py), but that seems low-priority to me.
Comment 7 Warren Togami 2005-05-20 05:40:59 EDT
Too late for such a change now, but it shouldn't be ignored for FC5.
Comment 8 Mike A. Harris 2005-05-20 19:12:34 EDT
I switched from using up2date to using yum about a year or so ago and haven't
really used up2date since then, so not really tracking this one anymore.

Only *.redhat.com on the CC list so far, and a quick bugzilla scan seems to
indicate no customers or FC user interest in seeing this flaw fixed, so it's
probably ultra-low priority on the grand scheme of things.  Most FC users
use yum, so wouldn't be affected anyway per se.

Feel free to close this bug if you like.

Comment 9 Warren Togami 2005-05-20 21:27:23 EDT
Nah, I think this is worth doing eventually, and mitr even went through the
effort of writing a patch.
Comment 10 Peter van Egdom 2005-07-29 18:43:17 EDT
*** Bug 111892 has been marked as a duplicate of this bug. ***
Comment 11 Peter van Egdom 2005-07-30 15:18:50 EDT
*** Bug 120249 has been marked as a duplicate of this bug. ***
Comment 12 Warren Togami 2006-03-06 10:32:36 EST
Removing from FC5Blocker because up2date is no longer in FC5.
Comment 13 Mike A. Harris 2006-03-06 15:57:28 EST
Wow, I didn't realize this bug was still open...   Closing bug now as up2date
is obsolete, and I'm no longer interested in tracking the bug.

I use yum exclusively from the commandline nowadays.


Note You need to log in before you can comment on or make changes to this bug.