Bug 862308 - subscription-manager version reports "registered to: 0.7.11-1" value when identity reports "This system is not yet registered."
subscription-manager version reports "registered to: 0.7.11-1" value when ide...
Status: CLOSED ERRATA
Product: Red Hat Enterprise Linux 5
Classification: Red Hat
Component: subscription-manager (Show other bugs)
5.10
Unspecified Unspecified
unspecified Severity unspecified
: beta
: 5.10
Assigned To: William Poteat
Entitlement Bugs
:
Depends On:
Blocks: rhsm-rhel510 868347 rhsm-2013
  Show dependency treegraph
 
Reported: 2012-10-02 11:19 EDT by John Sefler
Modified: 2013-09-30 18:50 EDT (History)
5 users (show)

See Also:
Fixed In Version: 1.8.2
Doc Type: Bug Fix
Doc Text:
No description necessary
Story Points: ---
Clone Of:
: 868347 (view as bug list)
Environment:
Last Closed: 2013-09-30 18:50:05 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description John Sefler 2012-10-02 11:19:02 EDT
Description of problem:

In Bug 846834, the "remote entitlement server:" string label was changed to "registered to:".  In my opinion this was a bad change.  Here is an example why...

[root@jsefler-59server ~]# subscription-manager identity
This system is not yet registered. Try 'subscription-manager register --help' for more information.

[root@jsefler-59server ~]# subscription-manager version
registered to: 0.7.11-1
server type: subscription management service
subscription-manager: 1.0.20-1.git.9.1f50513.el5
python-rhsm: 1.0.9-1.git.0.243d101.el5

^^^ Notice that the machine is NOT registered, yet the version module says "registered to: 0.7.11-1"

This value reported by the the "subscription-manager version" is actually the version of the candlepin server.  In my opinion, a more accurate and less misleading string label should be "server version:".



Version-Release number of selected component (if applicable):
subscription-manager: 1.0.20-1.git.9.1f50513.el5

How reproducible:


Steps to Reproduce:
1. Configure your rhsm.conf to a valid on-premise candlepin server (and get the candlepin's ca cert too).
2. without registering...
[root@jsefler-59server ~]# subscription-manager version
registered to: 0.7.11-1
server type: subscription management service
subscription-manager: 1.0.20-1.git.9.1f50513.el5
python-rhsm: 1.0.9-1.git.0.243d101.el5


Expected results:
[root@jsefler-59server ~]# subscription-manager version
server version: 0.7.11-1
server type: subscription management service
subscription-manager: 1.0.20-1.git.9.1f50513.el5
python-rhsm: 1.0.9-1.git.0.243d101.el5
Comment 1 RHEL Product and Program Management 2012-10-02 11:28:22 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 2 Matt Reid 2012-10-02 15:55:46 EDT
Good catch John, that doesn't make much sense now. 

My vote would be to change "registered to:" to "subscription management server", if we had refreshed the terminology of "remote entitlement server" without trying to get cute, that's what it would've been.

If registered to a subscription management service:
[root@localhost ~]# subscription-manager version
subscription management server: 0.7.11-1
server type: subscription management service
subscription-manager: 1.1.2-1.git.28.85c7626.el5
python-rhsm: 1.1.2-1.git.2.717d0ac.el5

If registered to Classic:
[root@localhost ~]# subscription-manager version
subscription management server: Unknown
server type: RHN Classic
subscription-manager: 1.1.2-1.git.28.85c7626.el5
python-rhsm: 1.1.2-1.git.2.717d0ac.el5

If we don't already have "subscription management server" translated somewhere, I'd be ok with just "server".

[root@localhost ~]# subscription-manager version
server: 0.7.11-1
server type: subscription management service
subscription-manager: 1.1.2-1.git.28.85c7626.el5
python-rhsm: 1.1.2-1.git.2.717d0ac.el5


More info:
This gives me some ideas for 6.4 bzs...
Comment 3 William Poteat 2012-10-04 10:47:16 EDT
master commit 561acaf1efa873bbcc0104416dbea75b46b13e74
Comment 6 John Sefler 2012-10-19 10:41:05 EDT
(In reply to comment #3)
> master commit 561acaf1efa873bbcc0104416dbea75b46b13e74

This fix will appear in rhel64 since it required a new string that is too late to be translated for rhel59.

Cloning this bug for verification in rhel64 and changing this bug's tracking blocker to rhsm-rhel510.
Comment 8 Bryan Kearney 2013-02-08 12:18:40 EST
Fixed in the 1.8.2 version of subscription-manager or python-rhsm
Comment 9 Shwetha Kallesh 2013-02-11 03:33:56 EST
Marking verified!!

[root@rhel7 ~]# subscription-manager identity
This system is not yet registered. Try 'subscription-manager register --help' for more information.


[root@rhel7 ~]# subscription-manager version
server type: This system is currently not registered.
subscription management server: 0.7.24-1
subscription-manager: 1.8.2-1.el7
python-rhsm: 1.8.2-1.el7
Comment 10 RHEL Product and Program Management 2013-04-09 15:59:37 EDT
This request was evaluated by Red Hat Product Management for inclusion
in a Red Hat Enterprise Linux release.  Product Management has
requested further review of this request by Red Hat Engineering, for
potential inclusion in a Red Hat Enterprise Linux release for currently
deployed products.  This request is not yet committed for inclusion in
a release.
Comment 12 errata-xmlrpc 2013-09-30 18:50:05 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHBA-2013-1332.html

Note You need to log in before you can comment on or make changes to this bug.