Bug 868935 - [abrt] gnome-settings-daemon-3.6.1-3.fc18: _gdk_x11_display_error_event: Process /usr/libexec/gnome-settings-daemon was killed by signal 5 (SIGTRAP)
[abrt] gnome-settings-daemon-3.6.1-3.fc18: _gdk_x11_display_error_event: Proc...
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-desktop3 (Show other bugs)
19
x86_64 Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Richard Hughes
Fedora Extras Quality Assurance
abrt_hash:a285fe3d30319436653a82b5c87...
:
: 968189 993466 996346 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2012-10-22 09:54 EDT by efreeti
Modified: 2013-09-07 20:34 EDT (History)
13 users (show)

See Also:
Fixed In Version: gnome-desktop3-3.8.4-1.fc19
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-09-07 20:34:19 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
File: core_backtrace (4.14 KB, text/plain)
2012-10-22 09:54 EDT, efreeti
no flags Details
File: environ (1.17 KB, text/plain)
2012-10-22 09:54 EDT, efreeti
no flags Details
File: event_log (1.48 KB, text/plain)
2012-10-22 09:54 EDT, efreeti
no flags Details
File: backtrace (52.89 KB, text/plain)
2012-10-22 09:54 EDT, efreeti
no flags Details
File: limits (1.29 KB, text/plain)
2012-10-22 09:54 EDT, efreeti
no flags Details
File: cgroup (127 bytes, text/plain)
2012-10-22 09:54 EDT, efreeti
no flags Details
File: dso_list (15.71 KB, text/plain)
2012-10-22 09:55 EDT, efreeti
no flags Details
File: maps (78.01 KB, text/plain)
2012-10-22 09:55 EDT, efreeti
no flags Details
File: proc_pid_status (936 bytes, text/plain)
2012-10-22 09:55 EDT, efreeti
no flags Details
File: var_log_messages (474 bytes, text/plain)
2012-10-22 09:55 EDT, efreeti
no flags Details
File: open_fds (1.01 KB, text/plain)
2012-10-22 09:55 EDT, efreeti
no flags Details

  None (edit)
Description efreeti 2012-10-22 09:54:35 EDT
Description of problem:
I closed the lid of laptop, system went to suspend (cannot change this!). Reopen, crash.

Version-Release number of selected component:
gnome-settings-daemon-3.6.1-3.fc18

Additional info:
libreport version: 2.0.16
abrt_version:   2.0.16
backtrace_rating: 4
cmdline:        /usr/libexec/gnome-settings-daemon
crash_function: _gdk_x11_display_error_event
kernel:         3.6.2-2.fc18.x86_64

truncated backtrace:
:Thread no. 1 (10 frames)
: #2 _gdk_x11_display_error_event at gdkdisplay-x11.c:2416
: #6 handle_error at xcb_io.c:212
: #8 XRRSetCrtcConfig at XrrCrtc.c:147
: #9 gnome_rr_crtc_set_config_with_time at gnome-rr.c:2181
: #10 configure_crtc at gnome-rr-config.c:1600
: #12 g_hash_table_foreach at ghash.c:1524
: #13 crtc_assignment_apply at gnome-rr-config.c:1945
: #14 gnome_rr_config_apply_with_time at gnome-rr-config.c:1308
: #15 apply_configuration at gsd-xrandr-manager.c:500
: #16 auto_configure_outputs at gsd-xrandr-manager.c:1691
Comment 1 efreeti 2012-10-22 09:54:39 EDT
Created attachment 631548 [details]
File: core_backtrace
Comment 2 efreeti 2012-10-22 09:54:42 EDT
Created attachment 631549 [details]
File: environ
Comment 3 efreeti 2012-10-22 09:54:45 EDT
Created attachment 631550 [details]
File: event_log
Comment 4 efreeti 2012-10-22 09:54:50 EDT
Created attachment 631551 [details]
File: backtrace
Comment 5 efreeti 2012-10-22 09:54:53 EDT
Created attachment 631552 [details]
File: limits
Comment 6 efreeti 2012-10-22 09:54:56 EDT
Created attachment 631553 [details]
File: cgroup
Comment 7 efreeti 2012-10-22 09:55:03 EDT
Created attachment 631554 [details]
File: dso_list
Comment 8 efreeti 2012-10-22 09:55:08 EDT
Created attachment 631555 [details]
File: maps
Comment 9 efreeti 2012-10-22 09:55:11 EDT
Created attachment 631556 [details]
File: proc_pid_status
Comment 10 efreeti 2012-10-22 09:55:17 EDT
Created attachment 631557 [details]
File: var_log_messages
Comment 11 efreeti 2012-10-22 09:55:21 EDT
Created attachment 631558 [details]
File: open_fds
Comment 12 Paul Finnigan 2012-10-30 11:35:26 EDT
Don't know. I was just loading a test system on a VirtualBox VM.

backtrace_rating: 4
Package: gnome-settings-daemon-3.6.1-3.fc18
OS Release: Fedora release 18 (Spherical Cow)
Comment 13 Pavel Sidlo 2013-05-09 08:52:47 EDT
Using latest NoMachine NX 3.5.0-9. When connected server side (my PC) from Windows 7 machine, Gnome Settings Daemon crashes. It probably happens every time - both new connect and reconnect too.

backtrace_rating: 4
cmdline:        /usr/libexec/gnome-settings-daemon
crash_function: _gdk_x11_display_error_event
executable:     /usr/libexec/gnome-settings-daemon
kernel:         3.8.6-203.fc18.x86_64
package:        gnome-settings-daemon-3.6.4-3.fc18
reason:         Process /usr/libexec/gnome-settings-daemon was killed by signal 5 (SIGTRAP)
reported_to:    uReport: BTHASH=8c55178dafa48c1973e16786672d91550db99cb8
uid:            1129
ureports_counter: 9
Comment 14 Rui Matos 2013-09-04 09:47:39 EDT
*** Bug 968189 has been marked as a duplicate of this bug. ***
Comment 15 Fedora Update System 2013-09-04 09:51:22 EDT
gnome-desktop3-3.8.4-1.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/gnome-desktop3-3.8.4-1.fc19
Comment 16 Rui Matos 2013-09-04 10:06:47 EDT
*** Bug 996346 has been marked as a duplicate of this bug. ***
Comment 17 Rui Matos 2013-09-04 11:44:37 EDT
*** Bug 993466 has been marked as a duplicate of this bug. ***
Comment 18 Fedora Update System 2013-09-04 21:35:22 EDT
Package gnome-desktop3-3.8.4-1.fc19:
* should fix your issue,
* was pushed to the Fedora 19 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-desktop3-3.8.4-1.fc19'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-15805/gnome-desktop3-3.8.4-1.fc19
then log in and leave karma (feedback).
Comment 19 Fedora Update System 2013-09-07 20:34:19 EDT
gnome-desktop3-3.8.4-1.fc19 has been pushed to the Fedora 19 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.