Bug 883159 - CSS styles in epub are not working
CSS styles in epub are not working
Status: CLOSED CURRENTRELEASE
Product: Publican
Classification: Community
Component: publican (Show other bugs)
3.0
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: Jeff Fearn
tools-bugs
:
: 736881 816769 823554 911995 (view as bug list)
Depends On:
Blocks: 816597
  Show dependency treegraph
 
Reported: 2012-12-03 17:43 EST by Jeff Fearn
Modified: 2013-12-18 21:46 EST (History)
6 users (show)

See Also:
Fixed In Version: 4.0.0
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-18 21:46:30 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jeff Fearn 2012-12-03 17:43:37 EST
Description of problem:
Admonitions, screens, program listings, etc, have no colours in epubs.

Version-Release number of selected component (if applicable):
3.0

How reproducible:
Always

Steps to Reproduce:
1. Build a book in EPUB

Actual results:
Admonitions et.al have reduced styling.

Expected results:
Admonitions et.al look shiny.

Additional info:
Also looks like the web site footer is being injected in to the epub. Remove that as well.
Comment 1 HSS Product Manager 2013-09-30 01:27:32 EDT
HSS-QE has reviewed and declined this request. QE for this bug will be handled by IED.
Comment 2 Jeff Fearn 2013-09-30 20:06:01 EDT
EPUB CSS split and reset, need to test layout and review style.

To ssh://git.fedorahosted.org/git/publican.git
   8711fbe..9d087c5  HEAD -> devel
Comment 3 Jeff Fearn 2013-10-01 02:47:45 EDT
*** Bug 823554 has been marked as a duplicate of this bug. ***
Comment 4 Jeff Fearn 2013-10-01 02:47:48 EDT
*** Bug 736881 has been marked as a duplicate of this bug. ***
Comment 5 Jeff Fearn 2013-10-01 02:47:50 EDT
*** Bug 816769 has been marked as a duplicate of this bug. ***
Comment 6 Jeff Fearn 2013-10-01 02:50:43 EDT
*** Bug 911995 has been marked as a duplicate of this bug. ***
Comment 7 Jeff Fearn 2013-10-01 22:48:36 EDT
More fixes to CSS output and style.

Can anyone with an ereader please d/l and test http://jfearn.fedorapeople.org/epub_test/Publican-4.0-Users_Guide-en-US.epub and let us know how it works for you?

It works much better on my Kobo Aura HD than the previous epubs did.

To ssh://git.fedorahosted.org/git/publican.git
   841ddd0..add30b0  HEAD -> devel
Comment 8 Ruediger Landmann 2013-10-16 19:30:54 EDT
Tested a book generated by publican-3.9.9-0.fc19.t6.noarch on a Kobo Mini -- very fast, very responsive, and very clear.

The small screen of the mini meant that chapter and section titles usually got wrapped, and I noticed some leading issues there, but that was the worst thing I saw even with a giant book like the RHEL Installation Guide! 

Counting this as verification; thanks! :D

Note You need to log in before you can comment on or make changes to this bug.