Bug 891411 - [de_DE][zh_TW][pt_BR][ru_RU][SAM CLI] user module "translation missing: de.activerecord.errors.messages.record_invalid" errors
[de_DE][zh_TW][pt_BR][ru_RU][SAM CLI] user module "translation missing: de.ac...
Status: CLOSED ERRATA
Product: Subscription Asset Manager
Classification: Red Hat
Component: katello (Show other bugs)
1.3
Unspecified Linux
unspecified Severity high
: rc
: ---
Assigned To: Lukas Zapletal
Og Maciel
: Translation, Triaged
Depends On: 887095 896251
Blocks: sam13-tracker
  Show dependency treegraph
 
Reported: 2013-01-02 16:15 EST by Jordan OMara
Modified: 2014-11-09 17:56 EST (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 887095
Environment:
Last Closed: 2013-10-01 06:55:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Og Maciel 2013-01-03 11:21:18 EST
Using RHEL 6.4:

# for i in de_DE zh_TW pt_BR ru_RU; do LANG=$i headpin -u admin -p admin user create --username=testuser-$i --password=redhat --email=foo@bar.com; done
Benutzer [ testuser-de_DE ] erfolgreich erstellt
已成功建立使用者 [ testuser-zh_TW ]
Usuário criado com sucesso [ testuser-pt_BR ]
Создан пользователь [ testuser-ru_RU ]
Comment 2 sthirugn@redhat.com 2013-01-03 13:23:53 EST
Using RHEL 6.3:

Same scenario mentioned by Og Maciel above:

# for i in de_DE zh_TW pt_BR ru_RU; do LANG=$i headpin -u admin -p admin user create --username=testuser-$i --password=redhat --email=foo@bar.com; done
translation missing: de.activerecord.errors.messages.record_invalid
translation missing: zh.activerecord.errors.messages.record_invalid
translation missing: pt.activerecord.errors.messages.record_invalid
translation missing: ru.activerecord.errors.messages.record_invalid

Other scenarios mentioned in the BZ:
Scenario 1:
# LANG=pt_BR
# headpin -u admin -p admin user create --username=te --password=red --email=
translation missing: pt.activerecord.errors.messages.record_invalid

Scenario 2:
#LANG=pt_BR
# headpin -u admin -p admin user create --username=test --password=redhat --email=test@localhost --disabled=true  --default_locale=en
translation missing: pt.activerecord.errors.messages.record_invalid

Scenario 3:
#LANG=pt_BR
# headpin -u admin -p admin user update --username=test --password=redhat --email=test@localhost --disabled=false --default_organization=test --default_environment=test --default_locale=t
Couldn't find organization 'test'
# headpin -u admin -p admin user update --username=test --password=redhat --email=test@localhost --disabled=false --default_organization=ACME_Corporation --default_environment=test --default_locale=t
Não foi possível encontrar ambiente [ test ] dentro da empresa  [ ACME_Corporation ] 

Scenario 4:
#LANG=pt_BR
# headpin -u admin -p admin user assign_role --username=test --role=Administrator
translation missing: pt.activerecord.errors.messages.record_invalid

Scenario 5: 
#LANG=pt_BR
# headpin -u admin -p admin user update --username=test --password=redhat --email=test@localhost --disabled=false --default_organization=test --default_environment=test --default_locale=t
Couldn't find organization 'test'
# headpin -u admin -p admin user update --username=test --password=redhat --email=test@localhost --disabled=false --default_organization=ACME_Corporation --default_environment=test --default_locale=t
Não foi possível encontrar ambiente [ test ] dentro da empresa  [ ACME_Corporation ]
Comment 4 Bryan Kearney 2013-08-14 16:10:07 EDT
Translations are in.
Comment 5 Og Maciel 2013-08-16 14:43:14 EDT
[root@cloud-qe-10 ~]# LANG=de_DE headpin -u admin-user1 -p redhat org list
---------------------------------------------------------------------------------------------------------------------------------
                                                       Organisationsliste

ID Name             Kennung          Beschreibung
---------------------------------------------------------------------------------------------------------------------------------
2  Dungeon          Dungeon          Legend of Dungeon
1  ACME_Corporation ACME_Corporation ACME_Corporation Organization
[root@cloud-qe-10 ~]# LANG=zh_TW headpin -u admin-user1 -p redhat org list
錯誤:'ascii' codec can't encode characters in position 0-1: ordinal not in range(128)(欲取得更多資訊請參閱日誌檔案 /var/log/katello/client.log)
[root@cloud-qe-10 ~]# LANG=pt_BR headpin -u admin-user1 -p redhat org list
erro: 'ascii' codec can't encode characters in position 2-3: ordinal not in range(128) (mais no arquivo log /var/log/katello/client.log)
[root@cloud-qe-10 ~]# LANG=ru_RU headpin -u admin-user1 -p redhat org list
ошибка: 'ascii' codec can't encode characters in position 0-8: ordinal not in range(128) (подробная информация в /var/log/katello/client.log)
Comment 6 Og Maciel 2013-08-16 14:54:26 EDT
This seems to be working now but there is a new issue which I shall file separately.

* apr-util-ldap-1.3.9-3.el6_0.1.x86_64
* candlepin-0.8.20-1.el6sam.noarch
* candlepin-scl-1-5.el6_4.noarch
* candlepin-scl-quartz-2.1.5-5.el6_4.noarch
* candlepin-scl-rhino-1.7R3-1.el6_4.noarch
* candlepin-scl-runtime-1-5.el6_4.noarch
* candlepin-selinux-0.8.20-1.el6sam.noarch
* candlepin-tomcat6-0.8.20-1.el6sam.noarch
* elasticsearch-0.19.9-8.el6sat.noarch
* katello-candlepin-cert-key-pair-1.0-1.noarch
* katello-certs-tools-1.4.2-2.el6sat.noarch
* katello-cli-1.4.3-7.el6sat.noarch
* katello-cli-common-1.4.3-7.el6sat.noarch
* katello-common-1.4.3-8.el6sam_splice.noarch
* katello-configure-1.4.4-2.el6sat.noarch
* katello-glue-candlepin-1.4.3-8.el6sam_splice.noarch
* katello-glue-elasticsearch-1.4.3-8.el6sam_splice.noarch
* katello-headpin-1.4.3-8.el6sam_splice.noarch
* katello-headpin-all-1.4.3-8.el6sam_splice.noarch
* katello-selinux-1.4.4-2.el6sat.noarch
* openldap-2.4.23-31.el6.x86_64
* python-ldap-2.3.10-1.el6.x86_64
* ruby193-rubygem-ldap_fluff-0.2.2-1.el6sat.noarch
* ruby193-rubygem-net-ldap-0.3.1-2.el6sat.noarch
* signo-0.0.20-1.el6sat.noarch
* signo-katello-0.0.20-1.el6sat.noarch
* thumbslug-0.0.32-1.el6sam.noarch
* thumbslug-selinux-0.0.32-1.el6sam.noarch
Comment 7 Og Maciel 2013-08-16 14:59:33 EDT
New BZ https://bugzilla.redhat.com/show_bug.cgi?id=998028
Comment 9 errata-xmlrpc 2013-10-01 06:55:04 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

http://rhn.redhat.com/errata/RHEA-2013-1390.html

Note You need to log in before you can comment on or make changes to this bug.