Bug 909662 - (Horde_View) Review Request: php-horde-Horde-View - Horde View API
Review Request: php-horde-Horde-View - Horde View API
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: Package Review (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Shawn Iwinski
Fedora Extras Quality Assurance
:
: 785488 (view as bug list)
Depends On: horde-channel Horde_Controller
Blocks: Horde_Core horde
  Show dependency treegraph
 
Reported: 2013-02-10 04:10 EST by Remi Collet
Modified: 2014-01-29 16:26 EST (History)
4 users (show)

See Also:
Fixed In Version: php-horde-Horde-View-2.0.3-2.el6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2014-01-18 02:57:31 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
shawn: fedora‑review+
limburgher: fedora‑cvs+


Attachments (Terms of Use)
phpcompatinfo.log (19.35 KB, text/x-log)
2014-01-09 21:54 EST, Shawn Iwinski
no flags Details
fedora-review.txt (6.98 KB, text/plain)
2014-01-09 21:56 EST, Shawn Iwinski
no flags Details

  None (edit)
Comment 1 Remi Collet 2013-02-10 04:10:39 EST
*** Bug 785488 has been marked as a duplicate of this bug. ***
Comment 3 Shawn Iwinski 2013-02-23 16:42:07 EST
$ rpmlint ./php-horde-Horde-View-2.0.2-1.remi.src.rpm 
php-horde-Horde-View.src: E: unknown-key GPG#00f97f56
1 packages and 0 specfiles checked; 1 errors, 0 warnings.


When searching for GPG key 00f97f56 it is marked as revoked.
Comment 4 Remi Collet 2013-02-24 05:17:40 EST
the GPG key used to sign the RPM shouldn't be an issue for the review (it is the one used to sign all RPM in my personal repo, I know it have been revoked a very long time ago.... my fault...)

Please simply ignore this warning (as it apply on the downloaded .src.rpm, not on the build one)
Comment 5 Shawn Iwinski 2013-02-24 19:07:29 EST
(In reply to comment #4)

You're right. Sorry. I was trying to figure out why my mock (from fedora-review) builds were failing. I missed that the build requires weren't available in rawhide yet (my mock logs weren't clear on that). Disregard all of my bug comments regarding the GPG key.
Comment 7 Shawn Iwinski 2014-01-09 21:54:44 EST
Created attachment 847983 [details]
phpcompatinfo.log

phpcompatinfo version 2.26.0
Comment 8 Shawn Iwinski 2014-01-09 21:56:09 EST
Created attachment 847984 [details]
fedora-review.txt

Generated by fedora-review 0.5.1 (bb9bf27) last change: 2013-12-13
Command line :/usr/bin/fedora-review --mock-config fedora-rawhide-x86_64 --define EPEL5 -b 909662
Buildroot used: fedora-rawhide-x86_64
Active plugins: Generic, PHP, Shell-api
Disabled plugins: Java, C/C++, Python, fonts, SugarActivity, Ocaml, Perl, Haskell, R, Ruby
Disabled flags: EXARCH, BATCH, DISTTAG
Comment 9 Shawn Iwinski 2014-01-09 21:59:17 EST
Issues:
=======
- EPEL5 requires explicit %clean with rm -rf %{buildroot} (or $RPM_BUILD_ROOT)
- EPEL5: Package does run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
  beginning of %install.



[x]: Spec file according to URL is the same as in SRPM.
     Note: Spec file as given by url is not the same as in SRPM (see attached
     diff).

     Allowable diff


Diff spec file in url and in SRPM
---------------------------------
--- 909662-php-horde-Horde-View/srpm/php-horde-Horde-View.spec	2014-01-06 15:41:41.084000000 -0500
+++ 909662-php-horde-Horde-View/srpm-unpacked/php-horde-Horde-View.spec	2013-08-23 05:13:43.000000000 -0400
@@ -39,5 +39,5 @@
 Requires:       php-pear(%{pear_channel}/Horde_Util) >= 2.0.0
 Requires:       php-pear(%{pear_channel}/Horde_Util) <  3.0.0
-# Optional
+# Optionnal
 Requires:       php-pear(%{pear_channel}/Horde_Controller) >= 2.0.0
 Requires:       php-pear(%{pear_channel}/Horde_Controller) <  3.0.0
Comment 11 Shawn Iwinski 2014-01-10 14:19:20 EST
[x] EPEL5 requires explicit %clean with rm -rf %{buildroot} (or $RPM_BUILD_ROOT)
[x] EPEL5: Package does run rm -rf %{buildroot} (or $RPM_BUILD_ROOT) at the
    beginning of %install.


No blockers.


===== APPROVED =====
Comment 12 Remi Collet 2014-01-11 01:06:19 EST
Thanks!

New Package SCM Request
=======================
Package Name: php-horde-Horde-View
Short Description: Horde View API
Owners: remi
Branches: f20 el6
InitialCC:
Comment 13 Gwyn Ciesla 2014-01-13 08:11:04 EST
Git done (by process-git-requests).
Comment 14 Fedora Update System 2014-01-14 01:06:52 EST
php-horde-Horde-View-2.0.3-2.el6 has been submitted as an update for Fedora EPEL 6.
https://admin.fedoraproject.org/updates/php-horde-Horde-View-2.0.3-2.el6
Comment 15 Fedora Update System 2014-01-14 01:07:02 EST
php-horde-Horde-View-2.0.3-2.fc20 has been submitted as an update for Fedora 20.
https://admin.fedoraproject.org/updates/php-horde-Horde-View-2.0.3-2.fc20
Comment 16 Fedora Update System 2014-01-14 15:57:41 EST
php-horde-Horde-View-2.0.3-2.el6 has been pushed to the Fedora EPEL 6 testing repository.
Comment 17 Fedora Update System 2014-01-23 06:10:48 EST
php-horde-Horde-View-2.0.3-2.fc20 has been pushed to the Fedora 20 stable repository.
Comment 18 Fedora Update System 2014-01-29 16:26:14 EST
php-horde-Horde-View-2.0.3-2.el6 has been pushed to the Fedora EPEL 6 stable repository.

Note You need to log in before you can comment on or make changes to this bug.