Bug 91691 - Bad man page formatting/display
Bad man page formatting/display
Status: CLOSED RAWHIDE
Product: Red Hat Linux Beta
Classification: Retired
Component: man (Show other bugs)
alpha 1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Eido Inoue
Ben Levenson
:
: 91690 (view as bug list)
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-05-27 04:34 EDT by David Balažic
Modified: 2007-04-18 12:54 EDT (History)
1 user (show)

See Also:
Fixed In Version: 1.5m2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-01-26 19:40:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Balažic 2003-05-27 04:34:05 EDT
Description of problem:

log in as root on VT2 ,
enter : man rpm
press '/' (search ) and search for '--dump'
after the first find, press 'n' to find second occurence.
The text jumps to a new location, buth the searched string
is not on the screen, scrolling up and down reveals it.

Version-Release number of selected component (if applicable):

man-1.5k-6
less-378-7
ncurses-5.3-4
rpm-4.2-0.69
Comment 1 David Balažic 2003-05-27 04:36:33 EDT
*** Bug 91690 has been marked as a duplicate of this bug. ***
Comment 2 Miloslav Trmac 2003-07-25 19:50:16 EDT
I can reproduce the bug with
        man -P '/usr/bin/less -isr' rpm
(this -P parameter corresponds to the default way less is invoked by man), but
not with
        man -P '/usr/bin/less -is' rpm
or with
        man -P '/usr/bin/less -isR' rpm

The -r was added due to bug 11621, but it is IMHO the wrong way to fix the
original problem; nowadays, 'less' in fact initializes its charset tables
correctly from locale data, even without LESSCHARSET.

The upstream man's configure tells this:
#
# Some people prefer "-irs", but probably only when they have a broken setup.
# (Indeed, -r may cause the terminal to get into funny states.
# Very inconvenient. For viewing pages in strange locales, set LC_*.)
#
DEFAULTLESSOPT="-is"
Comment 3 Eido Inoue 2004-01-26 19:40:42 EST
1.5m2 changes the man output device to -Tutf8 and sets LESSCHARSET to
supported utf-8. "-r" is no longer included in the less options.

Works with latest rawhide release

Note You need to log in before you can comment on or make changes to this bug.