Bug 91716 - individual package selection missing
individual package selection missing
Status: CLOSED WONTFIX
Product: Red Hat Linux Beta
Classification: Retired
Component: anaconda (Show other bugs)
alpha 3
All Linux
medium Severity medium
: ---
: ---
Assigned To: Jeremy Katz
Mike McLean
:
: 92008 105646 110195 110376 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-05-27 11:52 EDT by Gene Czarcinski
Modified: 2007-04-18 12:54 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-06-29 16:54:20 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Gene Czarcinski 2003-05-27 11:52:44 EDT
Description of problem:

While you can select package groups, the option to select individual packages is
missing.
Comment 2 Chris Ricker 2003-05-29 00:37:53 EDT
I know other bug reports have said this was deliberately removed for upgrades. I
hope the plan is to still have it present for clean installs, though
Comment 3 Michael Fulbright 2003-06-10 16:29:07 EDT
*** Bug 92008 has been marked as a duplicate of this bug. ***
Comment 4 Jeremy Katz 2003-06-16 04:02:57 EDT
What packages do you want that aren't in groups?  The current plan is for this
not to return (especially as redhat-config-packages can display this now)
Comment 5 Chris Ricker 2003-06-16 05:59:40 EDT
There are a couple of reasons I want / use this:

* groups are still quite broken in a lot of ways (see various bugs about
group-level selection autoselecting crap after its manually unselected, and
about some default apps not installing even though they're selected, such as
#87591 and #75126); until those issues are fixed, group-level selection is unusable

* due to various insanities with dependencies and default values in comps.xml,
group-level selection does not allow me to install postfix and not install
sendmail (at least last time I tried; might be related to some of the above
mentioned bugs)

* ditto for things like installation of gnome slurping in all the cd-burning
crap on my laptop, which has no cd-burning hardware

Bottom line is that group-level selection, at least for me, doesn't work
flexibly enough to use

I'm starting to think, with all the removed functionality in the installer in
these alphas, that I'm only going to be doing kickstarts from now on ;-)
Comment 6 Chris Ricker 2003-06-18 02:10:52 EDT
I just did the group level stuff on alpha3. Some things that really annoyed me
in addition to the above, which in the past I'd avoided by using the individual
package selection:

* the group-level stuff is stateless between groups. Some packages are in
multiple groups. Deselecting a package in one doesn't deselect in others, and
selecting in one doesn't select in others

* selection at a group level puts lots of stuff on the system I don't want, due
to required defaults in comps.xml for each group. For example, I want gnuplot
and units, so I have to select the "Engineering and Scientific" group. If I
select this group, I get blas and lapack, with no possibility of not selecting
them.... If you're going to do group-level stuff only, no package should be
required (meaning it can't be deselected by hitting details) 
Comment 7 Gene Czarcinski 2003-09-26 12:10:34 EDT
*** Bug 105646 has been marked as a duplicate of this bug. ***
Comment 8 Miloslav Trmac 2004-03-01 04:26:57 EST
*** Bug 110376 has been marked as a duplicate of this bug. ***
Comment 9 Miloslav Trmac 2004-03-01 04:27:34 EST
*** Bug 110195 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.