Bug 920320 - cinnamon does not start
cinnamon does not start
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: cinnamon (Show other bugs)
19
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Dan Mashal
Fedora Extras Quality Assurance
RejectedBlocker AcceptedFreezeException
:
: 924097 957898 959712 (view as bug list)
Depends On:
Blocks: F19Beta-accepted/F19BetaFreezeException
  Show dependency treegraph
 
Reported: 2013-03-11 15:37 EDT by Mike FABIAN
Modified: 2013-07-13 05:30 EDT (History)
14 users (show)

See Also:
Fixed In Version: 1.8.2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-05-13 00:42:22 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
.xsession-errors (4.86 KB, text/plain)
2013-03-12 02:49 EDT, Mike FABIAN
no flags Details
screenshot (361.47 KB, image/png)
2013-05-01 03:40 EDT, Dan Mashal
no flags Details

  None (edit)
Description Mike FABIAN 2013-03-11 15:37:50 EDT
I installed rawhide in qemu-kvm by updating  from default f18 installation
in qemu using yum.

Then installed the other  desktops
with

sudo yum groupinstall gnome-desktop-environment kde-desktop-environment xfce-desktop-environment lxde-desktop-environment cinnamon-desktop-environment mate-desktop-environment sugar-desktop-environment development-tools

Then tried to start cinnamon, it fails immediately with the

“Oh no! Something has gone wrong.”

frowney screen.

(Gnome, KDE, xfce, ...  all work).

Cinnamon version:

$ rpm -q cinnamon
cinnamon-1.6.7-7.fc19.x86_64
mfabian@fedora-rawhide-x86_64:~
$ 

Which logfiles would be useful to attach?
Comment 1 Dan Mashal 2013-03-11 23:26:40 EDT
Looks like something is conflicting somewhere.

I just did a fresh install of Cinnamon using F18 netinstall CD and it works fine. 

You installed 7 different DEs. You have most likely display manager conflicts going on there.

Check your .xsession-errors and /var/log/messages.

Working fine with fresh install of F18/netinst cd/cinnamon/latest packages from updates-testing.

http://i.imgur.com/43paZZM.png
Comment 2 Mike FABIAN 2013-03-12 02:35:20 EDT
(In reply to comment #1)
> Looks like something is conflicting somewhere.
> 
> I just did a fresh install of Cinnamon using F18 netinstall CD and it works
> fine. 

Yes, it works on F18. This report is for rawhide.

> You installed 7 different DEs. You have most likely display manager
> conflicts going on there.
> 
> Check your .xsession-errors and /var/log/messages.

There is no .xsession-errors on rawhide when cinnamon starts.
Comment 3 Dan Mashal 2013-03-12 02:46:02 EDT
I remember Leigh mentioning some stuff about rawhide issues. I'll upgrade to rawhide and see if it still works.
Comment 4 Mike FABIAN 2013-03-12 02:49:00 EDT
I don’t know where gdm stores the log nowadays, it used to be here:

mfabian@fedora-rawhide-x86_64:~
$ ll .cache/gdm/session.log 
-rw-------. 1 mfabian mfabian 8757  3月  6 09:34 .cache/gdm/session.log
mfabian@fedora-rawhide-x86_64:~
$ date
2013年  3月 11日 月曜日 16:13:30 CET
mfabian@fedora-rawhide-x86_64:~
$ 

but this file is not updated on rawhide when cinnamon starts.

So I tweaked /etc/X11/xinit/Xsession a bit to get the log to ~/.xsession-errors again:

$ diff -u /etc/X11/xinit/Xsession.orig /etc/X11/xinit/Xsession
--- /etc/X11/xinit/Xsession.orig        2013-02-19 05:42:11.000000000 +0100
+++ /etc/X11/xinit/Xsession     2013-03-11 16:10:50.614457614 +0100
@@ -9,7 +9,7 @@
 # Foundation, Inc., 675 Mass Ave, Cambridge, MA 02139, USA.
 
 # redirect errors to a file in user's home directory if we can
-if [ -z "$GDMSESSION" ]; then
+if [ -z "$xxGDMSESSION" ]; then
     # GDM redirect output itself in a smarter fashion
     errfile="$HOME/.xsession-errors"
     if ( umask 077 && cp /dev/null "$errfile" 2> /dev/null ); then
mfabian@fedora-rawhide-x86_64:~
$ 

Attaching the .xsession-errors produced ...
Comment 5 Mike FABIAN 2013-03-12 02:49:54 EDT
Created attachment 708784 [details]
.xsession-errors

.xsession-errors
Comment 6 Mike FABIAN 2013-03-12 02:59:25 EDT
It seems to be looking for this file: /usr/share/gjs-1.0/dbus.js

stat("/usr/share/cinnamon/js/dbus", 0x7fffcc44cfb0) = -1 ENOENT (No such file or directory)
stat("/usr/local/share/gjs-1.0/dbus", 0x7fffcc44cfb0) = -1 ENOENT (No such file or directory)
stat("/usr/share/gjs-1.0/dbus", 0x7fffcc44cfb0) = -1 ENOENT (No such file or directory)
stat("/usr/lib64/gjs-1.0/dbus", 0x7fffcc44cfb0) = -1 ENOENT (No such file or directory)
stat("/usr/share/gjs-1.0/dbus", 0x7fffcc44cfb0) = -1 ENOENT (No such file or directory)
    JS ERROR: !!!   Exception was: Error: No JS module 'dbus' found in search path
    JS ERROR: !!!     message = '"No JS module 'dbus' found in search path"'
    JS ERROR: !!!   Exception was: Error: No JS module 'dbus' found in search path
    JS ERROR: !!!     message = '"No JS module 'dbus' found in search path"'
ウィンドウ・マネージャーの警告: Log level 32: Execution of main.js threw exception: Error: No JS module 'dbus' found in search path
Comment 7 Mike FABIAN 2013-03-12 03:01:15 EDT
F18:

mfabian@ari:~
$ cat /etc/fedora-release 
Fedora release 18 (Spherical Cow)
mfabian@ari:~
$ rpm -q gjs
gjs-1.34.0-1.fc18.x86_64
mfabian@ari:~
$ rpm -ql gjs | grep dbus.js
/usr/share/gjs-1.0/dbus.js
mfabian@ari:~
$ 


Rawhide:

$ cat  /etc/fedora-release 
Fedora release 19 (Rawhide)
mfabian@fedora-rawhide-x86_64:~
$ rpm -q gjs
gjs-1.35.8-1.fc19.x86_64
mfabian@fedora-rawhide-x86_64:~
$ rpm -ql gjs | grep dbus.js
mfabian@fedora-rawhide-x86_64:~
$
Comment 9 Dan Mashal 2013-03-15 11:14:13 EDT
I haven't seen Leigh in a few weeks so I will try and look into this.
Comment 10 leigh scott 2013-03-15 12:22:16 EDT
I'm aware of the gjs changes and started porting

https://github.com/linuxmint/Cinnamon/issues/1620

hopefully others will help as the task is beyond me.

https://github.com/linuxmint/Cinnamon/issues/1788
Comment 11 Dan Mashal 2013-03-15 13:54:42 EDT
Hi Leigh. Thanks for the reply. Glad to see you are OK.
Comment 12 leigh scott 2013-03-21 13:40:23 EDT
*** Bug 924097 has been marked as a duplicate of this bug. ***
Comment 13 Dan Mashal 2013-04-17 18:08:25 EDT
After further looking in to this, this is cause by Gnome 3.8. Upstream is looking at fixing this.

ETA: none at this time.
Comment 14 leigh scott 2013-04-30 07:15:58 EDT
*** Bug 957898 has been marked as a duplicate of this bug. ***
Comment 15 Dan Mashal 2013-05-01 03:40:14 EDT
Created attachment 742105 [details]
screenshot
Comment 16 Dan Mashal 2013-05-01 03:41:27 EDT
I have this kind of working in Fedora 19, Cinnamon 2D and 3D (3d not working as well), lightdm on top of MATE.

Proof attached.

Leigh, let's sync up on IRC or via email when you get a chance.
Comment 17 leigh scott 2013-05-06 04:46:58 EDT
*** Bug 959712 has been marked as a duplicate of this bug. ***
Comment 18 Adam Williamson 2013-05-06 12:34:00 EDT
Discussed at 2013-05-06 blocker review meeting: http://meetbot.fedoraproject.org/fedora-blocker-review/2013-05-06/f19beta-blocker-review-3.2013-05-06-16.02.log.txt . Cinnamon is not a release-blocking desktop, so this bug is by definition not a blocker. However, showstopping bugs in non-release-blocking desktops are accepted as freeze exception issues, so this is rejected as a blocker but accepted as FE.
Comment 19 Dan Mashal 2013-05-09 01:50:37 EDT
UPDATE: cinnamon 1.8.2 / muffin 1.8.0 were tested by QA and work.   Will try to get this out to the repos by the beta freeze (05-13-13).
Comment 20 Fedora Update System 2013-05-09 09:47:58 EDT
nemo-1.8.1-1.fc19,cinnamon-1.8.2-2.fc19,muffin-1.8.0-3.fc19 has been submitted as an update for Fedora 19.
https://admin.fedoraproject.org/updates/nemo-1.8.1-1.fc19,cinnamon-1.8.2-2.fc19,muffin-1.8.0-3.fc19
Comment 21 Jens Petersen 2013-05-13 00:42:22 EDT
Update has been pushed stable.

Looks good to me so far.
Comment 22 Knut J BJuland 2013-07-13 05:09:19 EDT
Please reopen as this bug have hit back in 1.9.1
Comment 23 leigh scott 2013-07-13 05:30:45 EDT
(In reply to Knut J BJuland from comment #22)
> Please reopen as this bug have hit back in 1.9.1

I doubt it's related to the original report, please post any error logs to confirm this.
Did you install any thirdparty applets, extensions or desklets as they haven't been ported for the gjs/gnome-3.8 changes.

Note You need to log in before you can comment on or make changes to this bug.