Bug 971230 - Use BR: harfbuzz-icu-devel
Use BR: harfbuzz-icu-devel
Status: CLOSED WONTFIX
Product: Fedora
Classification: Fedora
Component: libreoffice (Show other bugs)
19
Unspecified Unspecified
unspecified Severity unspecified
: ---
: ---
Assigned To: David Tardon
Fedora Extras Quality Assurance
:
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2013-06-06 00:18 EDT by Parag Nemade
Modified: 2013-06-07 08:21 EDT (History)
14 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-06-07 08:21:23 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Parag Nemade 2013-06-06 00:18:06 EDT
Description of problem:
With the release of upstream harfbuzz-0.9.18, upstream recommended to split package into harfbuzz and harfbuzz-icu. I have built a new harfbuzz-0.9.18 package it F19 and devel.

Libreoffice spec file will need to use harfbuzz-icu as BR

Version-Release number of selected component (if applicable):
libreoffice-4.1.0.0-6.beta1.fc19

How reproducible:
always.

Steps to Reproduce:
1.
2.
3.

Actual results:


Expected results:


Additional info:
Comment 1 David Tardon 2013-06-06 01:58:51 EDT
I have changed the BuildRequires to harfbuzz-icu-devel for the upcoming 4.1.0 beta2 package.
Comment 2 Parag Nemade 2013-06-06 02:09:33 EDT
Thanks.
Comment 3 David Tardon 2013-06-06 02:16:50 EDT
... that is, i will do it when the new harfbuzz is available.
Comment 4 David Tardon 2013-06-07 03:21:11 EDT
*** Bug 971566 has been marked as a duplicate of this bug. ***
Comment 5 Akira TAGOH 2013-06-07 04:04:21 EDT
IMHO the kind of this breakage shouldn't happen at this stage. f19 Beta was already out. that looks better rolling harfbuzz back to 0.9.17.
Comment 6 Michael Schwendt 2013-06-07 06:35:32 EDT
*** Bug 971703 has been marked as a duplicate of this bug. ***
Comment 7 Caolan McNamara 2013-06-07 07:55:39 EDT
*** Bug 971829 has been marked as a duplicate of this bug. ***
Comment 8 peter.senna 2013-06-07 08:03:11 EDT
Are there any work around so I can use Libreoffice until it is fixed?
Comment 9 Parag Nemade 2013-06-07 08:19:42 EDT
Downgrading harfbuzz to 0.9.17-1 should fix breakage temporarily. New libreoffice build is currently building on koji will fix breakage issue.
Comment 10 David Tardon 2013-06-07 08:21:23 EDT
It turns out the BR change is not necessary after all (bug 971795).

Note You need to log in before you can comment on or make changes to this bug.