Bug 977029 - new bugs shown as both reported and unreported [NEEDINFO]
new bugs shown as both reported and unreported
Status: CLOSED ERRATA
Product: Fedora
Classification: Fedora
Component: gnome-abrt (Show other bugs)
18
x86_64 Linux
unspecified Severity medium
: ---
: ---
Assigned To: Jakub Filak
Fedora Extras Quality Assurance
:
: 982763 983775 (view as bug list)
Depends On:
Blocks: 1015609
  Show dependency treegraph
 
Reported: 2013-06-22 14:23 EDT by Dean Hunter
Modified: 2016-11-30 19:44 EST (History)
11 users (show)

See Also:
Fixed In Version: gnome-abrt-0.3.3-1.fc18
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-11-13 22:30:02 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
tech: needinfo? (extras-qa)


Attachments (Terms of Use)
"Reported: yes" vs. "This problem hasn't been reported ...." (73.72 KB, image/png)
2013-06-24 12:30 EDT, Dean Hunter
no flags Details

  None (edit)
Description Dean Hunter 2013-06-22 14:23:46 EDT
Description of problem:

The Automatic Bug Reporting Tool shows new bugs as:

  Reported  yes

but also displays the message:

  This problem hasn't been reported to Bugzilla
  yet. Our developers may need more information
  to fix the problem.
  Please consider reporting it - you may help
  them. Thank you.

This is confusing with a "Report" button in the upper right-hand corner of the window. What does "Reported  yes" mean in this context? 

Please also consider:

1) Disabling the "Report" button when a bug report summary is displayed

2) Use more of the space to the left of the bug number to display the bug report summary in a wrapped text control instead of the horizontally scrolled control.


Version-Release number of selected component (if applicable):

abrt-2.1.4-3.fc18.x86_64


How reproducible: Consistent
Comment 1 Jakub Filak 2013-06-24 04:09:47 EDT
(In reply to Dean Hunter from comment #0)
> This is confusing with a "Report" button in the upper right-hand corner of
> the window. What does "Reported  yes" mean in this context? 

"Reported yes" in fact means that reported_to problem element contains some entry. When you see the suggestion, the bug has been reported to ABRT server[1] only. Please, see bug #910317 for more details.

> 1) Disabling the "Report" button when a bug report summary is displayed

That's an interesting idea, but "Report" button can start reporting to various bug tracking tools. Thus gnome-abrt cannot make the decision if the bug is completely reported to all desired tools and then disable the button.

> 2) Use more of the space to the left of the bug number to display the bug
> report summary in a wrapped text control instead of the horizontally
> scrolled control.

Could you please file a new bugzilla bug against gnome-abrt and attach a screenshot of the unfriendly horizontal scroll bars? I want to be completely sure that I know what you mean.


1: https://retrace.fedoraproject.org/faf/summary/
Comment 2 Dean Hunter 2013-06-24 09:12:37 EDT
Please advise how to get a screen shot of just the Automatic Bug Reporting Tool window.  I know there is a keystroke combination that copies the active window to the clipboard, but I do not remember the combination.  Then which application should I paste the clipboard into?  I used to know where to find the image bit fiddler application, but it has all changed and I do not use it often enough to remember yet.  I apologize for being so clumsy.
Comment 3 Jiri Moskovcak 2013-06-24 10:44:15 EDT
It depends the desktop you're using, in GNOME it's Alt + printscreen and the result is saved in $HOME/Pictures.
Comment 4 Dean Hunter 2013-06-24 12:05:59 EDT
Thank you. That is different, and simpler, than what I thought I remembered.

977029 opened with a screen shot as requested.
Comment 5 Dean Hunter 2013-06-24 12:29:02 EDT
I do not understand how bug #910317 applies to my situation.
Comment 6 Dean Hunter 2013-06-24 12:30:22 EDT
Created attachment 764694 [details]
"Reported: yes" vs. "This problem hasn't been reported ...."
Comment 7 Jakub Filak 2013-06-28 03:36:48 EDT
(In reply to Dean Hunter from comment #5)
> I do not understand how bug #910317 applies to my situation.

"I suggest that abrt main window should ask the user to report a bug to bugzilla, if that particular bug has no bugzilla entry yet." [bug #910317 comment #0]

It clarifies why the suggestion message is displayed in the window. The problem has not been reported to Bugzilla yet, however the problem may have been already reported to some other bug tracking tool (in your case to ABRT server).

Is this explanation satisfactory? If so, we can close the bug as NOTABUG.
Comment 8 Dean Hunter 2013-06-28 17:39:58 EDT
I am sorry, but I am very confused. What is the ABRT server?
Comment 9 Jakub Filak 2013-07-01 12:01:03 EDT
(In reply to Dean Hunter from comment #8)
> I am sorry, but I am very confused. What is the ABRT server?

The ABRT server is an instance of FAF [1]. In short, it is something like Bugzilla but it is focused on automatic bug reporting and handling of large amount of data. The ABRT server tries to triage bug reports and filter out noise. Always when you report a problem, ABRT client sends an uReport to the ABRT server and after that the client continues in reporting to the Bugzilla if it is necessary.

1: https://github.com/abrt/faf/wiki
Comment 10 Dean Hunter 2013-07-01 18:08:46 EDT
Where should I have found this explanation?  I clearly missed this somewhere and I would have never figured it out from the display.  I would like to see a better explanation.  I am also confused by why sometimes ABRT automatically reports to RedHat Bugzilla and sometimes it does not.  And when should I delete entries from ABRT?
Comment 11 Jakub Filak 2013-07-10 03:30:24 EDT
*** Bug 982763 has been marked as a duplicate of this bug. ***
Comment 12 Jakub Filak 2013-07-12 01:51:19 EDT
*** Bug 983775 has been marked as a duplicate of this bug. ***
Comment 13 KitchM 2013-07-12 14:00:44 EDT
Yes, there still is a problem, and it still exists as of FC19.

Here's what needs to be done to ABRT's user interface:
1. Make sure that it means what it says.  If it says that the bug has been reported, then let it mean that.  If it means something else, then rephrase the interface to state it correctly.  Do not allow the user to be confused.
2. Make sure the all areas of the window's content agree with each other.  The interface cannot state one thing that is diametrically opposed to another statement in the same interface window, as seen by the user.
3. Understand that the user knows nothing but what the interface states.  If the user is to know something more, than make sure it is clearly defined within that interface window.  Otherwise, the programming is not finished correctly.

Thank you.
Comment 14 Jakub Filak 2013-07-12 17:32:08 EDT
(In reply to KitchM from comment #13)
Thank you for your comment.

I see two possible solutions here:
1. Change the label from 'Reported' to 'Processed' (because the Bugzilla is not the only bug tracking tool where users can report their problems) (IMHO 'Processed' is confusing and unsatisfactory, because gnome-abrt wants to say that user does not have to go through the process of filing a bugzilla bug, it is optional, the bug has been already reported and no more action is necessary if user does not want to participate in solving of the bug)

2. Rephrase the suggestion message:
This problem hasn't been associated with any Bugzilla bug yet. Our developers may need more information to fix the problem. Please consider filing a new Bugzilla bug for this problem - you may help them. Thank you. (users are still confused because they think that the Bugzilla is the only bucktracking tool where problems are reported)

Please, help me. Which one is better? Or none?
Comment 15 KitchM 2013-07-14 00:28:35 EDT
Okay, how about this.

Your premise for number one is wrong in a couple points:
First, I really don't believe users call it gnome-abrt; I know I certainly don't.  It is just the Automatic Bug Report Tool.  Period.
Second, I did not know that Fedora/RedHat used anything other than buzilla.
Third, one should not assume in any case that the user does not want to participate in the solution to the bug.

All we care about is if it has been reported to bugzilla.redhat.com, or not.  It is, after all, why we use it.  So it must be kept in simply stating if it has been reported or not.  If it can give the user to give other information, then it should have a place for that follow-up to the existing bug.

Number two is odd and difficult for me to understand.  Isn't that all covered in my response to number one?
First of all, we do not want to encourage people to make duplicate bug reports.  That isn't wise.
Second,Bugzilla is indeed the only place that Fedora/RedHat users would go to file bug reports, since every single program is handled thru it.
Third, the program should offer the user to comment further on the same bug, it it has already been reported, as I suggested before.  It would then offer the connection to the bug directly or a form that it will transmit for the user.

How about that?
Comment 16 Jakub Filak 2013-08-15 10:28:00 EDT
Well, I'm a bit lost in your reply. What is your proposed solution? And I'm sorry but we don't want to convert Automatic Bug Report Tool (the GUI part (gnome-abrt)) to a Bugzilla client.

Please read this email and maybe you will understand our efforts.
https://mail.gnome.org/archives/gnomecc-list/2012-November/msg00006.html

Even reporting to ABRT server makes Fedora desktop team happy. It is not necessary to report all crashes to Bugzilla.
https://plus.google.com/u/0/112174839778779720402/posts/UaGWHv4BEqs
Comment 17 David Woodhouse 2013-08-15 11:38:24 EDT
I don't really care too much what the solution is, as long as we don't continue to have a UI which simultaneously says:
 "Reported: yes"
and
 "This problem hasn't been reported to Bugzilla yet".

It's all very well explaining *here* that the first 'reported' means to something *other* than bugzilla, so the tool isn't really contradicting itself.

That explanation shouldn't be necessary. Please fix the UI so that it doesn't *need* such an explanation.
Comment 18 KitchM 2013-08-15 13:33:59 EDT
@Jakub
Okay let me just start with one thing.

What do you see as the purpose for ABRT?
Comment 19 Jiri Moskovcak 2013-08-16 03:06:30 EDT
(In reply to KitchM from comment #18)
> @Jakub
> Okay let me just start with one thing.
> 
> What do you see as the purpose for ABRT?

- reporting bugs, which doesn't imply "reporting bugs to bugzilla.redhat.com"

If you have problems with how the reporting process is works, please contact our design team https://fedorahosted.org/design-team/ and help them design a new better way of reporting or you can just start a discussion on fedora-devel about it, but we will not change the workflow which works form a lot user just because 1 user thinks differently. 

@david: yes, the ui message is a bit confusing we'll try to improve it somehow
Comment 20 KitchM 2013-08-16 13:08:34 EDT
(In reply to Jiri Moskovcak from comment #19)
> (In reply to KitchM from comment #18)
> > @Jakub
> > Okay let me just start with one thing.
> > 
> > What do you see as the purpose for ABRT?
> 
> - reporting bugs, which doesn't imply "reporting bugs to bugzilla.redhat.com"

Exactly as I had thought, and exactly has I had been addressing the issue.

Now that we agree on that, we can make progress on the problem.


> If you have problems with how the reporting process is works, please contact
> our design team https://fedorahosted.org/design-team/ and help them design a
> new better way of reporting or you can just start a discussion on
> fedora-devel about it, but we will not change the workflow which works form
> a lot user just because 1 user thinks differently. 
> 
> @david: yes, the ui message is a bit confusing we'll try to improve it
> somehow

Well, yes we have problems with how it works.  That is the whole point of this bug report!  Why did you not understand that?

Further, why did you not understand my suggestions for fixing the problem?  Perhaps we need someone in on this who can understand the extremely clear issue that Dean presented in the first place and David and I supported.

This is a real problem, and it is serious enough for real serious consideration, and for immediate rectifying.
Comment 21 Jakub Filak 2013-09-18 10:03:14 EDT
I've created 2 pull request which are supposed to fix this bug:
https://github.com/abrt/libreport/pull/178
https://github.com/abrt/gnome-abrt/pull/33
Comment 22 KitchM 2013-09-18 11:29:49 EDT
Thank you.
Comment 23 Jakub Filak 2013-09-19 05:11:08 EDT
Fixed in upstream git:

libreport:

commit d7a4e87987bdb7d676a081a508fdd6fe7246ac62

gnome-abrt:

commit b641735e9993b8681af75ce29a86e88172fefb34
commit 54548dfabb4e41072bc48a1695c0587e6b06b594
Comment 24 Fedora Update System 2013-10-14 04:27:52 EDT
gnome-abrt-0.3.2-1.fc18,abrt-2.1.8-1.fc18,libreport-2.1.8-2.fc18,satyr-0.10-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/gnome-abrt-0.3.2-1.fc18,abrt-2.1.8-1.fc18,libreport-2.1.8-2.fc18,satyr-0.10-1.fc18
Comment 25 Fedora Update System 2013-10-18 15:32:51 EDT
Package gnome-abrt-0.3.2-1.fc18, abrt-2.1.8-1.fc18, libreport-2.1.8-2.fc18, satyr-0.10-1.fc18:
* should fix your issue,
* was pushed to the Fedora 18 testing repository,
* should be available at your local mirror within two days.
Update it with:
# su -c 'yum update --enablerepo=updates-testing gnome-abrt-0.3.2-1.fc18 abrt-2.1.8-1.fc18 libreport-2.1.8-2.fc18 satyr-0.10-1.fc18'
as soon as you are able to.
Please go to the following url:
https://admin.fedoraproject.org/updates/FEDORA-2013-19232/gnome-abrt-0.3.2-1.fc18,abrt-2.1.8-1.fc18,libreport-2.1.8-2.fc18,satyr-0.10-1.fc18
then log in and leave karma (feedback).
Comment 26 Fedora Update System 2013-10-29 01:02:01 EDT
gnome-abrt-0.3.3-1.fc18,abrt-2.1.9-1.fc18,libreport-2.1.9-1.fc18,satyr-0.11-1.fc18 has been submitted as an update for Fedora 18.
https://admin.fedoraproject.org/updates/gnome-abrt-0.3.3-1.fc18,abrt-2.1.9-1.fc18,libreport-2.1.9-1.fc18,satyr-0.11-1.fc18
Comment 27 Fedora Update System 2013-11-13 22:30:02 EST
gnome-abrt-0.3.3-1.fc18, abrt-2.1.9-1.fc18, libreport-2.1.9-1.fc18, satyr-0.11-1.fc18 has been pushed to the Fedora 18 stable repository.  If problems still persist, please make note of it in this bug report.

Note You need to log in before you can comment on or make changes to this bug.