Bug 980162 - configuring direct-lun using lun which is already part of SD should be notified
configuring direct-lun using lun which is already part of SD should be notified
Status: CLOSED NOTABUG
Product: Red Hat Enterprise Virtualization Manager
Classification: Red Hat
Component: ovirt-engine (Show other bugs)
3.2.0
Unspecified Unspecified
unspecified Severity high
: ---
: 3.4.0
Assigned To: Tal Nisan
Aharon Canan
storage
: Triaged
: 879293 1096904 (view as bug list)
Depends On:
Blocks: 889053 910990 977679 977681
  Show dependency treegraph
 
Reported: 2013-07-01 10:55 EDT by Aharon Canan
Modified: 2016-02-10 14:11 EST (History)
13 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-12-09 11:26:44 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: Storage
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---
scohen: needinfo+


Attachments (Terms of Use)
screenshot (102.63 KB, image/png)
2013-12-04 09:23 EST, Elad
no flags Details

  None (edit)
Description Aharon Canan 2013-07-01 10:55:55 EDT
Description of problem:
=======================
engine should not allow user to use used luns within the same engine for creation of new disk or storage domain

Version-Release number of selected component (if applicable):
=============================================================
3.2


How reproducible:
=================
100%

Steps to Reproduce:
===================
1. Create new VM
2. attached direct-lun disk (Disk should be already in use by another storage domain) to that VM - 
3. start the VM

Actual results:
===============
able to attached direct-lun, cause data corruption

Expected results:
=================
user shouldn't be able to attached disk that already part of another storage domain

Additional info:
Comment 1 Itamar Heim 2013-07-02 04:41:16 EDT
not sure we should/can block this for now - ManageIQ (CloudForms) and other vendors are using this technique to analyze the disks on storage today.
Comment 3 Allon Mureinik 2013-12-03 05:30:38 EST
Is this via the webadmin? REST? 
Can we get a log? screenshot?
Comment 4 Elad 2013-12-04 09:23:28 EST
Created attachment 832683 [details]
screenshot

Allon,
Check on webadmin,
We get a red warning on the disk creation window when we pick a LUN which is already part of a SD.

Attaching screenshot
Comment 5 Allon Mureinik 2013-12-04 10:01:15 EST
AFAIK, Itamar is correct (see comment 1) - ManageIQ needs this feature, so we can only warn about it, not block the operation.

Sean, can you confirm?
Comment 6 Sean Cohen 2013-12-08 03:45:55 EST
(In reply to Allon Mureinik from comment #5)
> AFAIK, Itamar is correct (see comment 1) - ManageIQ needs this feature, so
> we can only warn about it, not block the operation.
> 
> Sean, can you confirm?

Confirmed, this operation should not be blocked. Cloudforms & other clusters solutions require it today,
However, we can notify the user that the direct LUN is already used in another VM and ask user to confirm the operation.
Changing the bug title accordingly
Sean
Comment 7 Allon Mureinik 2013-12-09 11:26:44 EST
The warning is already there (see snapshot), and the operation should not be blocked (see comment 6).
Based on these inputs, I'm closing the bug.
Comment 8 Daniel Erez 2013-12-23 08:24:55 EST
*** Bug 879293 has been marked as a duplicate of this bug. ***
Comment 9 Daniel Erez 2014-05-12 18:23:14 EDT
*** Bug 1096904 has been marked as a duplicate of this bug. ***
Comment 10 Nicolas Ecarnot 2015-04-09 10:20:18 EDT
Before trying to do the same thing (ie. direct attach to a LUN), to try to follow the doc here (http://manageiq.org/documentation/top-tasks/#run-smartstate-analysis-on-rhev-m-virtual-machines), is it harmless to do so?

Is it recommended to attach it with read only checkbox checked?
Comment 11 Allon Mureinik 2015-04-09 10:39:41 EDT
(In reply to Nicolas Ecarnot from comment #10)
> Before trying to do the same thing (ie. direct attach to a LUN), to try to
> follow the doc here
> (http://manageiq.org/documentation/top-tasks/#run-smartstate-analysis-on-
> rhev-m-virtual-machines), is it harmless to do so?
> 
> Is it recommended to attach it with read only checkbox checked?

SmartState analysis is perfectly safe.
I'm not an expert on the details, but using read-only sounds like a good idea.

Note You need to log in before you can comment on or make changes to this bug.