Bug 981118 - RFE: Provide a way of enabling a standardized Author_Group.xml file
RFE: Provide a way of enabling a standardized Author_Group.xml file
Status: CLOSED CURRENTRELEASE
Product: PressGang CCMS
Classification: Community
Component: CSProcessor (Show other bugs)
1.1
Unspecified Unspecified
unspecified Severity unspecified
: ---
: 1.2
Assigned To: Lee Newson
:
: 1011898 (view as bug list)
Depends On:
Blocks: 982076 1013825
  Show dependency treegraph
 
Reported: 2013-07-04 01:08 EDT by lcarlon
Modified: 2013-10-17 21:36 EDT (History)
6 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2013-10-17 19:49:16 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description lcarlon 2013-07-04 01:08:04 EDT
Currently, it is necessary to override the Author_Group.xml file every time a book is downloaded with the CSProcessor if the docs team uses a different author_group.xml file to the standard file provided by the CCMS. The override is used, for example, to list the author as "Red Hat Content Services".

If it's possible to provide a switch in the CSP map that docs leads could activate to skip the override that would be very helpful. Similar to the 'bug links =' switch.

Thanks
Lee
Comment 1 Misty Stanley-Jones 2013-07-24 21:46:38 EDT
Actually there are other ways to implement this. Here are some ideas.

1. Make it CSP-specific. Allow multiple AUTHOR= statements in the front-matter. Alternately, allow a chunk of XML in the front-matter and this would be inserted into the Author Group bit automatically. The second way may be messy.

2. Allow us to specify an Author Group file in the same way that we can specify a Revision History, Feedback, or Legal Notice override.

Actually, more generically, new content specs should probably include a new Author Group and Revision History file by default, in the front-matter. WDYT?
Comment 2 Lee Newson 2013-07-24 21:57:28 EDT
Yeah, 2 was the approach I was thinking of personally, as 1 has the potential to get really messy if have a lot of writers and 2 is more customisable.

As for the other suggestion I can see pros/cons and is probably better suited to its own RFE, but here are some points quickly:

1. If you are importing a book then you more than likely won't want a rev history/author group created when creating the spec.
2. What if you want to just use the defaults? You are then going to have orphan topics created that will never be used.

The above is void if you are just referring to the template though...
Comment 3 Misty Stanley-Jones 2013-07-24 21:59:32 EDT
Yes I'm only referring to the templates. For importing a book, you wouldn't be using the template, but rather the spec generated by the import tool. In that case, the Author_Group.xml and Revision_History.xml should be imported into topics as well. They are not right now, but I have asked Dan for this RFE in Chopbook. Adding him to the CC of this bug so he can comment.
Comment 4 lcarlon 2013-07-25 00:24:21 EDT
(In reply to Misty Stanley-Jones from comment #1)
> Actually there are other ways to implement this. Here are some ideas.
> 
> 2. Allow us to specify an Author Group file in the same way that we can
> specify a Revision History, Feedback, or Legal Notice override.

I think option 2 for the reason you mentioned.
Comment 5 Lee Newson 2013-09-25 18:50:43 EDT
*** Bug 1011898 has been marked as a duplicate of this bug. ***
Comment 6 Ruediger Landmann 2013-09-30 00:59:30 EDT
I'm removing this as a blocker for Platform R&D because on further reflection, I think implementing the various missing roles on a per-topic basis where possible and specifying them individually on a book basis where necessary makes better sense. 

From a platform point-of-view, bug 1012209 bug 1013433 and bug 1013436 together better provide the functionality missing here.

I think that Book-level credits should be additive to topic-level credits; so for books that seek to override or conceal the dynamically generated Author_Group, supplying a separate Author_Group file or an author_group override in the topic map would still be necessary. That kind of override isn't needed for platform though.
Comment 9 Matthew Casperson 2013-10-15 01:41:44 EDT
Confirmed that the Author Group topic needs the corresponding tag, and that when assigned to a spec will overwrite the Author_Group.xml file.

However with an author group topic assigned, all the topics lost their fixed url name, and reverted back to something like "TopicID8199.xml".
Comment 10 Matthew Casperson 2013-10-15 01:47:34 EDT
Confirmed that removing the Author Group metadata element means the topics get their fixed url file names.
Comment 12 Lee Newson 2013-10-15 01:50:27 EDT
That sounds like an issue in the fixed url pass which has nothing to do with this RFE, though we'll still need to find out why it's failing.
Comment 14 Lee Newson 2013-10-15 02:50:02 EDT
Fixed in 1.2-SNAPSHOT build 201310151644

As previously mentioned it was an unrelated server bug that was causing the fixed url pass to fail. I've also updated the builder to add an error message that it failed.
Comment 15 Lee Newson 2013-10-16 01:50:49 EDT
Verified that this now works by deleting the Fixed URL of the Author Group and rebuilding. The links still remained in their human readable form and the Author Groups fixed url was re-created.
Comment 16 Lee Newson 2013-10-17 21:36:48 EDT
Missed an important note about this that came up today. Due to the elements that are allowed in an <authorgroup> there isn't anyway to inject editor or bug links, so custom author groups won't have them included.

Also if an author group is invalid it will be replaced by the default author group and an error will be included in the Compiler Output chapter.

Note You need to log in before you can comment on or make changes to this bug.