Bug 98520 - UTF-8 locale and empty tips
UTF-8 locale and empty tips
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: gimp (Show other bugs)
1
All Linux
medium Severity medium
: ---
: ---
Assigned To: Nils Philippsen
David Lawrence
: i18n
: 110329 (view as bug list)
Depends On: 101377
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-03 04:04 EDT by Akira TAGOH
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version: 1.2.5-2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-09-12 23:32:11 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
proposed patch (753 bytes, patch)
2003-12-10 20:55 EST, Akira TAGOH
no flags Details | Diff
patch to iconv UTF-8 tips files to the native locale (1.71 KB, patch)
2003-12-24 01:35 EST, Akira TAGOH
no flags Details | Diff
overhauled patch to iconv UTF-8 tips files to the native locale (1.31 KB, patch)
2004-04-08 05:01 EDT, Nils Philippsen
no flags Details | Diff
fixed overhauled patch to iconv UTF-8 tips files to the native locale (1.31 KB, patch)
2004-04-08 05:19 EDT, Nils Philippsen
no flags Details | Diff

  None (edit)
Description Akira TAGOH 2003-07-03 04:04:51 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; ja-JP; rv:1.2.1) Gecko/20030225

Description of problem:
When I run GIMP with UTF-8 locale, empty tips are displayed so that the tips
files is stored as the legacy encoding.

Version-Release number of selected component (if applicable):


How reproducible:
Always

Steps to Reproduce:
1.LANG=ja_JP.UTF-8 gimp, for example
2.
3.
    

Additional info:
Comment 1 Leon Ho 2003-08-04 22:40:48 EDT
Okay.. Should we iconv all tips text file to UTF-8 for Cambridge?
Comment 2 Akira TAGOH 2003-08-05 09:18:10 EDT
Yes, it should solves this problem.
Comment 3 Akira TAGOH 2003-12-10 20:55:26 EST
Created attachment 96465 [details]
proposed patch

the encoding of tips files can be guessed from the po files, I think. so
attached patch will just try to convert all tips files to UTF-8.
Comment 4 Matt Wilson 2003-12-15 14:45:29 EST
*** Bug 110329 has been marked as a duplicate of this bug. ***
Comment 5 Akira TAGOH 2003-12-24 01:35:31 EST
Created attachment 96690 [details]
patch to iconv UTF-8 tips files to the native locale

This patch also supports to be ran on the native locale.
Comment 6 Akira TAGOH 2004-04-07 00:50:11 EDT
how is this going on? and can we get a chance to fix this on FC1 updates?
This problem causes really unusable for the newbie gimp users who want
to know the tips on Japanese.
Comment 7 Nils Philippsen 2004-04-08 04:13:57 EDT
I'm looking at the patch now and will likely put an updated package
out soon.
Comment 8 Nils Philippsen 2004-04-08 04:15:09 EDT
BTW: Am I supposed to apply both patches or only the second one?
Comment 9 Nils Philippsen 2004-04-08 04:52:31 EDT
I looked at your second patch and it seems like it isn't quite
consistent in using newly allocated and static strings... Guess I'll
need to overhaul the patch a bit.
Comment 10 Nils Philippsen 2004-04-08 05:01:52 EDT
Created attachment 99229 [details]
overhauled patch to iconv UTF-8 tips files to the native locale

this patch strdup()s in store_tip() so we only have newly allocated strings in
tips_text[].
Comment 11 Nils Philippsen 2004-04-08 05:19:54 EDT
Created attachment 99230 [details]
fixed overhauled patch to iconv UTF-8 tips files to the native locale

D'oh
Comment 12 Nils Philippsen 2004-04-08 05:42:40 EDT
Guess I'll have to apply the first patch as well...
Comment 13 Akira TAGOH 2004-04-08 23:26:23 EDT
Yes, the patch is assuming all of po files are UTF-8.
Comment 14 Nils Philippsen 2004-04-16 08:49:42 EDT
please test gimp-1.2.5-2
Comment 15 Akira TAGOH 2004-04-18 22:51:03 EDT
confirmed the fix. thanks.
Comment 16 Akira TAGOH 2004-05-17 05:01:33 EDT
doh, this package wasn't pushed to FC1-updates. reopening and
reverting the status.
Comment 17 Lawrence Lim 2004-09-12 23:32:11 EDT
Confirmed fixed in FC1-update; gimp-1.2.5-2

Tested in the following locale:
ja_JP
ja_JP.UTF-8
ko_KR
ko_KR.UTF-8
zh_CN.GB18030
zh_CN.UTF-8
zh_TW.Bug5
zh_TW.UTF-8


Thanks,
Lawrence

Note You need to log in before you can comment on or make changes to this bug.