Bug 99444 - Graphical boot hangs box
Graphical boot hangs box
Status: CLOSED NEXTRELEASE
Product: Red Hat Linux Beta
Classification: Retired
Component: kernel (Show other bugs)
beta1
All Linux
high Severity high
: ---
: ---
Assigned To: Arjan van de Ven
Brian Brock
:
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-07-19 14:27 EDT by Alan Cox
Modified: 2005-10-31 17:00 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-02-28 10:04:42 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
screen grab of strace'd kudzu startup (602.90 KB, image/jpeg)
2003-10-22 08:24 EDT, Dave Jones
no flags Details

  None (edit)
Description Alan Cox 2003-07-19 14:27:58 EDT
This system is reliable in Alphs3 but in Beta1 it gets to probing hardware fades
it hangs dead, no keyboard lights. This makes the entire beta impossible to use
so I've marked it as high/high.
Comment 1 Alan Cox 2003-07-19 18:14:51 EDT
The trigger for these hangs turns out to be kudzu. If kudzu runs the machine
crashes a little while later without kudzu its fine

Comment 2 Bill Nottingham 2003-07-19 23:28:04 EDT
Does this box have firewire?
Comment 3 Alan Cox 2003-07-20 07:56:56 EDT
No its pre firewire era hardware: 

AMD751/756 chipset (DVD-ROM drive on the onboard IDE)
PS/2 keyboard
PS/2 mouse (2 button - old microsoft)
USB (unused)
3 quad head S3 video cards (unused)
Nvidia Riva 128 AGP video (dual head, 1 used)
ISA SCSI card (unused)
3com 3c590 (used)
CMD680 PCI IDE controller (with disks on)

Alpha3 is fine, 9.0 is fine.
Comment 4 Bill Nottingham 2003-07-20 23:07:45 EDT
Does it persist when running kudzu post-boot? If so, what does a strace (or
similar) say when it's failing?
Comment 5 Alan Cox 2003-08-14 05:15:34 EDT
Running kudzu makes the box crash a bit later, it doesnt crash while kudzu is
running just later on
Comment 6 Bill Nottingham 2003-08-14 12:17:00 EDT
If you're in text mode, do you get any kernel output when it crashes?
Comment 7 Alan Cox 2003-08-14 12:38:32 EDT
Nope it just stops
Comment 8 Warren Togami 2003-09-21 07:46:12 EDT
Alan, you were experiencing a total system lockup?  In Bug 99528 I experienced
only a frozen boot process while I am still able to switch VT's.  After killing
rhgb's X in VT7 with CTRL-ALT-Backspace then hitting ALT-F7, I see a corrupted
looking kudzu that seems frozen.

I suspect that Bug 99528 and Bug 91697 are duplicates of this bug, although only
99528 is public.  Can we unhide this one?

Bug 100894 is related, perhaps another duplicate.
Comment 9 Warren Togami 2003-09-21 07:52:55 EDT
Bug 100925 also related.
Perhaps one bug should be an umbrella bug for "kudzu GUI" so we can clearly
eliminate duplicates?
Comment 10 Alan Cox 2003-09-21 09:12:05 EDT
It was a total lockup yes
Comment 11 Warren Togami 2003-09-21 16:32:11 EDT
Bug 102647 also related.
Comment 12 Bill Nottingham 2003-10-21 16:31:40 EDT
Assigning to kernel, nothing kudzu does should kill the box.
Comment 13 Dave Jones 2003-10-22 08:24:35 EDT
Created attachment 95382 [details]
screen grab of strace'd kudzu startup

I see this too occasionally, but only on my Vaio. Can't reproduce it at all on
any of my other systems. Attached is a screengrab of an strace during startup.
It always hangs in the same place.
Comment 14 Alan Cox 2004-02-28 10:04:15 EST
Really quite weird, but FC2test1 no longer triggers this problem so
whatever caused it has gone away somewhere.


Note You need to log in before you can comment on or make changes to this bug.