Bug 106796

Summary: redhat-config-boot fails to start
Product: [Retired] Red Hat Raw Hide Reporter: Daniel Malmgren <dm>
Component: redhat-config-bootAssignee: Harald Hoyer <harald>
Status: CLOSED RAWHIDE QA Contact: David Lawrence <dkl>
Severity: medium Docs Contact:
Priority: medium    
Version: 1.0CC: johan.dahl, mkanat, robatino, u2561633
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2003-11-06 10:12:03 UTC Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: --- Target Upstream Version:
Bug Depends On:    
Bug Blocks: 100643    
Description Flags
My grub.conf
redhat-config-boot-0.1.6-1 unhandled exception
Output of 'strace -o strace.out redhat-config-boot' none

Description Daniel Malmgren 2003-10-10 17:27:34 UTC
Description of problem:
redhat-config-boot fails with error messages.

Version-Release number of selected component (if applicable):

How reproducible:

Steps to Reproduce:
1. Start it
Actual results:
[root@Datorn root]# redhat-config-boot
Traceback (most recent call last):
  File "/usr/share/redhat-config-boot/redhat-config-boot.py", line 13, in ?
  File "/usr/share/redhat-config-boot/boot_gui.py", line 272, in stand_alone
  File "/usr/share/redhat-config-boot/boot_gui.py", line 86, in setupScreen
  File "/usr/share/redhat-config-boot/boot_gui.py", line 130, in readBootDB
    if tokens[0] == "title":
IndexError: list index out of range

Additional info:
It has been like this since the first release of redhat-config-boot. Using
latest rawhide rpm's of everything that could possibly have any relevance.

Comment 1 Daniel Malmgren 2003-10-14 16:30:40 UTC
Can someone please explain to me why this bug is closed? It fur sure isn't fixed!

Comment 2 Harald Hoyer 2003-10-14 16:46:27 UTC
should be fixed in 0.1.4

Comment 3 Daniel Malmgren 2003-10-16 15:54:59 UTC
Created attachment 95228 [details]
My grub.conf

Comment 4 Daniel Malmgren 2003-10-16 15:56:35 UTC
Nope. I get the exact same error in 0.1.4 (except now it's line 22 instead of 13).
I don't know if it's something with my grub.conf? Attaching file...

Comment 5 Harald Hoyer 2003-10-27 13:16:22 UTC
should be fixed with 0.1.5

Comment 6 Daniel Malmgren 2003-10-28 16:16:24 UTC
It's not exactly the same fault this time, but I guess I'll just reopen this bug
anyway. In 0.1.5 I get this:

Traceback (most recent call last):
  File "/usr/share/redhat-config-boot/redhat-config-boot.py", line 22, in ?
  File "/usr/share/firstboot/modules/boot_gui.py", line 275, in stand_alone
  File "/usr/share/firstboot/modules/boot_gui.py", line 87, in setupScreen
  File "/usr/share/firstboot/modules/boot_gui.py", line 178, in setDefault
AttributeError: BootWindow instance has no attribute 'probedTimeout'

Comment 7 Bill Nottingham 2003-10-28 22:02:45 UTC
*** Bug 108254 has been marked as a duplicate of this bug. ***

Comment 8 Need Real Name 2003-10-29 13:37:15 UTC
i get the same error after upgrading to 0.1.5-1

Comment 9 Max Kanat-Alexander 2003-10-29 22:32:48 UTC
Do you have the most recent rhpl? My having an old rhpl made this sort of thing
happen to me for a while.


Comment 10 Bill Nottingham 2003-10-30 05:12:28 UTC
*** Bug 108474 has been marked as a duplicate of this bug. ***

Comment 11 Daniel Malmgren 2003-10-30 07:15:36 UTC
> Do you have the most recent rhpl?

As I said above, I have the most recent versions of everything that
could possibly be relevant.

My rhpl version right now is 0.121-1.

Comment 12 Harald Hoyer 2003-10-30 12:42:08 UTC
ok... famous last words: 0.1.6 should fix it :)

Comment 13 Harald Hoyer 2003-11-05 11:29:36 UTC
*** Bug 109166 has been marked as a duplicate of this bug. ***

Comment 14 Alan Sanderson 2003-11-05 17:29:26 UTC
Created attachment 95734 [details]
redhat-config-boot-0.1.6-1 unhandled exception

Got further this time. A box actually opened up and I was able to choose a item
from the grub.conf file to work on and one I did and selected ok it crashed
with a unhandled exception I saved the output to the file that is attached.

Comment 15 Alan Sanderson 2003-11-05 17:44:50 UTC
Created attachment 95735 [details]
Output of 'strace -o strace.out redhat-config-boot'

Attaching the output of 'strace -o strace.out redhat-config-boot' for version
0.1.6-1 of redhat-config-boot.

Comment 16 Harald Hoyer 2003-11-06 10:05:43 UTC
no more strace please... the exception is enough to locate the problem :)

Comment 17 Harald Hoyer 2003-11-06 10:10:38 UTC
opened bug #109266 for the last exception