Bug 106796 - redhat-config-boot fails to start
redhat-config-boot fails to start
Status: CLOSED RAWHIDE
Product: Red Hat Raw Hide
Classification: Retired
Component: redhat-config-boot (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Harald Hoyer
David Lawrence
:
: 108254 108474 109166 (view as bug list)
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-10-10 13:27 EDT by Daniel Malmgren
Modified: 2007-04-18 12:58 EDT (History)
4 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-11-06 05:12:03 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
My grub.conf (383 bytes, text/plain)
2003-10-16 11:54 EDT, Daniel Malmgren
no flags Details
redhat-config-boot-0.1.6-1 unhandled exception (1.69 KB, text/plain)
2003-11-05 12:29 EST, Alan Sanderson
no flags Details
Output of 'strace -o strace.out redhat-config-boot' (615.79 KB, text/plain)
2003-11-05 12:44 EST, Alan Sanderson
no flags Details

  None (edit)
Description Daniel Malmgren 2003-10-10 13:27:34 EDT
Description of problem:
redhat-config-boot fails with error messages.

Version-Release number of selected component (if applicable):
0.1.3-1

How reproducible:
Always

Steps to Reproduce:
1. Start it
    
Actual results:
[root@Datorn root]# redhat-config-boot
Traceback (most recent call last):
  File "/usr/share/redhat-config-boot/redhat-config-boot.py", line 13, in ?
    app.stand_alone()
  File "/usr/share/redhat-config-boot/boot_gui.py", line 272, in stand_alone
    self.setupScreen()
  File "/usr/share/redhat-config-boot/boot_gui.py", line 86, in setupScreen
    self.readBootDB()
  File "/usr/share/redhat-config-boot/boot_gui.py", line 130, in readBootDB
    if tokens[0] == "title":
IndexError: list index out of range

Additional info:
It has been like this since the first release of redhat-config-boot. Using
latest rawhide rpm's of everything that could possibly have any relevance.
Comment 1 Daniel Malmgren 2003-10-14 12:30:40 EDT
Hey!
Can someone please explain to me why this bug is closed? It fur sure isn't fixed!
Comment 2 Harald Hoyer 2003-10-14 12:46:27 EDT
should be fixed in 0.1.4
Comment 3 Daniel Malmgren 2003-10-16 11:54:59 EDT
Created attachment 95228 [details]
My grub.conf
Comment 4 Daniel Malmgren 2003-10-16 11:56:35 EDT
Nope. I get the exact same error in 0.1.4 (except now it's line 22 instead of 13).
I don't know if it's something with my grub.conf? Attaching file...
Comment 5 Harald Hoyer 2003-10-27 08:16:22 EST
should be fixed with 0.1.5
Comment 6 Daniel Malmgren 2003-10-28 11:16:24 EST
It's not exactly the same fault this time, but I guess I'll just reopen this bug
anyway. In 0.1.5 I get this:

Traceback (most recent call last):
  File "/usr/share/redhat-config-boot/redhat-config-boot.py", line 22, in ?
    app.stand_alone()
  File "/usr/share/firstboot/modules/boot_gui.py", line 275, in stand_alone
    self.setupScreen()
  File "/usr/share/firstboot/modules/boot_gui.py", line 87, in setupScreen
    self.setDefault()
  File "/usr/share/firstboot/modules/boot_gui.py", line 178, in setDefault
    self.timeoutEntry.set_value(self.probedTimeout)
AttributeError: BootWindow instance has no attribute 'probedTimeout'
Comment 7 Bill Nottingham 2003-10-28 17:02:45 EST
*** Bug 108254 has been marked as a duplicate of this bug. ***
Comment 8 Need Real Name 2003-10-29 08:37:15 EST
i get the same error after upgrading to 0.1.5-1
Comment 9 Max Kanat-Alexander 2003-10-29 17:32:48 EST
Do you have the most recent rhpl? My having an old rhpl made this sort of thing
happen to me for a while.

-M
Comment 10 Bill Nottingham 2003-10-30 00:12:28 EST
*** Bug 108474 has been marked as a duplicate of this bug. ***
Comment 11 Daniel Malmgren 2003-10-30 02:15:36 EST
> Do you have the most recent rhpl?

As I said above, I have the most recent versions of everything that
could possibly be relevant.

My rhpl version right now is 0.121-1.
Comment 12 Harald Hoyer 2003-10-30 07:42:08 EST
ok... famous last words: 0.1.6 should fix it :)
Comment 13 Harald Hoyer 2003-11-05 06:29:36 EST
*** Bug 109166 has been marked as a duplicate of this bug. ***
Comment 14 Alan Sanderson 2003-11-05 12:29:26 EST
Created attachment 95734 [details]
redhat-config-boot-0.1.6-1 unhandled exception

Got further this time. A box actually opened up and I was able to choose a item
from the grub.conf file to work on and one I did and selected ok it crashed
with a unhandled exception I saved the output to the file that is attached.
Comment 15 Alan Sanderson 2003-11-05 12:44:50 EST
Created attachment 95735 [details]
Output of 'strace -o strace.out redhat-config-boot'

Attaching the output of 'strace -o strace.out redhat-config-boot' for version
0.1.6-1 of redhat-config-boot.
Comment 16 Harald Hoyer 2003-11-06 05:05:43 EST
no more strace please... the exception is enough to locate the problem :)
Comment 17 Harald Hoyer 2003-11-06 05:10:38 EST
opened bug #109266 for the last exception

Note You need to log in before you can comment on or make changes to this bug.