Bug 435382

Summary: Starting Xorg ends in display switched off
Product: [Fedora] Fedora Reporter: Matěj Cepl <mcepl>
Component: xorg-x11-serverAssignee: Adam Jackson <ajax>
Status: CLOSED RAWHIDE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: low Docs Contact:
Priority: low    
Version: rawhideCC: cra, gbcox, joernitsch, kdekorte, me, michal, ralston, xgl-maint
Target Milestone: ---   
Target Release: ---   
Hardware: All   
OS: Linux   
Whiteboard:
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2008-04-04 07:05:31 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
/var/log/Xorg.0.log
none
Xorg running in gdb
none
/var/log/Xorg.0.log.old none

Description Matěj Cepl 2008-02-28 17:08:31 EST
Description of problem:
Be it with runlevel 5 or startx in runlevel 3, whether Selinux is off,
Permissive, or Enforcing. Whatever I do, it just doesn't work.

Version-Release number of selected component (if applicable):
xorg-x11-server-common-1.4.99.1-0.25.20080227.fc9.x86_64
xorg-x11-server-Xorg-1.4.99.1-0.25.20080227.fc9.x86_64
xorg-x11-drv-ati-6.8.0-2.fc9.x86_64
xorg-x11-server-utils-7.3-3.fc9.x86_64

How reproducible:
100%
Comment 1 Matěj Cepl 2008-02-28 17:08:31 EST
Created attachment 296273 [details]
/var/log/Xorg.0.log
Comment 2 Matěj Cepl 2008-02-28 17:10:17 EST
Created attachment 296274 [details]
Xorg running in gdb

forgot to add one more … with or without /etc/X11/xorg.conf (these
particularly are without /etc/X11/xorg.conf)
Comment 3 Matěj Cepl 2008-02-28 17:10:52 EST
Created attachment 296275 [details]
/var/log/Xorg.0.log.old

don’t know if this one is of any worth
Comment 5 Michal Jaegermann 2008-02-29 15:41:32 EST
Backing off to

xorg-x11-server-Xorg-1.4.99.1-0.23.20080222.fc9
xorg-x11-server-common-1.4.99.1-0.23.20080222.fc9

does resolve the problem for me with xorg-x11-drv-ati-6.8.0-2.fc9
left in place.  Using the previous version of xorg-x11-drv-ati
but with the current xorg-x11-server-{Xorg,common} does not help.

AFAICS a display is not only switched off but it remains that way
until on a reboot BIOS reinitializes it.  Just stopping X is of
no use.
Comment 6 Charles R. Anderson 2008-03-01 19:07:13 EST
Ditto on Intel hardware.  Backing off to version 1.4.99.1-0.23.20080222 works
for me as well.
Comment 7 Kevin DeKorte 2008-03-01 20:13:26 EST
Happens on Intel G35 chipset. Recompiling xorg-x11-drv-intel from git (master
branch) seems to solve the black screen problem with the
xorg-x11-server-Xorg-1.4.99.1-0.23.20080222.fc9 version of the X server.


Comment 8 Charles R. Anderson 2008-03-02 13:45:20 EST
I should clarify my statements above in Comment #6.  With my ThinkPad T61 with
Intel graphics:

00:02.0 VGA compatible controller: Intel Corporation Mobile GM965/GL960
Integrated Graphics Controller (rev 0c) (prog-if 00 [VGA controller])
        Subsystem: Lenovo Unknown device 20b5

and these versions:

xorg-x11-drv-i810-2.2.1-2.fc9.x86_64
xorg-x11-server-common-1.4.99.1-0.23.20080222.fc9.x86_64
xorg-x11-server-Xorg-1.4.99.1-0.23.20080222.fc9.x86_64

X starts fine, but the backlight is turned off.  Running "xbacklight -set 100"
in the dark restores the display to a usable state and I can use X fine after that.

With the server upgraded to:

xorg-x11-server-Xorg-1.4.99.1-0.26.20080227.fc9
xorg-x11-server-common-1.4.99.1-0.26.20080227.fc9

then X doesn't start successfully at all--it just crashes and leaves the screen
blank (but the brightness is fine, the backlight is not turned off).  Changing
VTs back to 1 with Ctrl-Alt-F1 allows the text console to be used without problems.
Comment 9 Matěj Cepl 2008-03-03 07:56:47 EST
(In reply to comment #5)
> Backing off to
> 
> xorg-x11-server-Xorg-1.4.99.1-0.23.20080222.fc9
> xorg-x11-server-common-1.4.99.1-0.23.20080222.fc9

Yeah, this works for me too (at least for startx in runlevel 3)
Comment 10 Kevin DeKorte 2008-03-03 08:09:14 EST
Mar 3rd updates which include xorg-x11-drv-i810-2.2.1-3.fc9.x86_64 appears to
fix the problem on my intel G35 machine.
Comment 11 Matěj Cepl 2008-03-03 08:44:08 EST
*** Bug 435649 has been marked as a duplicate of this bug. ***
Comment 12 James Ralston 2008-03-03 11:09:22 EST
xorg-x11-drv-ati-6.8.0-3.fc9 fixes the same problem for me (from bug 435649).
Comment 13 Matěj Cepl 2008-03-03 18:44:15 EST
*** Bug 435615 has been marked as a duplicate of this bug. ***
Comment 14 Matěj Cepl 2008-03-03 18:55:45 EST
*** Bug 435782 has been marked as a duplicate of this bug. ***
Comment 15 Michal Jaegermann 2008-03-03 19:09:19 EST
After updates to

xorg-x11-server-common-1.4.99.1-0.26.20080227.fc9.x86_64
xorg-x11-server-Xorg-1.4.99.1-0.26.20080227.fc9.x86_64

and 

xorg-x11-drv-ati-6.8.0-3.fc9.x86_64

that combination looks to me like workable.  A keyboard is still messed
up but this is another issue.
Comment 16 Gerald Cox 2008-03-03 21:04:17 EST
xorg-x11-drv-ati-6.8.0-3.fc9.x86_64 and

xorg-x11-server-Xorg-1.4.99.1-0.26.20080227.fc9.x86_64
xorg-x11-server-common-1.4.99.1-0.26.20080227.fc9.x86_64

appear to work also, 

large text issue however remains:
https://bugzilla.redhat.com/show_bug.cgi?id=435216

along with 3D regression:
https://bugzilla.redhat.com/show_bug.cgi?id=434825
Comment 17 Adrien Bustany 2008-03-04 07:59:16 EST
OK, my bug was marked as duplicate of this bug, but it was not :-)
Anyway everything works with Xorg from March 03, except vt swtiching, but that's
another bug.
Comment 18 James Ralston 2008-03-04 13:46:42 EST
Which VT-switching bug is that?

I see bug 388181, but that doesn't seem to describe the problem I'm seeing,
wherein VT-switching seems to be simply disabled.  (I.e., once X is running,
none of Ctrl-Alt-F1 through Ctrl-Alt-F6 actually switch back to the
corresponding VT; nothing happens when you press them...)
Comment 19 Charles R. Anderson 2008-03-04 14:34:25 EST
With these versions:

kernel-2.6.25-0.87.rc3.git4.fc9.x86_64
xorg-x11-drv-i810-2.2.1-4.fc9.x86_64
xorg-x11-server-common-1.4.99.900-0.27.20080303.fc9.x86_64
xorg-x11-server-Xorg-1.4.99.900-0.27.20080303.fc9.x86_64

The X server no longer crashes at startup.  However, the backlight still remains
off after starting.  I have to log in at the gdm screen with the backlight off,
then open a gnome-terminal and type "xbacklight -set 100" to make X usable.

Also, VT switching with Ctrl-Alt-F1 now works but leaves the display blank or
the backlight turned off.  Ctrl-Alt-F7 restores the X session and turns the
backlight back on.
Comment 20 Brad Walker 2008-03-04 15:37:10 EST
I have the same problem as Charles Anderson on a ThinkPad X61s. My machine has
the same driver and server release. I've been working around the backlight issue
by running an old F8 kernel, kernel-2.6.23.1-42.fc8.x86_64.
Comment 21 Brad Walker 2008-03-11 05:26:45 EDT
I still have the backlight issue with these packages:
kernel-2.6.25-0.107.rc5.fc9.x86_64
xorg-x11-drv-i810-2.2.1-10.fc9.x86_64
xorg-x11-server-common-1.4.99.901-1.20080307.fc9.x86_64
xorg-x11-server-Xorg-1.4.99.901-1.20080307.fc9.x86_64

I've found that disabling RHGB works around the problem somewhat. The backlight
stays lit unless switched to a virtual console.
Comment 22 josc 2008-03-27 04:39:50 EDT
I have the same problem with the Fedora 9 Beta Live CD on HP NX7400.
Comment 23 Charles R. Anderson 2008-04-04 00:01:42 EDT
FWIW, this problem no longer happens for me on ThinkPad T61 w/Intel GM965.  It
was fixed quite a while back for me, but these are the versions I'm running now:

kernel-2.6.25-0.185.rc7.git6.fc9.x86_64
xorg-x11-drv-i810-2.2.1-19.fc9.x86_64
xorg-x11-server-common-1.4.99.901-16.20080401.fc9.x86_64
xorg-x11-server-Xorg-1.4.99.901-16.20080401.fc9.x86_64
Comment 24 Matěj Cepl 2008-04-04 07:05:31 EDT
I think this has been solved some time ago and I (in the authority of bug
reporter) cannot reproduce it. So (in the authority of a bug triager ;-)) I am
now closing it.