Bug 672030

Summary: AttributeError: 'NoneType' object has no attribute 'format'
Product: [Fedora] Fedora Reporter: Joachim Frieben <jfrieben>
Component: anacondaAssignee: David Lehman <dlehman>
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 15CC: andrewclarkii, awilliam, bcl, jlaska, jonathan, jreiser, martin.nad89, me, meyering, projects.rg, ultima.ratio.regum69, vanmeeuwen+fedora, v.plessky
Target Milestone: ---Keywords: Reopened
Target Release: ---   
Hardware: x86_64   
OS: Linux   
Whiteboard: anaconda_trace_hash:0fa98e8ac1ed4d6d4bc65e918872d326c8e617a2efb5e26d1550f2ec967214df AcceptedBlocker
Fixed In Version: anaconda-15.20.1-1.fc15 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-02-24 10:11:12 EST Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 657616    
Attachments:
Description Flags
Attached traceback automatically from anaconda.
none
Attached traceback automatically from anaconda.
none
Anaconda traceback
none
Attached traceback automatically from anaconda.
none
Traceback of anaconda
none
Attached traceback automatically from anaconda - Acer 6935G, Desktop-x86_64 (20110224)
none
Attached traceback automatically from anaconda.
none
Attached traceback automatically from anaconda. none

Description Joachim Frieben 2011-01-23 06:24:58 EST
The following was filed automatically by anaconda:
anaconda 15.15 exception report
Traceback (most recent call first):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/livecd.py", line 347, in getMinimumSizeMB
    return self.anaconda.storage.liveImage.format.size
  File "/usr/lib64/python2.7/site-packages/pyanaconda/storage/__init__.py", line 1027, in sanityCheck
    root.size < self.anaconda.backend.getMinimumSizeMB("/")):
  File "/usr/lib64/python2.7/site-packages/pyanaconda/iw/partition_gui.py", line 851, in getNext
    (errors, warnings) = self.storage.sanityCheck()
  File "/usr/lib64/python2.7/site-packages/pyanaconda/gui.py", line 1261, in nextClicked
    rc = self.currentWindow.getNext ()
AttributeError: 'NoneType' object has no attribute 'format'
Comment 1 Joachim Frieben 2011-01-23 06:25:25 EST
Created attachment 474810 [details]
Attached traceback automatically from anaconda.
Comment 2 David Lehman 2011-02-15 14:13:01 EST
Did this happen to you more than once? Have you tried with newer live images since you hit this failure? If so, what was the result?
Comment 3 Joachim Frieben 2011-02-17 04:09:21 EST
(In reply to comment #2)
Current live images do not even allow to run liveinst ("no live image"), thus, anaconda cannot be retested right now. Unfortunately, I do not remember which action triggered this anaconda exception.
Comment 4 Brian Lane 2011-02-18 14:44:54 EST
*** Bug 678607 has been marked as a duplicate of this bug. ***
Comment 5 Adam Williamson 2011-02-18 14:45:59 EST
Discussed at 2011-02-18 blocker review meeting (as 678607): accepted as a blocker as it appears to break live installation.
Comment 6 Dennis Gilmore 2011-02-18 23:24:54 EST
i used the freshly built nightly livecd and hit this. i tried installing a few times
Comment 7 David Lehman 2011-02-19 12:11:19 EST
I have posted a patch for review that fixes this issue in my testing:

https://www.redhat.com/archives/anaconda-devel-list/2011-February/msg00196.html


I have been hitting lvm deadlocks when trying to run lvcreate with this patch applied. I fixed anaconda's udev rules to specify read-only locks for the pvs commands we use to gather information about PVs, but then I hit the same deadlock with udisks-lvm-pv-export. This should not be running since we use udisks --inhibit to invoke anaconda. I confirmed that no deadlocks occurred with the read-only locks after completely killing the udisks-daemon. Perhaps we need to kill the udisks daemon before starting anaconda and restart it afterwards? Good stuff, this.
Comment 8 Andy Clark 2011-02-21 02:43:02 EST
Created attachment 479836 [details]
Attached traceback automatically from anaconda.
Comment 9 Athmane Madjoudj 2011-02-21 06:29:17 EST
Created attachment 479873 [details]
Anaconda traceback

The same issue with desktop nightly compose (20110221.00):

desktop-i386-20110221.00.iso
Comment 10 Chris Lumens 2011-02-21 08:33:09 EST
*** Bug 678911 has been marked as a duplicate of this bug. ***
Comment 11 James Laska 2011-02-21 10:57:11 EST
Tested the patch linked in comment#7.  This resolves the reported issue, but then I hit a new issue (see bug#679107).
Comment 12 Jim Meyering 2011-02-21 12:55:05 EST
Created attachment 479969 [details]
Attached traceback automatically from anaconda.
Comment 13 Chris Lumens 2011-02-21 12:56:49 EST
*** Bug 679131 has been marked as a duplicate of this bug. ***
Comment 14 Chris Lumens 2011-02-21 12:56:55 EST
*** Bug 679125 has been marked as a duplicate of this bug. ***
Comment 15 Fedora Update System 2011-02-21 14:35:21 EST
anaconda-15.20.1-1.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/anaconda-15.20.1-1.fc15
Comment 16 Fedora Update System 2011-02-21 15:38:43 EST
anaconda-15.20.1-1.fc15 has been pushed to the Fedora 15 testing repository.  If problems still persist, please make note of it in this bug report.
 If you want to test the update, you can install it with 
 su -c 'yum --enablerepo=updates-testing update anaconda'.  You can provide feedback for this update here: https://admin.fedoraproject.org/updates/anaconda-15.20.1-1.fc15
Comment 17 Chris Lumens 2011-02-21 16:06:32 EST
*** Bug 679193 has been marked as a duplicate of this bug. ***
Comment 18 James Laska 2011-02-22 08:44:02 EST
Confirmed fix with anaconda-15.20.1-1.fc15 (RC1)
Comment 19 Raphael Groner 2011-02-22 10:24:36 EST
Sorry, but it does not work for me with nightly xfce-i386-20110221.00.iso

New backtrace will be attached.
Comment 20 Raphael Groner 2011-02-22 10:26:55 EST
Created attachment 480156 [details]
Traceback of anaconda
Comment 21 David Lehman 2011-02-22 10:32:09 EST
(In reply to comment #19)
> Sorry, but it does not work for me with nightly xfce-i386-20110221.00.iso
> 
> New backtrace will be attached.

The fix is not in that nightly -- you need trees from 20110222 or newer.
Comment 22 James Laska 2011-02-22 11:50:35 EST
(In reply to comment #21)

> The fix is not in that nightly -- you need trees from 20110222 or newer.


Raphael, please try one of the images posted at http://serverbeach1.fedoraproject.org/pub/alt/stage/15-Alpha.RC1/Live/
Comment 23 Raphael Groner 2011-02-23 05:53:59 EST
So, from where to get a new fixed nightly?
There's still the buggy one on http://alt.fedoraproject.org/pub/alt/nightly-composes/xfce/
I tried to get updates (of abrt, anaconda etc.) into the running nightly but it stalls.
Comment 24 v.plessky 2011-02-24 09:32:15 EST
Tested current Rawhide (20110224) - Fedora 15 is "not installable" to HDD from LiveCD.
I was booting using Desktop-x86_64 version.

ABR submitted Bug Report to Bug 679125
But it was closed as duplicate of this bug.
So, I am reporting here now.
Comment 25 v.plessky 2011-02-24 09:36:45 EST
Created attachment 480773 [details]
Attached traceback automatically from anaconda - Acer 6935G, Desktop-x86_64 (20110224)


 traceback from Anaconda, from Desktop-x86-64 LiveCD dated 20110224
Comment 26 David Lehman 2011-02-24 10:11:12 EST
This is fixed for Fedora 15 in anaconda-15.20.1-1. For rawhide/master, it will be fixed in anaconda-16.0-1.
Comment 27 v.plessky 2011-02-24 10:19:48 EST
Dave, I was downloading ISO from
http://alt.fedoraproject.org/pub/alt/nightly-composes/desktop/

Is it Fedora 15 or Rawhide?
Where I can get working ISO image - right now, to test installation process?

Some parts of GFX Test Day testing-
https://fedoraproject.org/wiki/Test_Day:2011-02-23_Radeon
https://fedoraproject.org/wiki/Test_Day:2011-02-22_Nouveau

can't be completed without real installation.
Comment 28 Raphael Groner 2011-02-24 10:35:03 EST
In regards to comment #27 and #23,
I would like also to help testing. But this one is a major and annoying bug to get fixed in first place!
Comment 30 v.plessky 2011-02-24 12:33:20 EST
if someone else wants to follow:
Fedora Live Installer from http://serverbeach1.fedoraproject.org/pub/alt/stage/15-Alpha.RC1/Live/ image doesn't work in GUI.
But it can be launched from CLI: #liveinst
 Installation would be in text mode.
It comes through fine, with major issue IMHO that you ar enot prompted to add user.
After reboot, you will be in Runlevel 3 (Text console), and have login as root.

X/GNOME starts fine (tetsed x86-64/GNOME Desktop).
Comment 31 Adam Williamson 2011-02-24 12:40:50 EST
it works fine from GUI in most testing. you probably just hit https://bugzilla.redhat.com/show_bug.cgi?id=679486 again.
Comment 32 Brian Lane 2011-02-24 12:43:34 EST
v.plessky, please stop cluttering up bug reports with unrelated issues.

If you are having a problems please open new bugs after searching for existing
bugs related to your problems.
Comment 33 Fedora Update System 2011-02-24 22:50:21 EST
anaconda-15.20.1-1.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 34 Martin Naď 2011-02-26 16:25:10 EST
Created attachment 481195 [details]
Attached traceback automatically from anaconda.
Comment 35 Brian Lane 2011-04-08 12:49:45 EDT
Created attachment 490838 [details]
Attached traceback automatically from anaconda.