Bug 678236

Summary: User list sometimes not visible on greeter
Product: [Fedora] Fedora Reporter: Radek Lat <rlat>
Component: gdmAssignee: jmccann
Status: CLOSED ERRATA QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: medium Docs Contact:
Priority: unspecified    
Version: 15CC: adel.gadllah, andriy.tsykholyas, awilliam, bugs.michael, carstenblaauw, collura, covex, cschalle, giedrius.slavinskas, goeran, groknok, jfrieben, jlaska, jmccann, jmontleo, jsmith.fedora, mads, mclasen, me, me, mohdyusuf, mschmidt, pbrobinson, rhythm.gan, robatino, rstrode, samuel-rhbugs, sanjay.ankur, satellitgo, stephent98, tuxor1337
Target Milestone: ---   
Target Release: ---   
Hardware: Unspecified   
OS: Unspecified   
Whiteboard: AcceptedNTH
Fixed In Version: accountsservice-0.6.9-5.fc15 Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2011-04-28 15:20:17 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Bug Depends On:    
Bug Blocks: 617261, 657621    
Attachments:
Description Flags
photo of user list without users
none
Users not displayed
none
/var/log/messages with gdm debugging enabled
none
/var/log/gdm/:0-slave.log with gdm debugging enabled
none
/var/log/gdm/:0-greeter.log with gdm debugging enabled
none
/var/log/messages with gdm debugging, accountsservice-0.6.9-2.fc15.i686
none
/var/log/gdm/:0-slave.log with gdm debugging, accountsservice-0.6.9-2.fc15.i686
none
/var/log/gdm/\:0-greeter.log with gdm debugging, accountsservice-0.6.9-2.fc15.i686 none

Description Radek Lat 2011-02-17 04:16:54 EST
Description of problem:
After restart of recent Fedora 15 TC2 there is often no user list on gdm login screen. Only "other" option is visible. If the option "other" is selected and then canceled one or more times (not same every time), the list eventually appears.

Version-Release number of selected component (if applicable):
gdm-2.91.6-8.fc15.x86_64

How reproducible: often


Steps to Reproduce:
1. Reboot
2. Observe login screen
  
Actual results:
There is no user list

Expected results:
There should be user list every time
Comment 1 Mads Kiilerich 2011-03-04 14:02:26 EST
Created attachment 482350 [details]
photo of user list without users

I think I see the same - see the attached photo.

Trying "other" multiple times makes no difference.

gdm-2.91.91-1.fc15.i686
xorg-x11-drv-intel-2.14.0-2.fc15.i686
Comment 2 Mads Kiilerich 2011-03-08 05:52:45 EST
Actually, what I saw was the release blocker on Bug 672135.

Radek, can you verify if that also explains what you see?
Comment 3 Radek Lat 2011-03-08 06:14:43 EST
What I have reported is different from Bug 672135. The list of users is not visible at all (when the bug happens). Not just names.
Comment 4 Mads Kiilerich 2011-03-08 06:40:07 EST
A screen shot or photo of your issue could perhaps helping getting it fixed.
Comment 5 Giedrius Slavinskas 2011-03-16 05:24:09 EDT
I can confirm this bug. On the fresh boot greeter is empty, you are only able to select "Other". Account name shows up after idling for ~10 seconds. Sometimes not (maybe I need more patience and wait longer). After logging in with "Other" and logging out, greeter now is listing my account immediately.

I have to notice that bug report #672135 and attached image "photo of user list without users" is not relevant to this bug.


p.s. I am using fresh install of fedora 15 alpha.
Comment 6 Radek Lat 2011-03-16 09:10:45 EDT
Created attachment 485729 [details]
Users not displayed

Here is a photo of not displayed users in the list.
Comment 7 Joachim Frieben 2011-03-16 16:46:07 EDT
I seem to have a complete user list now:
- gdm-2.91.93-2.fc15
- glib2-2.28.3-1.fc15
- gtk2-2.24.3-1.fc15
- gtk3-3.0.3-1.fc15
Please update and report back.
Comment 8 Giedrius Slavinskas 2011-03-17 05:17:38 EDT
Got these packages, but user list is still empty.

(In reply to comment #5)
> I can confirm this bug. On the fresh boot greeter is empty, you are only able
> to select "Other". Account name shows up after idling for ~10 seconds.

I have to correct my self, waiting for the user list to show up does not do anything. The only way to get accounts in the list is by clicking "Other" and going back (by cancel button or by logging out if you've logged in).
Comment 9 Joachim Frieben 2011-03-17 06:09:54 EDT
(In reply to comment #8)
> Got these packages, but user list is still empty.

The user list has been reproducibely complete for 1-2 days now whereas before it used to show no or some random number of users. Please make sure that your system is really up to date with respect to both of fedora and updates-testing repositories.
I might have installed a few packages from the build server which are more recent than those in fedora or updates-testing but Fedora mirrors should catch up shortly. Alternatively, I recommend that you try with the latest live spin from:

 http://alt.fedoraproject.org/pub/alt/nightly-composes/desktop/desktop-i386-20110315.01.iso

which am downloading right now myself.
Comment 10 Joachim Frieben 2011-03-17 06:12:04 EDT
(In reply to comment #9)
Sorry, I forgot that desktop-i386-20110315.01.iso does -not- include packages from updates-testing but you can still try to update GNOME related packages from the running live system. Then create a few users, log out and see what happens ..
Comment 11 tuxor 2011-03-25 07:49:18 EDT
Can still confirm this issue. Those times, when the userlist is not loaded correctly, I get this in /var/log/messages:

Mar 25 12:39:56 fedora gdm-simple-greeter[1331]: DEBUG(+): GdmUserChooserWidget: User removed: MY_VERY_SECRET_USERNAME

And other times, when userlist is retrieved and displayed successfully, I'm not getting errors alike, but instead:

Mar 25 12:22:39 fedora gdm-simple-greeter[7160]: DEBUG(+): GdmUserChooserWidget: User added: thomas
Mar 25 12:22:39 fedora gdm-simple-greeter[7160]: DEBUG(+): GdmUserChooserWidget: User added name:thomas logged-in:1 pixbuf:0x15a6140

But there are times, when I get both (these cases are rare and usually lead to no userlist).
Comment 12 tuxor 2011-03-25 07:49:59 EDT
Btw, having this issue on x86_64 with latest updates (updates-testing etc.)
Comment 13 Michal Schmidt 2011-04-02 16:51:10 EDT
Still seeing this sometimes. It's non-deterministic.
gdm-2.91.94-1.fc15.x86_64
accountsservice-0.6.7-1.fc15.x86_64

I can confirm tuxor's observation that "User removed" is logged when it happens.
Comment 14 Adam Williamson 2011-04-04 17:29:28 EDT
I've been seeing this less on my desktop lately, but doing the desktop_login validation test on a VM installed from the Beta TC1 desktop live image, it's happening quite a lot. I too see 'User removed' in /var/log/gdm logs. Proposing as Beta blocker as it's an infringement of the desktop_login validation test which is marked as Beta stage, though we don't really have a criterion for this.
Comment 15 Jared Smith 2011-04-07 13:50:06 EDT
I've seen this periodically for the past couple of weeks as well -- it seems to me to be some sort of race condition, as sometimes it happens and sometimes it doesn't.  (In my particular case, it fails to show the user list approximately 25% of time.)
Comment 16 tuxor 2011-04-07 14:25:06 EDT
to me it seems like I'm running into this quite often after reboots!
Comment 17 Adam Williamson 2011-04-07 14:57:06 EDT
So, I proposed this as a blocker as it's a fail on a Beta-level validation test, but it doesn't hit any criteria and I think that's probably right: this seems NTH not blocker to me, there are easy workarounds (reboot if you really *need* the user list, or just type a user name) and it can be fixed with an update. propose drop to NTH. votes?
Comment 18 Dennis Gilmore 2011-04-07 15:04:14 EDT
this does need fixing for ga, but you can log in still. its just not the best experience im +1 to nth
Comment 19 James Laska 2011-04-07 15:35:41 EDT
(In reply to comment #17)
> votes?

+1 to NTH.  In fact, I'd suggest NTH for Final and avoid disrupting gdm at this stage.
Comment 20 Adam Williamson 2011-04-07 15:40:59 EDT
okay, i'm bumping to f15beta-accepted, and setting f15blocker for now, we can argue it at the next review meeting...
Comment 21 James Laska 2011-04-08 15:12:53 EDT
Discussed during the 2011-04-08 blocker review meeting [1].  AcceptedNTH for Beta. If a tested fix is available in time, will include in Beta

[1] http://meetbot.fedoraproject.org/fedora-bugzappers/2011-04-08/f-15-beta-blocker-review.2011-04-08-17.00.html
Comment 22 Adam Williamson 2011-04-15 14:22:18 EDT
Discussed at 2011-04-15 blocker review meeting. We're worried about this one, but it doesn't fit the release criteria very well. We are interested in whether this can cause live autologin to fail; if so we think this merits blocker status, if not, probably not. We will test and revisit next week. This is still definitely accepted as NTH.



-- 
Fedora Bugzappers volunteer triage team
https://fedoraproject.org/wiki/BugZappers
Comment 23 Matthias Clasen 2011-04-15 15:51:47 EDT
I cannot reproduce. It would be good to hear if the people who can reproduce this problem notice any difference with the accountsservice 0.6.9 update that I've built today. It fixes a possible crasher bug related to user removal.
Comment 24 Piscium 2011-04-15 19:40:56 EDT
I encountered this bug today, only once in about 10 logins since I installed gdm yesterday (previously I was using lxdm). My F15 partition is up-to-date so this bug is very much alive. As other people remarked this bug cannot be consistently reproduced.
Comment 25 Adam Pribyl 2011-04-16 13:36:23 EDT
This happens to me quite often. Latest F15 with update-testing. To me it seems like some kind of a race condition. This machine is not very fast.

This is what's in messages:
Apr 16 19:28:06 base gdm-simple-greeter[1063]: Gtk-WARNING: gtkwidget.c:6778: widget not within a GtkWindow
pr 16 19:28:07 base gdm-simple-greeter[1063]: Gtk-WARNING: gtk_widget_size_allocate(): attempt to allocate widget with width -47 and height -47
Comment 26 Jason Montleon 2011-04-18 09:59:31 EDT
I updated to 0.6.9 and so far I am not seeing this problem any more. I have rebooted ~8 times since installing it have not seen this problem occur once since installing the new version. Prior to that update it virtually never worked properly for me, so it is working much better at the very least.
Comment 27 Steve Tyler 2011-04-18 11:04:26 EDT
I tried rebooting a few times and this bug is still present with:

$ rpm -qa 'gdm*' 'accounts*' | sort
accountsservice-0.6.9-1.fc15.x86_64
accountsservice-libs-0.6.9-1.fc15.x86_64
gdm-3.0.0-2.fc15.x86_64
gdm-plugin-fingerprint-3.0.0-2.fc15.x86_64
Comment 28 Adam Pribyl 2011-04-18 11:23:40 EDT
In beta review for this bug is stated as workaround to press Cancel on "Other" but this does not work for me, I still see only "Other" after pressing Cancel. I have to restart Xorg to change things (Ctrl+Alt+Backspace - I have it enabled). It is not necessary to reboot. I even may see correct list after reboot, but it may display just "Other" after login/logout or Xorg restart.
Comment 29 Adam Williamson 2011-04-18 13:40:00 EDT
hit this on my first reboot with the updated accountsservice.
Comment 30 Steve Tyler 2011-04-18 17:11:55 EDT
(In reply to comment #27)
> I tried rebooting a few times and this bug is still present with:
> 
> $ rpm -qa 'gdm*' 'accounts*' | sort
> accountsservice-0.6.9-1.fc15.x86_64
> accountsservice-libs-0.6.9-1.fc15.x86_64
> gdm-3.0.0-2.fc15.x86_64
> gdm-plugin-fingerprint-3.0.0-2.fc15.x86_64

Amending my report. I have seen this bug only once on two different systems after many reboots and logouts.

There was an update to gdm along with accountsservice on Apr 16. (The last four lines below are from my experiment with downgrading accountsservice.)

# egrep 'accountsservice|gdm' /var/log/yum.log
Apr 06 08:47:15 Updated: 1:gdm-3.0.0-1.fc15.x86_64
Apr 06 08:47:29 Updated: 1:gdm-plugin-fingerprint-3.0.0-1.fc15.x86_64
Apr 10 02:55:31 Updated: pulseaudio-gdm-hooks-0.9.22-5.fc15.x86_64
Apr 16 17:16:07 Updated: accountsservice-0.6.9-1.fc15.x86_64
Apr 16 17:16:08 Updated: accountsservice-libs-0.6.9-1.fc15.x86_64
Apr 16 17:16:17 Updated: 1:gdm-3.0.0-2.fc15.x86_64
Apr 16 17:16:18 Updated: 1:gdm-plugin-fingerprint-3.0.0-2.fc15.x86_64
Apr 18 10:03:30 Installed: accountsservice-0.6.7-1.fc15.x86_64
Apr 18 10:03:30 Installed: accountsservice-libs-0.6.7-1.fc15.x86_64
Apr 18 12:11:07 Updated: accountsservice-0.6.9-1.fc15.x86_64
Apr 18 12:11:07 Updated: accountsservice-libs-0.6.9-1.fc15.x86_64
Comment 31 Steve Tyler 2011-04-18 17:20:47 EDT
(In reply to comment #30)
...
> There was an update to gdm along with accountsservice on Apr 16.

Tried downgrading gdm and rebooting. The bug occurred on the first try.

gdm-3.0.0-1.fc15.i686
gdm-plugin-fingerprint-3.0.0-1.fc15.i686
Comment 32 Samuel Sieb 2011-04-18 18:37:12 EDT
This appears to a timing issue and possibly related to the fingerprint plugin.  With gdm-plugin-fingerprint removed, I can't reproduce the problem.  With gdm-3.0.0-1, it happens on pretty much every boot and restarting prefdm fixes it.  With gdm-3.0.0-1, it happens very rarely, even with gdm-plugin-fingerprint installed.  The only difference between the two versions is that the Fedora logo was added!  Could it be that the slight difference in loading the logo is just enough time to miss the race condition whatever it is?
Comment 33 Steve Tyler 2011-04-18 19:10:30 EDT
(In reply to comment #32)
> This appears to a timing issue and possibly related to the fingerprint plugin. 
> With gdm-plugin-fingerprint removed, I can't reproduce the problem.  With
> gdm-3.0.0-1, it happens on pretty much every boot and restarting prefdm fixes
> it.  With gdm-3.0.0-1, it happens very rarely, even with gdm-plugin-fingerprint
> installed.  The only difference between the two versions is that the Fedora
> logo was added!  Could it be that the slight difference in loading the logo is
> just enough time to miss the race condition whatever it is?

Good question! An experiment would be to replace the logo with a huge image file that could possibly slow the greeter down enough to reproduce the bug ...

From skimming the images here:
$ xdg-open /usr/share/pixmaps/

I believe the logo is this file:
$ rpm -qf /usr/share/pixmaps/fedora-logo-sprite.svg
fedora-logos-14.0.1-500.fc14.noarch

There is a foot logo in gdm:
$ rpm -qf /usr/share/pixmaps/gdm-foot-logo.png
gdm-2.32.1-2.fc14.x86_64
Comment 34 Steve Tyler 2011-04-18 20:46:48 EDT
(In reply to comment #33)
> An experiment would be to replace the logo with a huge image
> file that could possibly slow the greeter down enough to reproduce the bug ...

I did manage to reproduce this bug once after:

$ sudo gconf-editor

Making this change:
apps:gdm:simple-greeter:logo_icon_name:start-here-1

And right-clicking and selecting "Set as Default".

IIRC, I simply logged out.

I couldn't reproduce it again.
Comment 35 Adam Pribyl 2011-04-20 07:25:36 EDT
I removed gdm-plugin-fingerprint and I also do not see this happen again in a short time... (few reboots, restarts).
Comment 36 Steve Tyler 2011-04-20 08:06:32 EDT
I just did an update and restarted. The user list showed "Other..." only.
Details here: Bug 691232 - gdm loses user name after software update
Comment 37 Adam Williamson 2011-04-20 12:19:06 EDT
*** Bug 691232 has been marked as a duplicate of this bug. ***
Comment 38 Andre Robatino 2011-04-21 01:41:30 EDT
I saw this bug once with the latest GNOME3 test day i686 live image on the following machine

http://www.smolts.org/client/show/pub_d16f8e5b-3ea1-4b4d-83be-a3ecc1a96b62

but couldn't reproduce it after several reboots. See also my other comment

https://bugzilla.redhat.com/show_bug.cgi?id=691232#c8
Comment 39 Peter Robinson 2011-04-21 04:19:59 EDT
I see this quite regularly with the SoaS live image.
Comment 40 Andre Robatino 2011-04-21 16:34:09 EDT
If someone sees this, what logs or other information should they collect from the system before logging out/rebooting? (Just so we're prepared.)
Comment 41 甘露(Gan Lu) 2011-04-24 09:18:14 EDT
I see this quite regularly, but I don't know how to collect the infomation you mentioned.
Comment 42 Ray Strode [halfline] 2011-04-25 11:22:44 EDT
if people who see this regularly could add Enable=true to the [debug] section of /etc/gdm/custom.conf and could then reproduce, and then attach

/var/log/messages
/var/log/gdm/:0-slave.log
/var/log/gdm/:0-greeter.log

that would be great.  I'm still trying to reproduce this but it happens very infrequently for me.
Comment 43 Steve Tyler 2011-04-25 11:37:48 EDT
Created attachment 494692 [details]
/var/log/messages with gdm debugging enabled

With /etc/gdm/custom.conf:
...
[debug]
Enable=true

After restarting, I had "Other..." only.
Comment 44 Steve Tyler 2011-04-25 11:46:12 EDT
Created attachment 494698 [details]
/var/log/gdm/:0-slave.log with gdm debugging enabled
Comment 45 Steve Tyler 2011-04-25 11:47:13 EDT
Created attachment 494699 [details]
/var/log/gdm/:0-greeter.log with gdm debugging enabled
Comment 46 Steve Tyler 2011-04-25 11:50:24 EDT
(In reply to comment #43)
> Created attachment 494692 [details]
> /var/log/messages with gdm debugging enabled
> 
> With /etc/gdm/custom.conf:
> ...
> [debug]
> Enable=true
> 
> After restarting, I had "Other..." only.

$ rpm -qa 'gdm*' accountsservice | sort
accountsservice-0.6.9-1.fc15.x86_64
gdm-3.0.0-2.fc15.x86_64
gdm-plugin-fingerprint-3.0.0-2.fc15.x86_64
Comment 47 Samuel Sieb 2011-04-25 11:51:27 EDT
Steve, you have the fingerprint plugin disabled?  I guess that eliminates that
as the cause.
Comment 48 Steve Tyler 2011-04-25 12:06:36 EDT
(In reply to comment #47)
> Steve, you have the fingerprint plugin disabled?  I guess that eliminates that
> as the cause.

It's installed is all I know:
gdm-plugin-fingerprint-3.0.0-2.fc15.x86_64
(IOW, I have not knowingly disabled it.)
Comment 49 Ray Strode [halfline] 2011-04-25 15:46:33 EDT
*** Bug 697180 has been marked as a duplicate of this bug. ***
Comment 50 Ray Strode [halfline] 2011-04-25 17:19:24 EDT
I'm going to push an accounts service update to updates-testing which I think may help things.  It also makes debug mode signficantly more chatty, so if my changes don't fix things, I should get a much clearer idea why in the next round of logs.
Comment 51 Fedora Update System 2011-04-25 17:32:48 EDT
accountsservice-0.6.9-2.fc15 has been submitted as an update for Fedora 15.
https://admin.fedoraproject.org/updates/accountsservice-0.6.9-2.fc15
Comment 52 Steve Tyler 2011-04-25 18:07:28 EDT
Created attachment 494768 [details]
/var/log/messages with gdm debugging, accountsservice-0.6.9-2.fc15.i686

"Other..." only both before and after updating (different system from the one in Comment 43). This should have both, separated by:

Apr 25 14:53:38 spruce yum[1675]: Updated: accountsservice-0.6.9-2.fc15.i686

$ rpm -qa 'gdm*' 'accountsservice*' | sort
accountsservice-0.6.9-2.fc15.i686
accountsservice-libs-0.6.9-2.fc15.i686
gdm-3.0.0-2.fc15.i686
gdm-plugin-fingerprint-3.0.0-2.fc15.i686
Comment 53 Steve Tyler 2011-04-25 18:13:18 EDT
Created attachment 494771 [details]
/var/log/gdm/:0-slave.log with gdm debugging, accountsservice-0.6.9-2.fc15.i686
Comment 54 Steve Tyler 2011-04-25 18:15:27 EDT
Created attachment 494772 [details]
/var/log/gdm/\:0-greeter.log with gdm debugging, accountsservice-0.6.9-2.fc15.i686
Comment 55 Steve Tyler 2011-04-25 18:44:52 EDT
With gdm debugging on, one system showed "Other..." only on several boots, and the other showed a user on several boots.

With gdm debugging off, on the first reboot, both systems displayed an alert during boot saying:
"Could not create ICE listening socket: Cannot establish any listening sockets: Log Out".
This was after "Starting LSB: start and stop sendmail....", IIRC.

Clicking "Log Out" allowed the boot to continue and gdm displayed a user.

accountsservice-0.6.9-2.fc15.i686
accountsservice-libs-0.6.9-2.fc15.i686
gdm-3.0.0-2.fc15.i686
gdm-plugin-fingerprint-3.0.0-2.fc15.i686
Comment 56 Ray Strode [halfline] 2011-04-26 12:32:43 EDT
thanks for the updated logs. They pointed out another bug in the code, which i'll push another test update for.
Comment 57 Ray Strode [halfline] 2011-04-26 16:01:30 EDT
Update is here: https://admin.fedoraproject.org/updates/accountsservice-0.6.9-4.fc15
Comment 58 Steve Tyler 2011-04-26 17:04:24 EDT
(In reply to comment #57)
> Update is here:
> https://admin.fedoraproject.org/updates/accountsservice-0.6.9-4.fc15

Thanks. I have this update on two systems now. After around a half dozen restarts, I have not observed this bug -- the user name was always displayed in the gdm greeter. (both with gdm debugging on and off)

On one system, I have seen some stalls while logging out from the gnome-shell. After clicking "Log Out" in the Log Out dialog, the desktop is shaded and there is a significant delay before the gdm greeter appears.

NB: I installed a large package update too.
Comment 59 Jason D. Clinton 2011-04-27 11:02:37 EDT
Just installed this as a part of a minor -testing push this morning and GDM autologin is now broken.

The process table shows the X server has started and GDM has a child process of pam-autologin in the sleep state. The slave log is empty while this is happening.

Stopping prefdm.service and restarting it makes no difference.

Disabling autologin in custom.conf allows the greeter to appear and function normally.

Nothing really stands out in greeter.log:

Gtk-Message: Failed to load module "pk-gtk-module"

(gnome-settings-daemon:1826): Gtk-WARNING **: gtk_window_set_wmclass: shouldn't set wmclass after window is realized!

** (process:1858): DEBUG: Greeter session pid=1858 display=:0 xauthority=/var/run/gdm/auth-for-gdm-vMDFF1/database
Gtk-Message: Failed to load module "pk-gtk-module"
Gtk-Message: Failed to load module "pk-gtk-module"
Failed to play sound: File or data not found
Gtk-Message: Failed to load module "pk-gtk-module"
gdm-simple-greeter[1858]: Gtk-WARNING: gtkwidget.c:6778: widget not within a GtkWindow
gdm-simple-greeter[1858]: Gtk-WARNING: gtk_widget_size_allocate(): attempt to allocate widget with width -47 and height -47
Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x1800007 (Login Wind)
Window manager warning: meta_window_activate called by a pager with a 0 timestamp; the pager needs to be fixed.
Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x1800007 (Login Wind)
Window manager warning: meta_window_activate called by a pager with a 0 timestamp; the pager needs to be fixed.
Window manager warning: Buggy client sent a _NET_ACTIVE_WINDOW message with a timestamp of 0 for 0x1800007 (Login Wind)
Window manager warning: meta_window_activate called by a pager with a 0 timestamp; the pager needs to be fixed.

(gnome-settings-daemon:1826): GLib-GObject-CRITICAL **: g_object_unref: assertion `G_IS_OBJECT (object)' failed
g_dbus_connection_real_closed: Remote peer vanished with error: Underlying GIOStream returned 0 bytes on an async read (g-io-error-quark, 0). Exiting.
Comment 60 Steve Tyler 2011-04-27 14:14:29 EDT
(In reply to comment #59)
> Just installed this as a part of a minor -testing push this morning and GDM
> autologin is now broken.
...

Confirming ...

accountsservice-0.6.9-4.fc15.x86_64:
Hangs at "Started LSB: Start start and stop sendmail." or
  "reloading sm-client:" (different systems).
After pressing ctrl-alt-backspace,
  the gdm greeter appears and login is possible.

accountsservice-0.6.7-1.fc15.x86_64:
Autologin works as expected.

Snippet from /etc/gdm/custom.conf:
[daemon]
AutomaticLoginEnable=true
AutomaticLogin=joeblow
Comment 61 Ray Strode [halfline] 2011-04-27 14:54:57 EDT
okay i've mopped up the autologin regression in a build pushed here: https://admin.fedoraproject.org/updates/accountsservice-0.6.9-5.fc15
Comment 62 Jason D. Clinton 2011-04-27 15:03:34 EDT
Confirming -5 fixes autologin.
Comment 63 Fedora Update System 2011-04-28 15:20:09 EDT
accountsservice-0.6.9-5.fc15 has been pushed to the Fedora 15 stable repository.  If problems still persist, please make note of it in this bug report.
Comment 64 Mohd Yusuf 2011-04-29 13:29:03 EDT
*** Bug 700806 has been marked as a duplicate of this bug. ***
Comment 65 Tom Slominski 2011-05-03 03:25:26 EDT
*** Bug 701349 has been marked as a duplicate of this bug. ***