This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours

Bug 806730

Summary: [abrt] control-center-3.2.2-1.fc16: get_brightness_cb: Process /usr/bin/gnome-control-center was killed by signal 5 (SIGTRAP)
Product: [Fedora] Fedora Reporter: collura
Component: control-centerAssignee: Control Center Maintainer <control-center-maint>
Status: CLOSED DUPLICATE QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 16CC: collura, control-center-maint, mkasik, rstrode
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:2f67128ba41718e7c7a0577ad58db97222b765be
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-03-30 09:14:56 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
File: dso_list
none
File: build_ids
none
File: maps
none
File: backtrace none

Description collura 2012-03-26 01:31:02 EDT
libreport version: 2.0.8
abrt_version:   2.0.7
backtrace_rating: 4
cmdline:        gnome-control-center --g-fatal-warnings
crash_function: get_brightness_cb
executable:     /usr/bin/gnome-control-center
kernel:         3.3.0-4.fc16.x86_64
pid:            24385
reason:         Process /usr/bin/gnome-control-center was killed by signal 5 (SIGTRAP)
time:           Mon 26 Mar 2012 12:41:08 AM EDT
var_log_messages: Mar 26 00:41:09 localhostf abrt[24398]: Saved core dump of pid 24385 (/usr/bin/gnome-control-center) to /var/spool/abrt/ccpp-2012-03-26-00:41:08-24385 (35614720 bytes)

backtrace:      Text file, 43862 bytes
build_ids:      Text file, 7503 bytes
dso_list:       Text file, 18108 bytes
maps:           Text file, 81232 bytes

comment:
:this is related to the disappearing brightness slider bug i have been trying to figure out 
:(https://bugzilla.redhat.com/show_bug.cgi?id=784532) 
:but the new bit is the core dumping when 
:add the '--g-fatal-warnings' option from command line :.)
:
:ran control center from shell: 
:   '$ gnome-control-center --g-fatal-warnings'
:which popped up the settings gui ok 
:
:when clicked on the 'screen' icon of the settings gui 
:it gave me the screen gui ok but only showed the brightness slider briefly 
:and then the brightness slider disappeared and got error:
:  'screen-cc-panel-WARNING **: Error getting brightness: Timeout was reached'
:the exciting part is that when i start the settins gui form gnome hotcorner menu the story ends here but since i started it from a command line i got the extra treat of:
:  'Trace/breakpoint trap (core dumped)'
:and then core dumped!  woohoo.
:
:so here is the dump that is hopefully related to the disappearing slider.
:

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=2
:HOSTNAME=<removed>.<removed>
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GPG_AGENT_INFO=/tmp/keyring-<removed>/gpg:0:1
:TERM=xterm
:SHELL=/bin/bash
:HISTSIZE=1000
:XDG_SESSION_COOKIE=c43d5bc63b22483003cd65b40000006e-1332722691.335428-2046259374
:GJS_DEBUG_OUTPUT=stderr
:WINDOWID=58720261
:GNOME_KEYRING_CONTROL=/tmp/keyring-<removed>
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:IMSETTINGS_MODULE=none
:USER=<removed>
:LS_COLORS=rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:mi=01;05;37;41:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arj=01;31:*.taz=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lz=01;31:*.xz=01;31:*.bz2=01;31:*.tbz=01;31:*.tbz2=01;31:*.bz=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.war=01;31:*.ear=01;31:*.sar=01;31:*.rar=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=01;36:*.au=01;36:*.flac=01;36:*.mid=01;36:*.midi=01;36:*.mka=01;36:*.mp3=01;36:*.mpc=01;36:*.ogg=01;36:*.ra=01;36:*.wav=01;36:*.axa=01;36:*.oga=01;36:*.spx=01;36:*.xspf=01;36:*.pdf=00;33:*.ps=00;33:*.ps.gz=00;33:*.txt=00;33:*.patch=00;33:*.diff=00;33:*.log=00;33:*.tex=00;33:*.xls=00;33:*.xlsx=00;33:*.ppt=00;33:*.pptx=00;33:*.rtf=00;33:*.doc=00;33:*.docx=00;33:*.odt=00;33:*.ods=00;33:*.odp=00;33:*.xml=00;33:*.epub=00;33:*.abw=00;33:*.html=00;33:*.wpd=00;33:
:SSH_AUTH_SOCK=/tmp/keyring-<removed>/ssh
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/1489,unix/unix:/tmp/.ICE-unix/1489
:USERNAME=<removed>
:PATH=/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/sbin:/home/<removed>/.local/bin:/home/<removed>/bin
:MAIL=/var/spool/mail/<removed>
:DESKTOP_SESSION=gnome
:QT_IM_MODULE=xim
:PWD=/home/<removed>
:XMODIFIERS=@im=none
:GNOME_KEYRING_PID=1484
:LANG=en_US.UTF-8
:KDE_IS_PRELINKED=1
:KDEDIRS=/usr
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:XDG_SEAT=seat0
:HOME=/home/<removed>
:SHLVL=2
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:LOGNAME=<removed>
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-<removed>,guid=c201c6685a00b653aba5732c0000009d
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/<removed>
:DISPLAY=:0
:COLORTERM=gnome-terminal
:XAUTHORITY=/var/run/gdm/auth-for-<removed>/database
:_=/usr/bin/gnome-control-center

smolt_data:
:
:
:General
:=================================
:UUID: 807b37ff-12cc-40b8-abdb-daa5e526093a
:OS: Fedora release 16 (Verne)
:Default run level: Unknown
:Language: en_US.UTF-8
:Platform: x86_64
:BogoMIPS: 4198.35
:CPU Vendor: AuthenticAMD
:CPU Model: AMD Turion(tm) X2 Dual-Core Mobile RM-72
:CPU Stepping: 1
:CPU Family: 17
:CPU Model Num: 3
:Number of CPUs: 2
:CPU Speed: 2100
:System Memory: 2758
:System Swap: 4291
:Vendor: TOSHIBA
:System: Satellite L355D PSLE8U-02P01D
:Form factor: Notebook
:Kernel: 3.3.0-4.fc16.x86_64
:SELinux Enabled: 1
:SELinux Policy: targeted
:SELinux Enforce: Enforcing
:MythTV Remote: Unknown
:MythTV Role: Unknown
:MythTV Theme: Unknown
:MythTV Plugin: 
:MythTV Tuner: -1
:
:
:Devices
:=================================
:(4130:38406:4473:65386) pci, pcieport, PCI/PCI, RS780 PCI to PCI bridge (PCIE port 2)
:(4098:17297:4473:65386) pci, ahci, STORAGE, SB7x0/SB8x0/SB9x0 SATA Controller [AHCI mode]
:(4098:38419:4473:65386) pci, radeon, VIDEO, RS780MC [Radeon HD 3100 Graphics]
:(4130:38400:4473:65386) pci, None, HOST/PCI, RS780 Host Bridge
:(4130:38402:4130:38402) pci, None, PCI/PCI, RS780/RS880 PCI to PCI bridge (int gfx)
:(4332:33078:4473:65386) pci, r8169, ETHERNET, RTL8101E/RTL8102E PCI Express Fast Ethernet controller
:(4130:4868:0:0) pci, None, HOST/PCI, Family 11h Processor Link Control
:(4130:4865:0:0) pci, None, HOST/PCI, Family 11h Processor Address Map
:(4130:4864:0:0) pci, None, HOST/PCI, Family 11h Processor HyperTransport Configuration
:(4130:4867:0:0) pci, k10temp, HOST/PCI, Family 11h Processor Miscellaneous Control
:(4130:4866:0:0) pci, None, HOST/PCI, Family 11h Processor DRAM Controller
:(4098:17308:4473:65386) pci, pata_atiixp, STORAGE, SB7x0/SB8x0/SB9x0 IDE Controller
:(4098:17285:4473:65386) pci, piix4_smbus, SERIAL, SBx00 SMBus Controller
:(4098:17309:4473:65386) pci, None, PCI/ISA, SB7x0/SB8x0/SB9x0 LPC host controller
:(4098:17283:4473:65386) pci, snd_hda_intel, MULTIMEDIA, SBx00 Azalia (Intel HDA)
:(4098:17284:0:0) pci, None, PCI/PCI, SBx00 PCI to PCI Bridge
:(4098:17302:4473:65386) pci, ehci_hcd, USB, SB7x0/SB8x0/SB9x0 USB EHCI Controller
:(4098:17303:4473:65386) pci, ohci_hcd, USB, SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
:(4098:17304:4473:65386) pci, ohci_hcd, USB, SB7x0 USB OHCI1 Controller
:(4098:17302:4473:65386) pci, ehci_hcd, USB, SB7x0/SB8x0/SB9x0 USB EHCI Controller
:(4098:17304:4473:65386) pci, ohci_hcd, USB, SB7x0 USB OHCI1 Controller
:(4098:17303:4473:65386) pci, ohci_hcd, USB, SB7x0/SB8x0/SB9x0 USB OHCI0 Controller
:(5772:28:5199:28968) pci, ath5k, ETHERNET, WLL3141 (Toshiba PA3613U-1MPC) 802.11bg Wireless Adapter
:(4130:38404:4473:65386) pci, pcieport, PCI/PCI, RS780 PCI to PCI bridge (PCIE port 0)
:(4130:38405:4473:65386) pci, pcieport, PCI/PCI, RS780 PCI to PCI bridge (PCIE port 1)
:
:
:Filesystem Information
:=================================
:device mtpt type bsize frsize blocks bfree bavail file ffree favail
:-------------------------------------------------------------------
:/dev/mapper/luks-346691ee-fa1e-4a5e-988f-143a53e6c184 / ext4 4096 4096 44952091 41241527 40791726 11255808 11048237 11048237
:/dev/sda6 /boot ext4 4096 4096 306446 274426 259066 76800 76515 76515
:

xsession_errors:
:(gnome-control-center:1998): screen-cc-panel-WARNING **: Error getting brightness: Timeout was reached
:(gnome-control-center:2907): screen-cc-panel-WARNING **: Error getting brightness: Timeout was reached
Comment 1 collura 2012-03-26 01:31:06 EDT
Created attachment 572641 [details]
File: dso_list
Comment 2 collura 2012-03-26 01:31:08 EDT
Created attachment 572642 [details]
File: build_ids
Comment 3 collura 2012-03-26 01:31:10 EDT
Created attachment 572643 [details]
File: maps
Comment 4 collura 2012-03-26 01:31:14 EDT
Created attachment 572644 [details]
File: backtrace
Comment 5 collura 2012-03-28 05:32:17 EDT
bug#806730 bug#807585 both call out glib/gmessages in abrt backtrace. coincidince or glib issue?
Comment 6 abrt-bot 2012-03-30 09:14:56 EDT
Backtrace analysis found this bug to be similar to bug #753919, closing as duplicate.

Bugs which were found to be similar to this bug: 
  control-center: bug #698216
  gnome-settings-daemon: bug #766859
  gtk3: bug #753919
  rhythmbox: bug #781645

This comment is automatically generated.

*** This bug has been marked as a duplicate of bug 753919 ***