Bug 831628

Summary: [abrt] libreoffice-core-3.5.4.2-1.fc17: ICEConnectionWorker thread still running during exit
Product: [Fedora] Fedora Reporter: Raphos <raphoszap>
Component: libreofficeAssignee: Caolan McNamara <caolanm>
Status: CLOSED UPSTREAM QA Contact: Fedora Extras Quality Assurance <extras-qa>
Severity: unspecified Docs Contact:
Priority: unspecified    
Version: 17CC: caolanm, davedave.skinner, dtardon, erack, hmelende, ignace.bienville, ltinkl, metherid, mstahl, sbergman, stedchris
Target Milestone: ---   
Target Release: ---   
Hardware: x86_64   
OS: Unspecified   
Whiteboard: abrt_hash:abf3d2d39d2d6701d51c3e96f775f86b8954c044
Fixed In Version: Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: Environment:
Last Closed: 2012-06-22 09:35:25 EDT Type: ---
Regression: --- Mount Type: ---
Documentation: --- CRM:
Verified Versions: Category: ---
oVirt Team: --- RHEL 7.3 requirements from Atomic Host:
Attachments:
Description Flags
File: backtrace
none
File: smolt_data
none
File: maps
none
File: dso_list
none
File: build_ids none

Description Raphos 2012-06-13 09:20:20 EDT
libreport version: 2.0.10
abrt_version:   2.0.10
backtrace_rating: 4
cmdline:        /usr/lib64/libreoffice/program/soffice.bin --calc file:///home/Raph/Documents/.Elise_Raph/Elise/Recherches/Consommations.ods --splash-pipe=6
crash_function: __memcpy_ssse3_back
executable:     /usr/lib64/libreoffice/program/soffice.bin
kernel:         3.4.0-1.fc17.x86_64
pid:            4385
pwd:            /home/Raph
time:           mer. 13 juin 2012 14:24:35 CEST
uid:            1000
username:       Raph
xsession_errors: 

backtrace:      Text file, 153724 bytes
build_ids:      Text file, 7216 bytes
dso_list:       Text file, 19040 bytes
maps:           Text file, 86465 bytes
smolt_data:     Text file, 6122 bytes

cgroup:
:9:perf_event:/
:8:blkio:/
:7:net_cls:/
:6:freezer:/
:5:devices:/
:4:memory:/
:3:cpuacct,cpu:/
:2:cpuset:/
:1:name=systemd:/user/Raph/1

comment:
:1 Open a .odt file with libreoffice
:2 Change tab in file
:3 Session close, back to the gnome loggin windows 

core_backtrace:
:a4ec59d7fc9c453fb4287d7ebc5fcf6579792e65 0x14674b __memcpy_ssse3_back libc.so.6 -
:7d2fd80dbbf2819ea84d0857dbeed35eebfa949f 0x350f3 - libvclplug_genlo.so -
:7abf6f5910d864b9914301365d64bbf8502fc06e 0x169cc - libuno_sal.so.3 -
:73777e822e00ca152ffca281ab0ace0cb498ec48 0x7d14 start_thread libpthread.so.0 -
:a4ec59d7fc9c453fb4287d7ebc5fcf6579792e65 0xf199d clone libc.so.6 -

environ:
:XDG_VTNR=1
:XDG_SESSION_ID=1
:HOSTNAME=raph.home
:IMSETTINGS_INTEGRATE_DESKTOP=yes
:GIO_LAUNCHED_DESKTOP_FILE_PID=4371
:GPG_AGENT_INFO=/run/user/Raph/keyring-pACIAJ/gpg:0:1
:SHELL=/bin/bash
:TERM=dumb
:DESKTOP_STARTUP_ID=nautilus-2339-raph.home-libreoffice-1_TIME14572838
:HISTSIZE=1000
:GJS_DEBUG_OUTPUT=stderr
:OLDPWD=/usr/lib64/libreoffice/program
:GNOME_KEYRING_CONTROL=/run/user/Raph/keyring-pACIAJ
:'GJS_DEBUG_TOPICS=JS ERROR;JS LOG'
:QT_GRAPHICSSYSTEM_CHECKED=1
:IMSETTINGS_MODULE=none
:USER=Raph
:SSH_AUTH_SOCK=/run/user/Raph/keyring-pACIAJ/ssh
:USERNAME=
:SESSION_MANAGER=local/unix:@/tmp/.ICE-unix/795,unix/unix:/tmp/.ICE-unix/795
:GIO_LAUNCHED_DESKTOP_FILE=/usr/share/applications/libreoffice-calc.desktop
:MAIL=/var/spool/mail/Raph
:PATH=/usr/NX/bin:/usr/local/bin:/usr/bin:/bin:/usr/local/sbin:/usr/sbin:/home/Raph/.local/bin:/home/Raph/bin
:DESKTOP_SESSION=gnome
:NXDIR=/usr/NX
:QT_IM_MODULE=xim
:PWD=/home/Raph
:XMODIFIERS=@im=none
:KDE_IS_PRELINKED=1
:LANG=fr_FR.utf8
:GDM_LANG=fr_FR.utf8
:KDEDIRS=/usr
:GDMSESSION=gnome
:HISTCONTROL=ignoredups
:XDG_SEAT=seat0
:HOME=/home/Raph
:SHLVL=1
:GNOME_DESKTOP_SESSION_ID=this-is-deprecated
:SAL_ENABLE_FILE_LOCKING=1
:LOGNAME=Raph
:DBUS_SESSION_BUS_ADDRESS=unix:abstract=/tmp/dbus-rXA03YPHW5,guid=0d201e250ed32e2a847473eb00000012
:'LESSOPEN=||/usr/bin/lesspipe.sh %s'
:WINDOWPATH=1
:XDG_RUNTIME_DIR=/run/user/Raph
:DISPLAY=:0.0
:XAUTHORITY=/var/run/gdm/auth-for-Raph-eEZ4jj/database
:LD_LIBRARY_PATH=/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3.x86_64/jre/lib/amd64/client:/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3.x86_64/jre/lib/amd64/server:/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3.x86_64/jre/lib/amd64/native_threads:/usr/lib/jvm/java-1.7.0-openjdk-1.7.0.3.x86_64/jre/lib/amd64

limits:
:Limit                     Soft Limit           Hard Limit           Units     
:Max cpu time              unlimited            unlimited            seconds   
:Max file size             unlimited            unlimited            bytes     
:Max data size             unlimited            unlimited            bytes     
:Max stack size            8388608              unlimited            bytes     
:Max core file size        0                    unlimited            bytes     
:Max resident set          unlimited            unlimited            bytes     
:Max processes             1024                 95847                processes 
:Max open files            4096                 4096                 files     
:Max locked memory         65536                65536                bytes     
:Max address space         unlimited            unlimited            bytes     
:Max file locks            unlimited            unlimited            locks     
:Max pending signals       95847                95847                signals   
:Max msgqueue size         819200               819200               bytes     
:Max nice priority         0                    0                    
:Max realtime priority     0                    0                    
:Max realtime timeout      unlimited            unlimited            us        

open_fds:
:0:/dev/null
:1:/home/Raph/.xsession-errors
:2:/home/Raph/.xsession-errors
:3:socket:[1508661]
:4:anon_inode:[eventfd]
:5:pipe:[1506637]

var_log_messages:
:Jun 13 14:24:35 raph kernel: [14551.660290] soffice.bin[4389]: segfault at 0 ip 00000030cc34674b sp 00007ff694d34bc8 error 6 in libc-2.15.so[30cc200000+1ac000]
:Jun 13 14:24:36 raph abrt[4419]: Saved core dump of pid 4385 (/usr/lib64/libreoffice/program/soffice.bin) to /var/spool/abrt/ccpp-2012-06-13-14:24:35-4385 (110075904 bytes)
Comment 1 Raphos 2012-06-13 09:20:27 EDT
Created attachment 591493 [details]
File: backtrace
Comment 2 Raphos 2012-06-13 09:20:37 EDT
Created attachment 591494 [details]
File: smolt_data
Comment 3 Raphos 2012-06-13 09:20:40 EDT
Created attachment 591495 [details]
File: maps
Comment 4 Raphos 2012-06-13 09:20:44 EDT
Created attachment 591496 [details]
File: dso_list
Comment 5 Raphos 2012-06-13 09:20:46 EDT
Created attachment 591497 [details]
File: build_ids
Comment 6 Stephan Bergmann 2012-06-20 08:18:56 EDT
*** Bug 833808 has been marked as a duplicate of this bug. ***
Comment 7 Stephan Bergmann 2012-06-22 09:35:25 EDT
From looking at the code (vcl/unx/generic/app/sm.cxx) it is unclear to me how it can happen that ICEConnectionWorker thread is still running during exit.  I have pushed a number of commits to upstream master (towards LibreOffice 3.7) to clean up and improve the relevant code (up to <http://cgit.freedesktop.org/libreoffice/core/commit/?id=2a5fc950439d484d1227a736bea6566e86e73b7c> "Some further clean-up of X Session Management code") anyway.  Maybe they magically help make the unexplainable behavior go away.
Comment 8 Stephan Bergmann 2012-09-21 03:02:56 EDT
*** Bug 859148 has been marked as a duplicate of this bug. ***
Comment 9 Stephan Bergmann 2012-10-22 03:46:54 EDT
*** Bug 868706 has been marked as a duplicate of this bug. ***
Comment 10 Michael Stahl 2013-01-04 16:35:30 EST
*** Bug 891031 has been marked as a duplicate of this bug. ***
Comment 11 Stephan Bergmann 2013-05-27 03:37:48 EDT
*** Bug 967208 has been marked as a duplicate of this bug. ***
Comment 12 Stephan Bergmann 2013-08-23 02:58:06 EDT
(In reply to Stephan Bergmann from comment #7)
> From looking at the code (vcl/unx/generic/app/sm.cxx) it is unclear to me
> how it can happen that ICEConnectionWorker thread is still running during
> exit.

What is suspicious is that the backtrace of thread 3 (calling __run_exit_handlers) is apparently cut, so it is very likely that this is not a normal exit from reaching the end of main, but rather some explicit call to exit from some error handling code, likely a duplicate of bug 1000150.