Bug 100517 - Can't upgrade MySQL to version 4.0
Can't upgrade MySQL to version 4.0
Status: CLOSED UPSTREAM
Product: Red Hat Linux Beta
Classification: Retired
Component: mysql (Show other bugs)
beta1
i386 Linux
medium Severity medium
: ---
: ---
Assigned To: Patrick Macdonald
:
: 108000 115640 136142 137296 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-07-22 20:59 EDT by Jonathan Smith
Modified: 2007-04-18 12:55 EDT (History)
5 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-07-23 08:46:59 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Jonathan Smith 2003-07-22 20:59:23 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.5a) Gecko/20030718
Mozilla Firebird/0.6

Description of problem:
When doing a simple rpm -Uvh to MySQL 4.0, I get the following error:

libmysqlclient.so.10 is needed by (installed) mod_auth_mysql-20030510-3
libmysqlclient.so.10 is needed by (installed) perl-DBD-MySQL-2.9002-1
libmysqlclient.so.10 is needed by (installed) php-mysql-4.3.2-6

I'd like to be able to use 4.0's new features, and it's much easier to use RPM's
than to build from source.


Version-Release number of selected component (if applicable):
3.23.57-1

How reproducible:
Always

Steps to Reproduce:
1. Download MySQL-server from mysql.com and do a rpm -Uvh
2.
3.
    

Actual Results:  Got error shown above

Expected Results:  successful upgrade

Additional info:
Comment 1 Patrick Macdonald 2003-07-23 08:46:59 EDT
At the moment, Red Hat does not support MySQL 4.0.x due to licensing
incompatibilities.  

We did have MySQL 4.0 rpms available on Rawhide for a little while (before the
license problem was discovered).  Along with the MySQL 4.0 rpms, we had a 
mysqlclient10 rpm which contained the libmysqlclient.so.10 file (which is what
you need).

The MySQL folks are looking into the licensing issue and we'll roll the rpms
once the issue is taken care of. 
Comment 2 Patrick Macdonald 2003-10-27 09:33:18 EST
*** Bug 108000 has been marked as a duplicate of this bug. ***
Comment 3 Patrick Macdonald 2004-02-16 12:23:17 EST
*** Bug 115640 has been marked as a duplicate of this bug. ***
Comment 4 Need Real Name 2004-06-12 15:39:51 EDT
Any news about this, maybe adding the mysql-4.x to fedora, since 
fedora is a really gpl project, I read the mysql license and I don't 
think should be any problems to add mysql 4 to Fedora Core, but in 
the case of RedHat Enterprise applies the new mysql license, other 
distros are using mysql-4..
Regards
Comment 5 Bill Nottingham 2004-10-18 12:59:37 EDT
*** Bug 136142 has been marked as a duplicate of this bug. ***
Comment 6 Jan Kratochvil 2004-10-18 14:16:52 EDT
Despite "Resolution UPSTREAM" no relevant Bug found on:
http://bugs.mysql.com/

Expected reasons are: MySQL-4.0 turned mysqclient license LGPL -> GPL.
Some proprietary code of RedHat Enterprise links against mysqlclient.

Fedora would be fine to use MySQL-4.x. It is just not viable for
RedHat to split Fedora vs. Enterprise development.
Comment 7 Jan Kratochvil 2004-10-18 14:47:12 EDT
FYI Red Hat legal attitude at: Bug 136142
(mine): UPSTREAM points to the Red Hat legal department.
Comment 8 Tom Lane 2004-10-27 11:43:39 EDT
*** Bug 137296 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.