Bug 1013445 - [RFE] Improve display of recipe details in job results
[RFE] Improve display of recipe details in job results
Status: CLOSED DUPLICATE of bug 1263917
Product: Beaker
Classification: Community
Component: web UI (Show other bugs)
0.15
Unspecified Unspecified
unspecified Severity unspecified (vote)
: ---
: ---
Assigned To: beaker-dev-list
tools-bugs
: FutureFeature
: 1062165 (view as bug list)
Depends On: 1012201
Blocks:
  Show dependency treegraph
 
Reported: 2013-09-30 02:08 EDT by Nick Coghlan
Modified: 2016-04-28 01:29 EDT (History)
11 users (show)

See Also:
Fixed In Version:
Doc Type: Enhancement
Doc Text:
Story Points: ---
Clone Of: 1012201
Environment:
Last Closed: 2016-04-18 03:32:03 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nick Coghlan 2013-09-30 02:08:53 EDT
The increased use of vertical whitespace in the new 0.15 theme results in a lot more wasted space in the recipe results display header.

Possible improvements:

- stop displaying the redundant "Clone RecipeSet" in the header for each recipe (if bug 894137 is ever implemented we may want to find room for a link back to the recipe set, though)

- stop displaying the Arch and Family (and create an RFE to allow filtering of the job results page by Arch and Family?)

There's also the brute force option of reducing the use of vertical whitespace in these particular rows.

This bug specifically does *not* include making substantial changes to the way we display log files in the job results, although it may cover changes to the way the display of overall recipe logs is toggled.

Bug 600232 and bug 584518 cover other possible improvements to the display of log information.
Comment 3 Nick Coghlan 2014-02-06 17:38:17 EST
*** Bug 1062165 has been marked as a duplicate of this bug. ***
Comment 5 Dan Callaghan 2016-04-18 03:32:03 EDT
Marking this as a dupe of bug 1263917, which is the new recipe page design for Beaker 23.0.

https://beaker-project.org/dev/proposals/job-page-improvements.html

The original idea of this RFE was to just squeeze some extra space out of the recipe widget header section, to account for the extra vertical spacing we incurred in the Beaker 0.15 Bootstrap migration. But as it turned out, we have managed to live with the existing recipe page this whole time. So there is nothing really left to do in this bug.

*** This bug has been marked as a duplicate of bug 1263917 ***

Note You need to log in before you can comment on or make changes to this bug.