Bug 102061 - (kudzu-sysctl-warning) Kudzu uses sysctl(2) - deprecated in kernel 2.6
Kudzu uses sysctl(2) - deprecated in kernel 2.6
Status: CLOSED DEFERRED
Product: Fedora
Classification: Fedora
Component: kudzu (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Bill Nottingham
David Lawrence
http://rhl.redhat.com/projects/additi...
:
: 115855 115878 115920 116370 117987 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2003-08-10 04:11 EDT by Paul Nasrat
Modified: 2014-03-16 22:38 EDT (History)
12 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-11-28 14:43:18 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Paul Nasrat 2003-08-10 04:11:07 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.4) Gecko/20030703

Description of problem:
The following thread on lkml discuses deprecation of the sysctl(2) which
currently kudzu uses for setting hotplug amongst other things.

http://marc.theaimsgroup.com/?t=105788803400003&r=1&w=2

At the moment it is fine, we just get a warning on boot or when using kudzu or
the kudzu python module

python: numerical sysctl 1 23 is obsolete.

Looking at the code what is being done here is getting the log level

I have also managed to get these messages which are for turning hotplug on and off

python: numerical sysctl 1 49 is obsolete.


Version-Release number of selected component (if applicable):
kudzu-1.1.13-1.1

How reproducible:
Always

Steps to Reproduce:
The following python fragment will produce the error

import kudzu
        list = kudzu.probe(kudzu.CLASS_MOUSE, kudzu.BUS_UNSPEC,
                           kudzu.PROBE_ALL)
1. Ensure running 2.6 kernel, eg kernel 2.6.0-0.test3.1.31 from Arjan's repository 
2. run python fragment
3. run dmesg

---
Actual Results:  The following occurs in the dmesg output

python: numerical sysctl 1 23 is obsolete.

Expected Results:  No printk, should use /proc directly (maybe ala procps sysctl.c).

---
Additional info:

I know this is on a Cambridge++ timescale (or beyond as it's just marked so will
not go away until 2.7/2.8), but it looks fairly trivial to replace using /proc,
unless there is any point that kudzu runs when proc is not yet mounted,
certainly this is not the case in standard boot order, and IIRC anaconda mounts
proc for an install.
Comment 1 Jeremy Katz 2004-02-11 18:56:26 EST
*** Bug 114912 has been marked as a duplicate of this bug. ***
Comment 2 Bill Nottingham 2004-02-16 15:14:25 EST
*** Bug 115855 has been marked as a duplicate of this bug. ***
Comment 3 Bill Nottingham 2004-02-16 15:27:41 EST
*** Bug 115878 has been marked as a duplicate of this bug. ***
Comment 4 Bill Nottingham 2004-02-16 23:44:52 EST
*** Bug 115920 has been marked as a duplicate of this bug. ***
Comment 5 Aleksey Nogin 2004-02-20 00:19:19 EST
I am seeing several such messages from kudzu:

kudzu: numerical sysctl 1 23 is obsolete.
kudzu: numerical sysctl 1 49 is obsolete.
kudzu: numerical sysctl 1 49 is obsolete.
Comment 6 Bill Nottingham 2004-02-20 13:06:03 EST
*** Bug 116370 has been marked as a duplicate of this bug. ***
Comment 9 Jeremy Katz 2004-03-10 16:51:32 EST
*** Bug 117987 has been marked as a duplicate of this bug. ***
Comment 10 Bill Nottingham 2004-03-11 19:51:02 EST
Removing from lists - warning is no longer in the kernel.
Comment 11 Rahul Sundaram 2005-11-24 14:57:43 EST
Can we close this bug report as per the last comment?

Note You need to log in before you can comment on or make changes to this bug.