Bug 103135 - Unable to authenticate error message
Unable to authenticate error message
Status: CLOSED CURRENTRELEASE
Product: Red Hat Raw Hide
Classification: Retired
Component: up2date (Show other bugs)
1.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Adrian Likins
Fanny Augustin
:
: 103136 103137 103140 103301 (view as bug list)
Depends On:
Blocks: CambridgeTarget
  Show dependency treegraph
 
Reported: 2003-08-26 16:57 EDT by Michael Lee Yohe
Modified: 2007-04-18 12:57 EDT (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-08-24 14:57:05 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Michael Lee Yohe 2003-08-26 16:57:28 EDT
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686) Gecko/20030722 Galeon/1.3.7

Description of problem:
Upon upgrading to the latest Rawhide up2date, I have noticed that executing
up2date does nothing.  If I start up2date from the console, I receive the following:

# up2date
There was an authentication error: Unable to authenticate

This error message should be more descriptive (citing what the user may or may
not be able to do to fix it).  It should also be available as a dialog box, if
up2date is running in Gnome mode.

Version-Release number of selected component (if applicable):
up2date-3.9.13-2

How reproducible:
Always

Steps to Reproduce:
1. see description


Actual Results:  "There was an authentication error: Unable to authenticate" is
displayed only if up2date is executed from a console.

Expected Results:  The error message should be displayed in a dialog box, and be
more descriptive as to what the actual problem is.

Additional info:
Comment 1 Bill Nottingham 2003-08-26 22:55:44 EDT
*** Bug 103136 has been marked as a duplicate of this bug. ***
Comment 2 Bill Nottingham 2003-08-26 22:55:51 EDT
*** Bug 103137 has been marked as a duplicate of this bug. ***
Comment 3 Bill Nottingham 2003-08-26 22:55:56 EDT
*** Bug 103140 has been marked as a duplicate of this bug. ***
Comment 4 Michael Lee Yohe 2003-08-27 11:53:11 EDT
Sorry for all the duplicates.. Bugzilla was suffering from extreme horkage
yesterday.
Comment 5 Bill Nottingham 2003-08-28 23:39:38 EDT
*** Bug 103301 has been marked as a duplicate of this bug. ***
Comment 6 Adam H. Pendleton 2003-09-23 14:05:26 EDT
I am receiving the same error.  I have deleted my system profile from RHN,
re-run rhn_register, and get these error outputs from rhn_register:

Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/gui.py", line 1023, in onSendPageNext
    up2dateAuth.updateLoginInfo()
  File "/usr/share/rhn/up2date_client/up2dateAuth.py", line 140, in updateLoginInfo
    raise up2dateErrors.AuthenticationError("Unable to authenticate")
up2date_client.up2dateErrors.AuthenticationError: Unable to authenticate
Traceback (most recent call last):
  File "/usr/share/rhn/up2date_client/gui.py", line 1048, in onRegFinishPagePrepare
    ret = rhnreg.finishMessage(self.systemId)
  File "/usr/share/rhn/up2date_client/rhnreg.py", line 197, in finishMessage
    raise up2dateErrors.CommunicationError(f.faultString)
up2date_client.up2dateErrors.CommunicationError: Error communicating with
server. The message was:
While running 'registration.finish_message': caught
server.apacheRequest.UnknownXML : Invalid request received (function:
registration.finish_message invalid).


I am using up2date-3.9.28-2.
Comment 7 Adam H. Pendleton 2003-09-23 15:55:28 EDT
Upgrading to up2date-3.9.29-2 fixed this problem for me.

Note You need to log in before you can comment on or make changes to this bug.