Bug 104058 - dbus starts too late
dbus starts too late
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: dbus (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: John (J5) Palmieri
: Triaged
: 150195 150196 176522 (view as bug list)
Depends On:
Blocks: CambridgeTarget 150195 FC5Blocker
  Show dependency treegraph
 
Reported: 2003-09-09 11:01 EDT by David Woodhouse
Modified: 2013-03-13 00:49 EDT (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-06 10:31:43 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description David Woodhouse 2003-09-09 11:01:53 EDT
S25bluetooth depends on S97messagebus. 

Please start dbus earlier.
Comment 1 Havoc Pennington 2003-10-04 01:27:57 EDT
First services are currently: 

S05kudzu
S08iptables
S09isdn
S10network
S12syslog
S13portmap
S14nfslock
S17keytable
S20random
S24pcmcia
S25netfs
S26apmd

I can imagine kudzu, network, syslog, pcmcia, apmd etc. using dbus someday, so
arguably dbus should be S03. I can imagine dbus requiring some of those other
things, but then again I don't think it currently does; it doesn't listen on
remote network sockets (thankfully).

Any opinions on the proper dbus priority?
Comment 2 Bill Nottingham 2003-10-06 01:21:22 EDT
Current policy is that all services that depend on netowrking must start after
network (duh), and all services that depend on things outside of the root FS
must start after netfs.

If neither of those is required, start as early as you want.
Comment 3 Havoc Pennington 2003-10-06 11:19:47 EDT
"network" covers TCP/IP, but would not cover a unix domain socket, right?

What does "root fs" mean for netfs? Does it include /etc config, /usr/bin, and
/var/ lockfiles?
Comment 4 Bill Nottingham 2003-10-06 15:13:28 EDT
Nah, unix domain sockets are fine.

"root fs" = /, /lib, /etc, /sbin, /tmp, /var. *NOT* /usr.
Comment 5 John (J5) Palmieri 2004-09-10 13:54:23 EDT
As dbus stands right now all of its libraries are in /usr/lib and
binaries in /usr/bin.  This means the earliest we can start dbus is
after S25netfs.  If we want to start it earlier, perhaps before kudzu,
we need to move dbus into /sbin and /lib.  And what about HAL?  It is
concevable that kudzu will also use HAL in the future.

Should I move dbus up to S26 for now (bluetooth would still need to
move down)?  Do we need to get it up higher in the chain and therefor
start the task of having everything installed in /lib and /sbin or can
that be put off for another release?

Just noticed this is an old bug.  Do we care about it anymore?
Comment 6 Bill Nottingham 2004-09-10 14:43:48 EDT
If bluetooth still needs it, we could move it up. As I understood,
bluetooth uses it for asking the user for data, though - that's not as
relevant during system startup.
Comment 7 John (J5) Palmieri 2005-03-11 15:27:20 EST
*** Bug 150196 has been marked as a duplicate of this bug. ***
Comment 8 John (J5) Palmieri 2005-03-11 15:27:30 EST
*** Bug 150195 has been marked as a duplicate of this bug. ***
Comment 9 John (J5) Palmieri 2005-03-11 15:32:52 EST
I need to talk to upstream about putting dbus in /sbin and /lib.  We should do
that.  Unfortunatly it doesn't solve the issue of networking which needs HAL. 
Hal links to glib so it can't be easily moved into /sbin and /lib.  Chicken and
the egg problem occures when a user is relying on NetworkManager to bring up an
NFS mounted /usr.  I will work on the problem of dbus starting late first and
then we can figure out what to do about HAL and NetworkManager.
Comment 10 Steve Grubb 2006-01-19 07:30:00 EST
Just a note on this, we need the dbus SE Linux messages to land in the audit
deamon, so dbus has to start after the audit daemon. I've moved the audit daemon
to start just before syslog.
Comment 11 John (J5) Palmieri 2006-01-20 16:46:40 EST
I'm starting dbus at 22 and stopping at 85 (auditd stops at 88) in the next
build however bluetooth stops at 90.  It should most likely stop before we stop
dbus.
Comment 12 John (J5) Palmieri 2006-02-06 10:29:59 EST
*** Bug 176522 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.