Bug 106575 - Upgrading from OOo 1.0.2 doesn't work as expected
Upgrading from OOo 1.0.2 doesn't work as expected
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: openoffice.org (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Dan Williams
:
: 106657 106754 106910 (view as bug list)
Depends On:
Blocks: CambridgeBlocker
  Show dependency treegraph
 
Reported: 2003-10-08 10:59 EDT by Nils Philippsen
Modified: 2007-11-30 17:10 EST (History)
7 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2003-10-31 11:18:30 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Nils Philippsen 2003-10-08 10:59:18 EDT
Description of problem:

When starting ooffice, oowriter, ... from a user with an existing OOo 1.0.2
installation, the (graphical) setup routine gets started which wants to install
in ~/OpenOffice.org1.1.0 (instead of ~/.openoffice). Running an OOo program
doesn't recognize this and starts setup again.

Version-Release number of selected component (if applicable):

openoffice.org-1.1.0-1

How reproducible:

Fairly easy.

Steps to Reproduce:
1. Have a user with an openoffice-1.0.2 installation
2. run oowriter
3. setup gets run
4. run oowriter
5. setup gets run
[...]
(n-1). choose ~/.openoffice as user directory
(n). run oowriter which starts finally
    
Actual results:

See description.

Expected results:

Old config gets migrated to OOo 1.1.0 format, few/no user interaction required.

Additional info:
Comment 1 Bill Nottingham 2003-10-09 14:27:20 EDT
*** Bug 106657 has been marked as a duplicate of this bug. ***
Comment 2 Dan Williams 2003-10-10 17:25:52 EDT
Problem is that the old installed language was "00" (see
~/.openoffice/instdb.ins) but new install language is "01", and therefore OOo
setup will not cleanly upgrade.  Problem will be fixed in 1.1.0-3
Comment 3 Dan Williams 2003-10-13 09:49:54 EDT
*** Bug 106910 has been marked as a duplicate of this bug. ***
Comment 4 Dan Williams 2003-10-13 11:17:39 EDT
*** Bug 106754 has been marked as a duplicate of this bug. ***
Comment 5 Max Kanat-Alexander 2003-10-29 17:34:39 EST
1.1.0-3 has been released. Has this been resolved?

-M
Comment 6 Denice 2003-10-31 06:15:35 EST
I tested upgrading with a couple of different user accounts at version 1.1.0-4,
and this problem is fixed for me.

I did have an account that still had problems; however it was a test account
that I had used for various OOo tests, and probably was very 'unhealthy'.
Comment 7 Dan Williams 2003-10-31 11:18:30 EST
Should be fixed for all in 1.1.0-4, for new upgrades.

Note You need to log in before you can comment on or make changes to this bug.