Bug 117498 - md code missing event interface
md code missing event interface
Status: CLOSED UPSTREAM
Product: Fedora
Classification: Fedora
Component: kernel (Show other bugs)
rawhide
All Linux
medium Severity medium
: ---
: ---
Assigned To: Doug Ledford
:
: 119834 121243 121832 122691 (view as bug list)
Depends On:
Blocks: FC2Blocker FC3Target FC4Target
  Show dependency treegraph
 
Reported: 2004-03-04 12:44 EST by Bill Nottingham
Modified: 2014-03-16 22:42 EDT (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-11-12 12:21:56 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)
MD Event interface patch (12.89 KB, patch)
2004-06-07 15:29 EDT, Doug Ledford
no flags Details | Diff

  None (edit)
Description Bill Nottingham 2004-03-04 12:44:01 EST
It prints out:

Kernel md module does not support events.

and immediately exits.
Comment 1 Doug Ledford 2004-03-30 16:08:28 EST
Needs the updated kernel md code.  I was told by Neil Brown that he
was going to push that into 2.6 himself.  Will have to check with him.
 Regardless though, it's a kernel issue, not an mdmpd issue.
Comment 2 Doug Ledford 2004-04-02 11:33:29 EST
*** Bug 119834 has been marked as a duplicate of this bug. ***
Comment 3 Doug Ledford 2004-04-22 18:38:54 EDT
*** Bug 121243 has been marked as a duplicate of this bug. ***
Comment 4 Doug Ledford 2004-05-03 16:34:42 EDT
*** Bug 121832 has been marked as a duplicate of this bug. ***
Comment 5 Jeremy Katz 2004-05-06 23:45:31 EDT
Did this get pushed in?  If not, we should disable mdmpd.
Comment 6 Gene Czarcinski 2004-05-07 04:22:21 EDT
I still see "mdmpd failed" at startup on x86_64 with no software raid
(was everything install).  No other messages.  This may be a different
problem.
Comment 7 Doug Ledford 2004-05-07 07:39:12 EDT
*** Bug 122691 has been marked as a duplicate of this bug. ***
Comment 8 Doug Ledford 2004-05-07 07:44:16 EDT
I've contacted the md maintainer to get a 2.6 version of the event
interface patch.  No word back yet.  I'll rebuild a new package today
that doesn't turn the program on by default.
Comment 9 Doug Ledford 2004-05-14 11:42:09 EDT
The upstream md maintainer is going to try and push the event
interface into the mainstream kernel in about a week.
Comment 10 Doug Ledford 2004-06-07 15:29:35 EDT
Created attachment 100940 [details]
MD Event interface patch

This is the patch that implements the md event interface.  It's currently the
only outstanding md patch that the upstream maintainer has not yet submitted to
the 2.6 kernel.
Comment 11 Boris Folgmann 2004-07-08 05:34:20 EDT
Problem still present with current kernel-2.6.6-1.435.2.3
Any plans when the patch will be integrated?
Comment 12 Dona Gibbons 2004-08-04 09:50:46 EDT
Problem still present with current kernel-2.6.7-1.494.2.2
Comment 13 Efraim MARQUEZ-ARREAZA 2004-08-31 11:24:07 EDT
Problem still  present with current kernel-2.6.8.1-521 (Fedora Core 2)
Comment 14 Doug Ledford 2004-11-12 12:21:56 EST
The mdadm tools package was modified to work without the md event
interface.  If it is accepted upstream (which I believe it has been as
of 2.6.10-rc1) then we will eventually get it in the future.  Since
it's an optimization and not a hard requirement for operability (due
to the mdadm package update, prior to that it was a hard requirement),
I'm closing this bug out as UPSTREAM.

Note You need to log in before you can comment on or make changes to this bug.