Bug 1285230 - Data Tiering:File create terminates with "Input/output error" as split brain is observed
Data Tiering:File create terminates with "Input/output error" as split brain ...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
mainline
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Susant Kumar Palai
bugs@gluster.org
: ZStream
Depends On: 1275751 1286028 1286029 1291557 1358823
Blocks: 1260923 1290363
  Show dependency treegraph
 
Reported: 2015-11-25 04:23 EST by Susant Kumar Palai
Modified: 2016-07-21 10:39 EDT (History)
8 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1275751
: 1290363 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:46:40 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-11-25 05:25:01 EST
REVIEW: http://review.gluster.org/12745 (feature/tier: Fix EIO during write) posted (#1) for review on master by Susant Palai (spalai@redhat.com)
Comment 2 Vijay Bellur 2015-11-26 04:16:16 EST
REVIEW: http://review.gluster.org/12745 (feature/tier: Fix EIO during write) posted (#2) for review on master by Susant Palai (spalai@redhat.com)
Comment 3 Vijay Bellur 2015-11-30 04:57:31 EST
REVIEW: http://review.gluster.org/12745 (feature/tier: Fix EIO during write) posted (#3) for review on master by Susant Palai (spalai@redhat.com)
Comment 4 Vijay Bellur 2015-12-01 02:29:12 EST
REVIEW: http://review.gluster.org/12745 (feature/tier: Fix EIO during write) posted (#4) for review on master by Susant Palai (spalai@redhat.com)
Comment 5 Vijay Bellur 2015-12-01 03:29:44 EST
REVIEW: http://review.gluster.org/12745 (feature/tier: Fix EIO during write) posted (#5) for review on master by Susant Palai (spalai@redhat.com)
Comment 6 Vijay Bellur 2015-12-01 05:59:19 EST
REVIEW: http://review.gluster.org/12745 (feature/tier: Fix EIO during write) posted (#6) for review on master by Susant Palai (spalai@redhat.com)
Comment 7 Vijay Bellur 2015-12-03 02:39:42 EST
REVIEW: http://review.gluster.org/12745 (feature/tier: Fix EIO during write) posted (#7) for review on master by Susant Palai (spalai@redhat.com)
Comment 8 Vijay Bellur 2015-12-07 07:40:13 EST
REVIEW: http://review.gluster.org/12894 (afr: refresh inode using fstat) posted (#1) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 9 Vijay Bellur 2015-12-08 00:01:50 EST
REVIEW: http://review.gluster.org/12745 (posix: fix posix_fgetxattr to return the correct error) posted (#8) for review on master by Susant Palai (spalai@redhat.com)
Comment 10 Vijay Bellur 2015-12-08 07:59:40 EST
REVIEW: http://review.gluster.org/12894 (afr: refresh inode using fstat) posted (#2) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 11 Vijay Bellur 2015-12-08 16:47:40 EST
REVIEW: http://review.gluster.org/12894 (afr: refresh inode using fstat) posted (#3) for review on master by Vijay Bellur (vbellur@redhat.com)
Comment 12 Vijay Bellur 2015-12-08 23:43:53 EST
REVIEW: http://review.gluster.org/12894 (afr: refresh inode using fstat) posted (#4) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 13 Vijay Bellur 2015-12-09 02:01:55 EST
COMMIT: http://review.gluster.org/12745 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 848bf0db0dde745e1f3a966db0143b7003bd49b5
Author: Susant Palai <spalai@redhat.com>
Date:   Wed Nov 25 05:07:03 2015 -0500

    posix: fix posix_fgetxattr to return the correct error
    
    posix_fgetxattr used to not updating op_ret
    and op_errno (initialized to -1 and ENOENT respectively)
    on success cases. Hence, it can return ENOENT even if all
    the opertions were sucessful.
    
    Change-Id: I5db3c1821208166a052d734b0be2553d009b8ee4
    BUG: 1285230
    Signed-off-by: Susant Palai <spalai@redhat.com>
    Reviewed-on: http://review.gluster.org/12745
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
Comment 14 Vijay Bellur 2015-12-09 02:26:46 EST
REVIEW: http://review.gluster.org/12916 (storage/posix: fix dict leak in posix_fgetxattr) posted (#1) for review on master by Susant Palai (spalai@redhat.com)
Comment 15 Vijay Bellur 2015-12-09 03:59:53 EST
REVIEW: http://review.gluster.org/12916 (storage/posix: fix dict leak in posix_fgetxattr.) posted (#2) for review on master by Susant Palai (spalai@redhat.com)
Comment 16 Vijay Bellur 2015-12-09 04:11:12 EST
REVIEW: http://review.gluster.org/12916 (storage/posix: fix dict leak in posix_fgetxattr) posted (#3) for review on master by Susant Palai (spalai@redhat.com)
Comment 17 Vijay Bellur 2015-12-09 06:38:24 EST
REVIEW: http://review.gluster.org/12894 (afr: refresh inode using fstat) posted (#5) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 18 Vijay Bellur 2015-12-09 07:55:17 EST
REVIEW: http://review.gluster.org/12894 (afr: refresh inode using fstat) posted (#6) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 19 Vijay Bellur 2015-12-09 08:03:17 EST
REVIEW: http://review.gluster.org/12916 (storage/posix: fix dict leak in posix_fgetxattr) posted (#4) for review on master by Susant Palai (spalai@redhat.com)
Comment 20 Vijay Bellur 2015-12-09 23:46:44 EST
REVIEW: http://review.gluster.org/12894 (afr: refresh inode using fstat) posted (#7) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 21 Vijay Bellur 2015-12-10 05:32:02 EST
COMMIT: http://review.gluster.org/12916 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 3949541b21b1d03ab37c7ab39f95581d553251d4
Author: Susant Palai <spalai@redhat.com>
Date:   Wed Dec 9 03:53:45 2015 -0500

    storage/posix: fix dict leak in posix_fgetxattr
    
    Change-Id: I8c53805993570e6f37786dde2103cb884c026791
    BUG: 1285230
    Signed-off-by: Susant Palai <spalai@redhat.com>
    Reviewed-on: http://review.gluster.org/12916
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
Comment 22 Vijay Bellur 2015-12-11 11:19:26 EST
REVIEW: http://review.gluster.org/12894 (afr: refresh inode using fstat) posted (#8) for review on master by Dan Lambright (dlambrig@redhat.com)
Comment 23 Vijay Bellur 2015-12-14 05:47:35 EST
REVIEW: http://review.gluster.org/12894 (afr: refresh inode using fstat) posted (#9) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 24 Vijay Bellur 2015-12-15 11:52:36 EST
REVIEW: http://review.gluster.org/12894 (afr: refresh inode using fstat) posted (#10) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 25 Vijay Bellur 2015-12-16 11:12:16 EST
REVIEW: http://review.gluster.org/12894 (afr: refresh inode using fstat) posted (#11) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 26 Vijay Bellur 2015-12-18 01:15:04 EST
REVIEW: http://review.gluster.org/12894 (afr: refresh inode using fstat) posted (#12) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 27 Vijay Bellur 2015-12-18 04:42:00 EST
REVIEW: http://review.gluster.org/12894 (afr: refresh inode using fstat) posted (#13) for review on master by Ravishankar N (ravishankar@redhat.com)
Comment 28 Vijay Bellur 2015-12-20 23:04:42 EST
COMMIT: http://review.gluster.org/12894 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit d5a9e765543fd6eec5d522e4f3f062bef97aefed
Author: Ravishankar N <ravishankar@redhat.com>
Date:   Mon Dec 7 18:03:03 2015 +0530

    afr: refresh inode using fstat
    
    For fd based operations (fgetxattr, readv etc.) if an inode refresh is
    required, do so using fstat instead of lookup. This is because the file
    might have been deleted by another client before refresh but posix
    mandates that FOPS using already open fds must still succeed.
    
    Change-Id: Id5f71c3af4892b648eb747f363dffe6208e7ac09
    BUG: 1285230
    Signed-off-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-on: http://review.gluster.org/12894
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
Comment 29 Ravishankar N 2015-12-20 23:08:36 EST
All patches for this BZ are merged, moving this to MODIFIED.
Comment 30 Niels de Vos 2016-06-16 09:46:40 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.