Bug 1286029 - Data Tiering:File create terminates with "Input/output error" as split brain is observed
Data Tiering:File create terminates with "Input/output error" as split brain ...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: disperse (Show other bugs)
mainline
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Ashish Pandey
: ZStream
Depends On: 1275751 1286028
Blocks: 1260923 1285230 1290363 1291557 1358823
  Show dependency treegraph
 
Reported: 2015-11-27 04:46 EST by Ashish Pandey
Modified: 2016-07-21 10:39 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.8rc2
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1286028
: 1291557 (view as bug list)
Environment:
Last Closed: 2016-06-16 09:47:06 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-11-30 02:09:42 EST
REVIEW: http://review.gluster.org/12816 (storage/posix: Implement .unlink directory) posted (#1) for review on master by Ashish Pandey (aspandey@redhat.com)
Comment 2 Vijay Bellur 2015-12-04 03:11:47 EST
REVIEW: http://review.gluster.org/12816 (storage/posix: Implement .unlink directory) posted (#2) for review on master by Ashish Pandey (aspandey@redhat.com)
Comment 3 Vijay Bellur 2015-12-04 03:17:37 EST
REVIEW: http://review.gluster.org/12816 (storage/posix: Implement .unlink directory) posted (#3) for review on master by Ashish Pandey (aspandey@redhat.com)
Comment 4 Vijay Bellur 2015-12-04 06:03:14 EST
REVIEW: http://review.gluster.org/12816 (storage/posix: Implement .unlink directory) posted (#4) for review on master by Ashish Pandey (aspandey@redhat.com)
Comment 5 Vijay Bellur 2015-12-08 02:55:46 EST
REVIEW: http://review.gluster.org/12816 (storage/posix: Implement .unlink directory) posted (#5) for review on master by Ashish Pandey (aspandey@redhat.com)
Comment 6 Vijay Bellur 2015-12-08 10:09:42 EST
REVIEW: http://review.gluster.org/12816 (storage/posix: Implement .unlink directory) posted (#6) for review on master by Vijay Bellur (vbellur@redhat.com)
Comment 7 Vijay Bellur 2015-12-08 16:50:44 EST
REVIEW: http://review.gluster.org/12816 (storage/posix: Implement .unlink directory) posted (#7) for review on master by Vijay Bellur (vbellur@redhat.com)
Comment 8 Vijay Bellur 2015-12-09 00:05:29 EST
REVIEW: http://review.gluster.org/12816 (storage/posix: Implement .unlink directory) posted (#8) for review on master by Ashish Pandey (aspandey@redhat.com)
Comment 9 Vijay Bellur 2015-12-09 01:06:32 EST
REVIEW: http://review.gluster.org/12816 (storage/posix: Implement .unlink directory) posted (#9) for review on master by Ashish Pandey (aspandey@redhat.com)
Comment 10 Vijay Bellur 2015-12-12 08:42:58 EST
REVIEW: http://review.gluster.org/12816 (storage/posix: Implement .unlink directory) posted (#10) for review on master by Ashish Pandey (aspandey@redhat.com)
Comment 11 Vijay Bellur 2015-12-14 05:40:42 EST
REVIEW: http://review.gluster.org/12816 (storage/posix: Implement .unlink directory) posted (#11) for review on master by Ashish Pandey (aspandey@redhat.com)
Comment 12 Vijay Bellur 2015-12-15 03:36:02 EST
COMMIT: http://review.gluster.org/12816 committed in master by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit c4f6521dfe6a44cee2f61ae41fc26faaf785372d
Author: Ashish Pandey <aspandey@redhat.com>
Date:   Thu Nov 26 14:35:49 2015 +0530

    storage/posix: Implement .unlink directory
    
    Problem: For EC volume, If a file descriptor is open and
    file has been unlinked, any further write on that fd will
    fail. When a write request comes, EC internally reads some
    blocks using anonymous fd. This read will fail as the file
    has already been unlinked.
    
    Solution: To solve this issue, we are using .unlink directory
    to keep track of unlinked file. If a file is to be unlinked
    while its fd is open, move this to .unlink directory and unlink
    it from .glusterfs and real path. Once all the fd will be closed,
    remove this entry form .unlink directory.
    
    Change-Id: I8344edb0d340bdb883dc46458c16edbc336916b9
    BUG: 1286029
    Signed-off-by: Ashish Pandey <aspandey@redhat.com>
    Reviewed-on: http://review.gluster.org/12816
    Reviewed-by: Krutika Dhananjay <kdhananj@redhat.com>
    Reviewed-by: Xavier Hernandez <xhernandez@datalab.es>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
Comment 13 Mike McCune 2016-03-28 18:16:42 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 14 Niels de Vos 2016-06-16 09:47:06 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.8.0, please open a new bug report.

glusterfs-3.8.0 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] http://blog.gluster.org/2016/06/glusterfs-3-8-released/
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.