Bug 1290363 - Data Tiering:File create terminates with "Input/output error" as split brain is observed
Data Tiering:File create terminates with "Input/output error" as split brain ...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: tiering (Show other bugs)
3.7.6
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Susant Kumar Palai
bugs@gluster.org
: ZStream
Depends On: 1275751 1285230 1286028 1286029 1291557 1358823
Blocks: 1260923 glusterfs-3.7.7
  Show dependency treegraph
 
Reported: 2015-12-10 05:38 EST by Susant Kumar Palai
Modified: 2016-07-21 10:39 EDT (History)
7 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1285230
Environment:
Last Closed: 2016-04-19 03:50:44 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-12-10 05:40:35 EST
REVIEW: http://review.gluster.org/12939 (storage/posix: fix dict leak in posix_fgetxattr) posted (#1) for review on release-3.7 by Susant Palai (spalai@redhat.com)
Comment 2 Vijay Bellur 2015-12-21 06:22:52 EST
REVIEW: http://review.gluster.org/13040 (afr: refresh inode using fstat) posted (#1) for review on release-3.7 by Ravishankar N (ravishankar@redhat.com)
Comment 3 Vijay Bellur 2015-12-22 06:46:32 EST
REVIEW: http://review.gluster.org/13040 (afr: refresh inode using fstat) posted (#2) for review on release-3.7 by Ravishankar N (ravishankar@redhat.com)
Comment 4 Vijay Bellur 2015-12-29 02:25:27 EST
COMMIT: http://review.gluster.org/13040 committed in release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit f88369e75fc2482eec68da798d849acaa30c5de8
Author: Ravishankar N <ravishankar@redhat.com>
Date:   Mon Dec 7 18:03:03 2015 +0530

    afr: refresh inode using fstat
    
    Backport of http://review.gluster.org/12894
    
    For fd based operations (fgetxattr, readv etc.) if an inode refresh is
    required, do so using fstat instead of lookup. This is because the file
    might have been deleted by another client before refresh but posix
    mandates that FOPS using already open fds must still succeed.
    
    Change-Id: Id5f71c3af4892b648eb747f363dffe6208e7ac09
    BUG: 1290363
    Signed-off-by: Ravishankar N <ravishankar@redhat.com>
    Reviewed-on: http://review.gluster.org/13040
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
Comment 5 Vijay Bellur 2016-01-06 05:42:16 EST
COMMIT: http://review.gluster.org/12939 committed in release-3.7 by Raghavendra G (rgowdapp@redhat.com) 
------
commit 1a464c2ef3b8351e2d5217009d9a0a20e03add9a
Author: Susant Palai <spalai@redhat.com>
Date:   Wed Dec 9 03:53:45 2015 -0500

    storage/posix: fix dict leak in posix_fgetxattr
    
    BUG: 1290363
    Change-Id: I49200316250b9894fdbf93ae33e50b02abb74db8
    Reviewed-on: http://review.gluster.org/12916
    Tested-by: Gluster Build System <jenkins@build.gluster.com>
    Tested-by: NetBSD Build System <jenkins@build.gluster.org>
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Signed-off-by: Susant Palai <spalai@redhat.com>
    Reviewed-on: http://review.gluster.org/12939
    Reviewed-by: Raghavendra G <rgowdapp@redhat.com>
Comment 6 Kaushal 2016-04-19 03:50:44 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user

Note You need to log in before you can comment on or make changes to this bug.