Bug 1291557 - Data Tiering:File create terminates with "Input/output error" as split brain is observed
Data Tiering:File create terminates with "Input/output error" as split brain ...
Status: CLOSED CURRENTRELEASE
Product: GlusterFS
Classification: Community
Component: disperse (Show other bugs)
3.7.6
Unspecified Unspecified
urgent Severity urgent
: ---
: ---
Assigned To: Ashish Pandey
: ZStream
Depends On: 1275751 1286028 1286029
Blocks: 1260923 1285230 1290363 1358823
  Show dependency treegraph
 
Reported: 2015-12-15 02:05 EST by Ashish Pandey
Modified: 2016-07-21 10:39 EDT (History)
6 users (show)

See Also:
Fixed In Version: glusterfs-3.7.7
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of: 1286029
: 1358823 (view as bug list)
Environment:
Last Closed: 2016-04-19 03:51:02 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Comment 1 Vijay Bellur 2015-12-15 02:16:28 EST
REVIEW: http://review.gluster.org/12968 (storage/posix: Implement .unlink directory) posted (#1) for review on release-3.7 by Ashish Pandey (aspandey@redhat.com)
Comment 2 Vijay Bellur 2015-12-15 02:36:55 EST
REVIEW: http://review.gluster.org/12968 (storage/posix: Implement .unlink directory) posted (#2) for review on release-3.7 by Ashish Pandey (aspandey@redhat.com)
Comment 3 Vijay Bellur 2015-12-22 00:59:36 EST
REVIEW: http://review.gluster.org/12968 (storage/posix: Implement .unlink directory) posted (#3) for review on release-3.7 by Ashish Pandey (aspandey@redhat.com)
Comment 4 Vijay Bellur 2016-01-13 02:16:35 EST
REVIEW: http://review.gluster.org/12968 (storage/posix: Implement .unlink directory) posted (#4) for review on release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 5 Vijay Bellur 2016-01-18 20:28:45 EST
REVIEW: http://review.gluster.org/12968 (storage/posix: Implement .unlink directory) posted (#5) for review on release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 6 Vijay Bellur 2016-01-24 21:44:59 EST
REVIEW: http://review.gluster.org/12968 (storage/posix: Implement .unlink directory) posted (#6) for review on release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com)
Comment 7 Vijay Bellur 2016-01-25 06:37:13 EST
COMMIT: http://review.gluster.org/12968 committed in release-3.7 by Pranith Kumar Karampuri (pkarampu@redhat.com) 
------
commit 195548f55b09bf71db92929b7b734407b863093c
Author: Ashish Pandey <aspandey@redhat.com>
Date:   Thu Nov 26 14:35:49 2015 +0530

    storage/posix: Implement .unlink directory
    
    Problem: For EC volume, If a file descriptor is open and
    file has been unlinked, any further write on that fd will
    fail. When a write request comes, EC internally reads some
    blocks using anonymous fd. This read will fail as the file
    has already been unlinked.
    
    Solution: To solve this issue, we are using .unlink directory
    to keep track of unlinked file. If a file is to be unlinked
    while its fd is open, move this to .unlink directory and unlink
    it from .glusterfs and real path. Once all the fd will be closed,
    remove this entry form .unlink directory.
    
    master -
    http://review.gluster.org/#/c/12816/
    
    Change-Id: I8344edb0d340bdb883dc46458c16edbc336916b9
    BUG: 1291557
    Signed-off-by: Ashish Pandey <aspandey@redhat.com>
    Reviewed-on: http://review.gluster.org/12968
    Reviewed-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Tested-by: Pranith Kumar Karampuri <pkarampu@redhat.com>
    Smoke: Gluster Build System <jenkins@build.gluster.com>
    CentOS-regression: Gluster Build System <jenkins@build.gluster.com>
    NetBSD-regression: NetBSD Build System <jenkins@build.gluster.org>
Comment 8 Vijay Bellur 2016-02-16 01:37:38 EST
REVIEW: http://review.gluster.org/13449 (posix: fix posix_fgetxattr to return the correct error) posted (#1) for review on release-3.7 by Susant Palai (spalai@redhat.com)
Comment 9 Vijay Bellur 2016-03-21 03:28:08 EDT
REVIEW: http://review.gluster.org/13449 (posix: fix posix_fgetxattr to return the correct error) posted (#2) for review on release-3.7 by Susant Palai (spalai@redhat.com)
Comment 10 Mike McCune 2016-03-28 18:16:42 EDT
This bug was accidentally moved from POST to MODIFIED via an error in automation, please see mmccune@redhat.com with any questions
Comment 11 Kaushal 2016-04-19 03:51:02 EDT
This bug is getting closed because a release has been made available that should address the reported issue. In case the problem is still not fixed with glusterfs-3.7.7, please open a new bug report.

glusterfs-3.7.7 has been announced on the Gluster mailinglists [1], packages for several distributions should become available in the near future. Keep an eye on the Gluster Users mailinglist [2] and the update infrastructure for your distribution.

[1] https://www.gluster.org/pipermail/gluster-users/2016-February/025292.html
[2] http://thread.gmane.org/gmane.comp.file-systems.gluster.user
Comment 12 Vijay Bellur 2016-07-15 03:00:23 EDT
REVIEW: http://review.gluster.org/13449 (posix: fix posix_fgetxattr to return the correct error) posted (#3) for review on release-3.7 by Susant Palai (spalai@redhat.com)

Note You need to log in before you can comment on or make changes to this bug.