This service will be undergoing maintenance at 00:00 UTC, 2017-10-23 It is expected to last about 30 minutes
Bug 135209 - (rhgb-nodri) No direct rendering when booting init 5
No direct rendering when booting init 5
Status: CLOSED CURRENTRELEASE
Product: Fedora
Classification: Fedora
Component: xorg-x11 (Show other bugs)
3
All Linux
medium Severity high
: ---
: ---
Assigned To: X/OpenGL Maintenance List
David Lawrence
:
: 134968 135071 135075 135884 135988 (view as bug list)
Depends On:
Blocks: FC3Blocker
  Show dependency treegraph
 
Reported: 2004-10-10 11:33 EDT by louisgtwo
Modified: 2007-11-30 17:10 EST (History)
7 users (show)

See Also:
Fixed In Version: 6.8.1-6
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-08-19 18:42:36 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description louisgtwo 2004-10-10 11:33:31 EDT
When booting in init 5, or graphical mode with rhgb I don't get direct
rendering support with my radeon 7500 when first logging in. If,
however, the I execute a log out and then log back in, direct
rendering is enabled.

Daniel Veillard commented since rhgb now starts the X server of gdm in
parallel to ease the visual transition from the graphical boot to the
gdm prompt, this might be related

As a side note, when booting in init 3 and executing a startx direct
rendering is present.

Version-Release number of selected component:
kernel-2.6.8-1.603
xorg-x11-6.8.1-4
rhgb-0.13.5-2
Comment 1 Jukka Ketelaars 2004-10-11 11:51:27 EDT
This looks like a variation on bug 1220 at freedesktop.org
(https://freedesktop.org/bugzilla/show_bug.cgi?id=1220). It contains a
fix (not yet in cvs), maybe it also fixes this problem...
Comment 2 Mike A. Harris 2004-10-12 01:26:00 EDT
It sounds to me like the environment rhgb starts up in is different
from what the X server normally starts up in, and that might
be causing DRI to fail to start.  In order to diagnose this,
we will need you to reboot the system, to re-trigger the
problem, then while in X copy the complete X server log, config
file, and /var/log/messages from boot time onward.  Please attach
these as individual uncompressed files using the bugzilla file
attachment link below.

Thanks in advance.
Comment 3 Daniel Veillard 2004-10-12 09:26:49 EDT
Mike, the request for debugging files are unreasonnable as 
rhgb starts X from a temporary memory filesystem and there is no
way an user can get into the system and grab those before the
memory filesystem gets unmounted.
But if it can be reproduced outside of RHGB by starting 2 servers
simultaneously (:0 and :1) then yes logs files can be gathered.

Daniel
Comment 4 Kristian Høgsberg 2004-10-15 14:07:15 EDT
This should now be fixed.  The xorg-x11-6.8.1-6 X server supports an
option to disable DRI and rhgb-0.14.1-1 use this option to disable DRI
for the rhgb X server.  This means that the GDM X server will be able
to initialize DRI properly.

Please update to at least those versions of xorg-x11 and rhgb and give
it a try again.

Thanks!
Comment 5 Kristian Høgsberg 2004-10-15 14:10:01 EDT
*** Bug 135071 has been marked as a duplicate of this bug. ***
Comment 6 Daniel Veillard 2004-10-15 14:30:23 EDT
*** Bug 135884 has been marked as a duplicate of this bug. ***
Comment 7 Mike A. Harris 2004-10-16 16:50:10 EDT
*** Bug 135988 has been marked as a duplicate of this bug. ***
Comment 8 Mike A. Harris 2004-10-16 16:58:08 EDT
*** Bug 134968 has been marked as a duplicate of this bug. ***
Comment 9 Mike A. Harris 2004-10-16 17:04:42 EDT
*** Bug 135075 has been marked as a duplicate of this bug. ***
Comment 10 Marius Andreiana 2005-08-19 16:49:56 EDT
Reporters, does FC4 work for you?

Note You need to log in before you can comment on or make changes to this bug.