Bug 135912 - Various Evolution dialogs on x86_64 broken due to libgal2 looking in wrong place for its glade files
Various Evolution dialogs on x86_64 broken due to libgal2 looking in wrong pl...
Status: CLOSED RAWHIDE
Product: Fedora
Classification: Fedora
Component: libgal2 (Show other bugs)
rawhide
x86_64 Linux
medium Severity medium
: ---
: ---
Assigned To: Dave Malcolm
:
: 135916 136734 136735 136736 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-15 15:07 EDT by Colin Walters
Modified: 2007-11-30 17:10 EST (History)
1 user (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2004-10-26 16:26:40 EDT
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Colin Walters 2004-10-15 15:07:09 EDT
User-Agent:       
Build Identifier: 

Clicking "Categories" causes a crash.  I'll get you a backtrace in a minute.

Reproducible: Always
Steps to Reproduce:
1. Start evolution
2. Click Calendars
3. Click New
4. Click Categories
Comment 1 Colin Walters 2004-10-15 15:08:58 EDT
#0  0x0000002a95a18f7a in waitpid () from /lib64/tls/libpthread.so.0
#1  0x0000003060458c14 in libgnomeui_module_info_get () from
/usr/lib64/libgnomeui-2.so.0
#2  <signal handler called>
#3  0x000000305e7169ef in g_datalist_id_set_data_full () from
/usr/lib64/libglib-2.0.so.0
#4  0x000000305e90e1e1 in g_object_interface_list_properties ()
   from /usr/lib64/libgobject-2.0.so.0
#5  0x000000305e90e493 in g_object_unref () from /usr/lib64/libgobject-2.0.so.0
#6  0x0000003062248769 in e_categories_new () from /usr/lib64/libgal-2.2.so.1
#7  0x0000003062512d95 in e_categories_config_open_dialog_for_entry ()
   from /usr/lib64/evolution/2.0/libeutil.so.0
#8  0x000000305e90bfaa in g_closure_invoke () from /usr/lib64/libgobject-2.0.so.0
#9  0x000000305e92158a in g_signal_has_handler_pending () from
/usr/lib64/libgobject-2.0.so.0
#10 0x000000305e922d36 in g_signal_emit_valist () from
/usr/lib64/libgobject-2.0.so.0
#11 0x000000305e923083 in g_signal_emit () from /usr/lib64/libgobject-2.0.so.0
#12 0x000000305ef6fe48 in gtk_button_get_alignment () from
/usr/lib64/libgtk-x11-2.0.so.0
#13 0x000000305e90bfaa in g_closure_invoke () from /usr/lib64/libgobject-2.0.so.0
#14 0x000000305e920b90 in g_signal_has_handler_pending () from
/usr/lib64/libgobject-2.0.so.0
#15 0x000000305e922d36 in g_signal_emit_valist () from
/usr/lib64/libgobject-2.0.so.0
#16 0x000000305e923083 in g_signal_emit () from /usr/lib64/libgobject-2.0.so.0
#17 0x000000305ef6f309 in gtk_button_set_relief () from
/usr/lib64/libgtk-x11-2.0.so.0
#18 0x000000305f01ad66 in gtk_marshal_VOID__UINT_STRING () from
/usr/lib64/libgtk-x11-2.0.so.0
#19 0x000000305e90bfaa in g_closure_invoke () from /usr/lib64/libgobject-2.0.so.0
#20 0x000000305e920f1c in g_signal_has_handler_pending () from
/usr/lib64/libgobject-2.0.so.0
#21 0x000000305e92299d in g_signal_emit_valist () from
/usr/lib64/libgobject-2.0.so.0
#22 0x000000305e923083 in g_signal_emit () from /usr/lib64/libgobject-2.0.so.0
#23 0x000000305f105880 in gtk_widget_activate () from /usr/lib64/libgtk-x11-2.0.so.0
#24 0x000000305f018d4e in gtk_propagate_event () from /usr/lib64/libgtk-x11-2.0.so.0
#25 0x000000305f0190d5 in gtk_main_do_event () from /usr/lib64/libgtk-x11-2.0.so.0
#26 0x000000305fc44b40 in gdk_event_get_graphics_expose () from
/usr/lib64/libgdk-x11-2.0.so.0
#27 0x000000305e7266bd in g_main_context_dispatch () from
/usr/lib64/libglib-2.0.so.0
#28 0x000000305e728397 in g_main_context_acquire () from /usr/lib64/libglib-2.0.so.0
#29 0x000000305e728735 in g_main_loop_run () from /usr/lib64/libglib-2.0.so.0
#30 0x000000306082da7b in bonobo_main () from /usr/lib64/libbonobo-2.so.0
#31 0x000000000041c1ab in main ()
Comment 2 Dave Malcolm 2004-10-15 15:35:05 EDT
This is the Categories button in the New Appointment dialog.  It works
for me on i386, perhaps an x86_64 bug.

Comment 3 Colin Walters 2004-10-15 16:00:09 EDT
Confirmed this still appears even with GConf working.  Here's a better backtrace.  

#0  0x0000002a98305f7a in waitpid () from /lib64/tls/libpthread.so.0
#1  0x0000002a96919c14 in libgnomeui_module_info_get () from
/usr/lib64/libgnomeui-2.so.0
#2  <signal handler called>
#3  g_datalist_id_set_data_full (datalist=0xbc15a0, key_id=47, data=0x0,
destroy_func=0) at gdataset.c:220
#4  0x0000002a98cb01e1 in g_object_real_dispose (object=0xbc1590) at gobject.c:523
#5  0x0000002a98cb0493 in g_object_unref (_object=0x2a99174d68) at gobject.c:557
#6  0x0000002a9643a769 in e_categories_new (initial_category_list=0xb19190 "")
at e-categories.c:648
#7  0x0000002a959e0d95 in e_categories_config_open_dialog_for_entry
(entry=0xb173d0) at e-categories-config.c:188
#8  0x0000002a98cadfaa in g_closure_invoke (closure=0xb5be80, return_value=0x0,
n_param_values=1,
    param_values=0x7fbfffe580, invocation_hint=0x7fbfffe430) at gclosure.c:437
#9  0x0000002a98cc358a in signal_emit_unlocked_R (node=0x7910e0, detail=0,
instance=0x916cc0,
    emission_return=0x0, instance_and_params=0x7fbfffe580) at gsignal.c:2435
#10 0x0000002a98cc4d36 in g_signal_emit_valist (instance=0x916cc0,
signal_id=3221218688, detail=0,
    var_args=0x7fbfffe740) at gsignal.c:2194
#11 0x0000002a98cc5083 in g_signal_emit (instance=0x2a99174d68, signal_id=1,
detail=0) at gsignal.c:2238
#12 0x0000002a97f63e48 in gtk_real_button_released (button=0x916cc0) at
gtkbutton.c:1220
#13 0x0000002a98cadfaa in g_closure_invoke (closure=0x790f40, return_value=0x0,
n_param_values=1,
    param_values=0x7fbfffeb80, invocation_hint=0x7fbfffea30) at gclosure.c:437
#14 0x0000002a98cc2b90 in signal_emit_unlocked_R (node=0x790fd0, detail=0,
instance=0x916cc0,
    emission_return=0x0, instance_and_params=0x7fbfffeb80) at gsignal.c:2365
#15 0x0000002a98cc4d36 in g_signal_emit_valist (instance=0x916cc0,
signal_id=3221220224, detail=0,
    var_args=0x7fbfffed40) at gsignal.c:2194
#16 0x0000002a98cc5083 in g_signal_emit (instance=0x2a99174d68, signal_id=1,
detail=0) at gsignal.c:2238
#17 0x0000002a97f63309 in gtk_button_button_release (widget=0x2a99174d68,
event=0x1) at gtkbutton.c:1136
#18 0x0000002a9800ed66 in _gtk_marshal_BOOLEAN__BOXED (closure=0x56f740,
return_value=0x7fbffff040,
    n_param_values=0, param_values=0x7fbffff1c0, invocation_hint=0x2a99174d68,
marshal_data=0x2a97f632f0)
    at gtkmarshalers.c:82
#19 0x0000002a98cadfaa in g_closure_invoke (closure=0x56f740,
return_value=0x7fbffff040, n_param_values=2,
    param_values=0x7fbffff1c0, invocation_hint=0x7fbffff070) at gclosure.c:437
#20 0x0000002a98cc2f1c in signal_emit_unlocked_R (node=0x56f7d0, detail=0,
instance=0x916cc0,
    emission_return=0x7fbffff150, instance_and_params=0x7fbffff1c0) at
gsignal.c:2473
#21 0x0000002a98cc499d in g_signal_emit_valist (instance=0x916cc0, signal_id=0,
detail=0, var_args=0x7fbffff380)
    at gsignal.c:2204
#22 0x0000002a98cc5083 in g_signal_emit (instance=0x2a99174d68, signal_id=1,
detail=0) at gsignal.c:2238
#23 0x0000002a980f9880 in gtk_widget_event_internal (widget=0x916cc0,
event=0x6bc160) at gtkwidget.c:3564
#24 0x0000002a9800cd4e in gtk_propagate_event (widget=0x916cc0, event=0x6bc160)
at gtkmain.c:2345
#25 0x0000002a9800d0d5 in gtk_main_do_event (event=0x6bc160) at gtkmain.c:1583
#26 0x0000002a98453b40 in gdk_event_dispatch (source=0x2a99174d68, callback=0x1,
user_data=0x0)
    at gdkevents-x11.c:2184
#27 0x0000002a990136bd in g_main_context_dispatch (context=0x55df70) at gmain.c:1942
#28 0x0000002a99015397 in g_main_context_iterate (context=0x55df70,
block=-1725757728, dispatch=1, self=0x0)
    at gmain.c:2573
#29 0x0000002a99015735 in g_main_loop_run (loop=0x6aeb00) at gmain.c:2777
#30 0x0000002a97291a7b in bonobo_main () from /usr/lib64/libbonobo-2.so.0
#31 0x000000000041c1ab in main (argc=5458416, argv=0x0) at main.c:585
Comment 4 Dave Malcolm 2004-10-21 18:08:45 EDT
*** Bug 135916 has been marked as a duplicate of this bug. ***
Comment 5 Dave Malcolm 2004-10-21 18:12:16 EDT
Something went wront with the build of libgal2, it's trying          
                                                                     
                                        and failing to load a glade
file from:
'/usr/src/build/468338-x86_64/install/usr/share/gal-2.2/2.2.3/glade/gal-categories.glade'
Comment 6 Dave Malcolm 2004-10-22 11:40:37 EDT
*** Bug 136736 has been marked as a duplicate of this bug. ***
Comment 7 Dave Malcolm 2004-10-22 11:41:01 EDT
*** Bug 136734 has been marked as a duplicate of this bug. ***
Comment 8 Dave Malcolm 2004-10-22 11:47:47 EDT
*** Bug 136735 has been marked as a duplicate of this bug. ***
Comment 9 Dave Malcolm 2004-10-22 19:27:02 EDT
I've rebuilt libgal2 (version libgal2 2:2.2.3-3) and verified that the
define of GAL_GLADEDIR in all of the buildlogs is correct; I will test
and then pester the release manager to get this into Rawhide.
Comment 10 Dave Malcolm 2004-10-22 19:50:23 EDT
Tested successfully on i386
Comment 11 Dave Malcolm 2004-10-25 15:02:08 EDT
Also tested succesfully on x86_64; I'll close this when the package is
in rawhide...
Comment 12 Dave Malcolm 2004-10-26 16:26:40 EDT
OK, libgal2-2.2.3-3 is now in Rawhide; resolving as RAWHIDE

Note You need to log in before you can comment on or make changes to this bug.