This service will be undergoing maintenance at 00:00 UTC, 2016-09-28. It is expected to last about 1 hours
Bug 136938 - odd line at right of screen appears when clicking on panel button
odd line at right of screen appears when clicking on panel button
Status: CLOSED RAWHIDE
Product: Red Hat Enterprise Linux 4
Classification: Red Hat
Component: gnome-panel (Show other bugs)
4.0
All Linux
medium Severity medium
: ---
: ---
Assigned To: Mark McLoughlin
:
: 138597 139117 139206 149830 (view as bug list)
Depends On:
Blocks:
  Show dependency treegraph
 
Reported: 2004-10-23 12:40 EDT by Chris Runge
Modified: 2007-11-30 17:07 EST (History)
9 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2005-01-14 07:00:27 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:


Attachments (Terms of Use)
Shows a line of corrupted pixels on the right (877.68 KB, image/png)
2004-11-05 15:32 EST, Alexander Boström
no flags Details
screenshot in FC3 with the problem (547.18 KB, image/png)
2004-11-07 17:49 EST, Chris Runge
no flags Details
Rogue yellow line on RHS (179.26 KB, application/octet-stream)
2004-11-22 06:26 EST, Tim Towers
no flags Details

  None (edit)
Description Chris Runge 2004-10-23 12:40:25 EDT
Description of problem:

An odd bright line about a pixel wide appears at the extreme right
edge of the screen when clicking on an icon on the panel (e.g., on the
GNOME terminal icon). The line remains until you click on the desktop
background.

Updating to post-beta 1 RPMS don't fix this issue.

Note: it isn't apparent exactly which component is doing this;
gnome-panel is my best swag at this point.

Version-Release number of selected component (if applicable):

$ rpm -q gnome-panel xorg-x11 metacity
gnome-panel-2.8.1-3
xorg-x11-6.8.1-12
metacity-2.8.6-2

How reproducible:

100%

Steps to Reproduce:
1. Start a GNOME session with no other apps running
2. With the desktop background showing, click on the GNOME terminal
icon on the panel
3. The bright line appears at the right edge of the screen
4. Click on the background to remove the bright line
  
Additional info:

This appears on an IBM ThinkPad T30 with a 1400x1050 screen and an ATI
Mobility 7500 chip. It has never been an issue on previous RHEL or FC
or RHL releases. The problem does not seem to occur on an IBM ThinkPad
T41 with a 1024x768 screen and an ATI Mobility 7500 chip.
Comment 1 Peter Jones 2004-10-25 18:12:12 EDT
Happens on my 1400x1050 T41 with a Radeon M9 as well.  lspci for the
card shows:

01:00.0 VGA compatible controller: ATI Technologies Inc Radeon R250 Lf
[Radeon Mobility 9000 M9] (rev 02) (prog-if 00 [VGA])
        Subsystem: IBM: Unknown device 0531
        Flags: bus master, stepping, fast Back2Back, 66Mhz, medium
devsel, latency 66, IRQ 4
        Memory at e0000000 (32-bit, prefetchable) [size=128M]
        I/O ports at 3000 [size=256]
        Memory at c0100000 (32-bit, non-prefetchable) [size=64K]
        Capabilities: [58] AGP version 2.0
        Capabilities: [50] Power Management version 2
Comment 2 Mark McLoughlin 2004-10-28 10:05:47 EDT
A screenshot would be very helpful in explaining what you're seeing -
e.g. where is this terinal icon you speak of ? :)

However, I have noticed something similar under icons in the
notification area in the past.
Comment 3 Chris Runge 2004-10-28 10:50:30 EDT
I don't have access to the system right now, but will try to get this
info to you.

The terminal icon was added manually to the panel; I *think* the same
behavior occurred whenever I clicked on any other panel icon as well
(that didn't immediately bring the app fullscreen).
Comment 4 Alexander Boström 2004-11-05 15:08:15 EST
This is most likely caused by the splash effect and maybe some X bug.
I see this on FC devel too. Using IBM Thinkpad with "S3 Savage/IX"
gfx. Attaching screenshot.
Comment 5 Alexander Boström 2004-11-05 15:32:20 EST
Created attachment 106238 [details]
Shows a line of corrupted pixels on the right
Comment 6 Alexander Boström 2004-11-05 15:37:16 EST
It looks like every pixel along the right except the topmost one gets
their red and green values inverted (x => 255-x), but the blue value
stays the same.

The effect is visible on a screenshot but disappears after a redraw.
Comment 7 Alexander Boström 2004-11-05 16:50:01 EST
Probably related:

http://bugzilla.gnome.org/show_bug.cgi?id=153996
Comment 8 Chris Runge 2004-11-07 17:49:34 EST
Created attachment 106264 [details]
screenshot in FC3 with the problem

This seems to be a problem in FC3 as well (except now the line appears to be
yellow).

Note that the problem only appears if an already running application is not
maximized before launching a non-maximized application from the panel. If an
already running application is maximized then the line does not appear.
Comment 9 Bill Nottingham 2004-11-10 03:02:44 EST
*** Bug 138597 has been marked as a duplicate of this bug. ***
Comment 10 Benny Sun 2004-11-11 21:50:40 EST
I want to add that the line probably comes from the visual effect that
happens immediately following the clicking of a launcher. The
rectangle is yellow in color and expands out past the edges of the
screen, all except for the right side of the rectangle.
Comment 11 Mark McLoughlin 2004-11-12 12:12:28 EST
The panel has code to draw an an xor based animation when you click
the launcher. Most likely the culprit, but not neccessarily a panel bug.

See gnome-panel/gnome-panel/xstuff.c:xstuff.c:xstuff_zoom_animate(). 

Might be worth pulling the code as a test case and seeing if we still
reproduce the problem, but its more likely that it needs to be the
same client doing the grabbing/drawing which causes us not to get
expose events or something. Just a guess, needs debugging.
Comment 12 Mark McLoughlin 2004-11-14 14:30:41 EST
*** Bug 139206 has been marked as a duplicate of this bug. ***
Comment 13 Mark McLoughlin 2004-11-15 04:01:25 EST
*** Bug 139117 has been marked as a duplicate of this bug. ***
Comment 14 Tim Towers 2004-11-22 06:26:44 EST
Created attachment 107175 [details]
Rogue yellow line on RHS

view with "gunzip < filename | xwud". This picture shows the yellow line does
not extend the full height of my window.
Comment 15 Tim Towers 2004-11-22 06:28:57 EST
I have had a yellow line one pixel wide on the right hand side of my
screen for days now. The line does not extend all the way down the
screen though. I have attached a bitmap image to this bug for your
perusal.

Dragging a window over the line lets it redraw with the correct xroot
picture, and I can reproduce the line at will by opening an xterm from
the panel.

xdpyinfo says that I am running 1280x1024
Comment 16 Andrew D. Stadler 2004-11-23 22:25:53 EST
I am also seeing the yellow line, behaving roughly as described in the
above submissions.  I'm on a ThinkPad T30, Radeon 7500, 1400x1050,
running FC3.

gnome-panel-2.8.1-3
xorg-x11-6.8.1-12.FC3.1
metacity-2.8.6-2

For me it began when I placed a FireFox launcher in my bottom panel. 
Each click of this launcher toggles the yellow line.  Launching
FireFox from the Internet menu doesn't cause it.  (another launcher,
for another program, also creates the yellow line)
Comment 17 Mark McLoughlin 2004-11-26 11:51:11 EST
Upstream bug with a patch:

  http://bugzilla.gnome.org/show_bug.cgi?id=156162
Comment 18 Mark McLoughlin 2004-11-26 12:47:47 EST
Built fix into dist-4E-HEAD and dist-fc4
Comment 19 Bas Mevissen 2004-12-09 11:37:29 EST
Bug fixed in gnome-panel-1.8.2. Can this be updated in FC3 soon, please?
Comment 20 Bas Mevissen 2004-12-09 19:00:22 EST
OK, new package build, based upon the core 3 package. Here are the
.spec file and the binary RPMS:

<http://www.basmevissen.nl/RPM/gnome-panel/>

Note that there is a problem introduced with the clock.scheme file in
gnome-panel-2.8.2:

[root@blower SPECS]# rpm -Uhv 
/usr/src/redhat/RPMS/i386/gnome-panel-2.8.2-1sgm.i386.rpm
/usr/src/redhat/RPMS/i386/gnome-panel-devel-2.8.2-1sgm.i386.rpm
Preparing...               
########################################### [100%]
   1:gnome-panel           
########################################### [ 50%]
WARNING: Failed to parse default value `୨୪' for schema
(/schemas/apps/clock_applet/prefs/hour_format)
   2:gnome-panel-devel     
########################################### [100%]

I'll take this upstream.
Comment 21 Jay Turner 2005-01-14 07:00:27 EST
Closing out as patch included in latest code.  Please reopen if problems still
occur with the latest code.
Comment 22 Bas Mevissen 2005-03-16 07:22:36 EST
(In reply to comment #21)
> Closing out as patch included in latest code.  Please reopen if problems still
> occur with the latest code.

Can this latest code be used for an official Fedora Core 3 update?

Comment 23 Wesley Haines 2005-04-12 16:41:07 EDT
*** Bug 149830 has been marked as a duplicate of this bug. ***

Note You need to log in before you can comment on or make changes to this bug.