Bug 140103 - random crashes in eggcups/desktop apps
random crashes in eggcups/desktop apps
Status: CLOSED DUPLICATE of bug 140081
Product: Fedora
Classification: Fedora
Component: desktop-printing (Show other bugs)
3
i586 Linux
medium Severity medium
: ---
: ---
Assigned To: Colin Walters
http://www.philwelchdns.net
:
Depends On:
Blocks: 135876
  Show dependency treegraph
 
Reported: 2004-11-19 14:49 EST by Phil Welch
Modified: 2007-11-30 17:10 EST (History)
2 users (show)

See Also:
Fixed In Version:
Doc Type: Bug Fix
Doc Text:
Story Points: ---
Clone Of:
Environment:
Last Closed: 2006-02-21 14:07:09 EST
Type: ---
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)

  None (edit)
Description Phil Welch 2004-11-19 14:49:09 EST
From Bugzilla Helper:
User-Agent: Mozilla/5.0 (X11; U; Linux i686; en-US; rv:1.7.5)
Gecko/20041111 Firefox/1.0

Description of problem:
Error message comes up when the screen is being painted after a cold
reboot indicating that eggcups failed.  cups version is
cups-1.1.22-0.rc1.8.  Screen is left devoid of any icons and will not
allow right click to open terminal window, etc.  No references to
eggcups in /var/log other than installation prelink message. 
/var/log/messages states "Nov 19 11:22:37 localhost
cups-config-daemon: cups-config-daemon startup succeeded".  Don't know
the relationship between cups and eggcups.
Note that this box does not currently have a printer attached and has
not had a printer attached since FC3 was installed and yum updated
including latest kernel.

kernel-2.6.9-1.667
kernel-2.6.9-1.678_FC3


Version-Release number of selected component (if applicable):
cups-1.1.22-0.rc1.8 

How reproducible:
Always

Steps to Reproduce:
1. reboot
2. login
3. fails
    

Actual Results:  same

Expected Results:  paint desktop icons and not fail.  Was not failing
until FC3 updates were applied.

Additional info:
Comment 1 Colin Walters 2004-11-19 18:00:04 EST
Can you try running this command, and attach the resulting tarball to
the bug report?

tar chjf eggcups-libraries.tar.bz2 `LD_TRACE_PRELINKING=1 LD_WARN=
/usr/bin/eggcups | awk '{print $3}'`

After doing that, can you run: 
prelink /usr/bin/eggcups
And see if it fixes the problem?
Comment 2 Phil Welch 2004-11-19 18:12:11 EST
I put your multicode in fix.sh but got a tar empty message.  Then I
ran the command standalong and got nothing, after which I ran the
/usr/bin/eggcups and got a popup message saying eggcups had failed. 
It came up three times.

[root@localhost ~]# vi fix.sh
[root@localhost ~]# LD_TRACE_PRELINKING=1 LD_WARN=/usr/bin/eggcups
[root@localhost ~]# ./fix.sh
tar: Cowardly refusing to create an empty archive
Try `tar --help' for more information.
[root@localhost ~]# /usr/bin/eggcups
Illegal instruction
Comment 3 Phil Welch 2004-11-19 18:30:32 EST
did the prelink; cold reboot with cups/config deactivated and
everything came up without error and with the screen icons painted
normally.  Then activated cups/config and did another code reboot
without error and screen icons painted normally.  I would say the
problem has been resolved.  Thanks.  Phil
Comment 4 Colin Walters 2004-11-19 18:58:13 EST
It should have been:

tar chjf eggcups-libraries.tar.bz2 
`LD_TRACE_PRELINKING=1 LD_WARN= /usr/bin/eggcups | awk '{print $3}'`

Unfortunately Bugzilla or Mozilla (not sure which) evilly line-wraps
the comments.  

I'm keeping this bug open as a tracker.
Comment 5 Marc Deslauriers 2004-11-20 09:19:31 EST
I had the same problem after installing all the latest patches.
eggcups and gnome-volume-manager both die when I open a new session.

Here is the tarball as asked for in this bug report (too big to attach
here):

http://www.infostrategique.com/linuxrpms/marc/eggcups-libraries.tar.bz2
Comment 6 Andrew Buyuk 2004-11-21 01:28:44 EST
I have the same problem as Comment #5.  I suspect it is one of the
newer packages that was installed.  I installed 3 new ones today.

Man
Slang
and one other
Comment 7 Remi COLLET 2004-11-21 04:30:24 EST
I have the same problem as #5.
I've try to rollback slang, rhgb, gamin and udev.

Same probleme persist with kernel-2.6.9-1.667 and kernel-2.6.9-1.678_FC3

I've don't try to roolback xorg.
Comment 8 Deron Meranda 2004-11-21 05:55:22 EST
FYI, this bug is also being tracked over at the Gnome project's
buzilla database as their bug 151307,
http://bugzilla.gnome.org/show_bug.cgi?id=151307

Running the prelink command has fixed the problem on all my FC3
systems.  I suspect this may have been introduced with the kernel
update to 2.6.9-1.678_FC3.

To fix:
  1. reboot using kernel 2.6.9-1.678_FC3
  2. log in as root (if necessary select the "fail safe" session type
from the graphical login's "session" menu on the login page).
  3. At a shell prompt run,
      prelink /usr/lib/libdbus*so*
Comment 9 Remi COLLET 2004-11-21 11:35:25 EST
I confirm that running "/usr/sbin/prelink /usr/lib/libdbus*so*" fixed
the problem for me (as in bug 14081) for eggcups and gnome-volume-manager.
Thanks
Comment 10 P Jones 2004-11-21 13:11:33 EST
The fix in comment #9 solved the problem I was having on my laptop,
where, during bootup, the HAL daemon was failing. When logging into
GNOME, the splash screen would stop on the printer icon. The rest of
the desktop would load and be functional, but the splash screen would
stay on the desktop. On shutdown, cups-config-daemon would fail.

The question I have is this; prelink runs on a daily basis anyway,
right? Theoretically just leaving one's machines on overnight should
fix the problem, no?
Comment 11 Need Real Name 2004-11-21 18:02:47 EST
comments about
" Additional Comment #8 From Deron Meranda  on 2004-11-21 05:'-------

Running the prelink command has fixed the problem on all my FC3
systems.  I suspect this may have been introduced with the kernel
update to 2.6.9-1.678_FC3.

To fix:
  1. reboot using kernel 2.6.9-1.678_FC3
  2. log in as root (if necessary select the "fail safe" session type
from the graphical login's "session" menu on the login page).
  3. At a shell prompt run,
      prelink /usr/lib/libdbus*so*

no positive changes in my FC3 distro recently yum updated version
no negative changes, too.
jonas2@optimum2.mii.lt
Comment 12 Leo Canale 2004-11-22 18:36:46 EST
Running the prelink command has fixed the problem on my FC3.
I did not have kernel 2.6.9-1.678_FC3 installed I had kernel-2.6.9-1.667
It also continued to happen with kernel-2.6.9-1.681_FC3
Comment 13 Havoc Pennington 2004-11-23 09:54:12 EST
Is this assigned to the right person to get it fixed?
Comment 14 Colin Walters 2004-11-23 10:18:07 EST

*** This bug has been marked as a duplicate of 140081 ***
Comment 15 Red Hat Bugzilla 2006-02-21 14:07:09 EST
Changed to 'CLOSED' state since 'RESOLVED' has been deprecated.

Note You need to log in before you can comment on or make changes to this bug.