Bug 1479055 - Horizon won't load with OSP11 - Script timed out before returning headers: django.wsgi
Horizon won't load with OSP11 - Script timed out before returning headers: dj...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
9.0 (Mitaka)
x86_64 Linux
medium Severity medium
: zstream
: 9.0 (Mitaka)
Assigned To: Radomir Dopieralski
Ido Ovadia
: Triaged, ZStream
Depends On: 1478042 1479051 1496173
Blocks: 1479056 1485889 1478870 1479057 1479058 1479732 1481774 1485890 1485894
  Show dependency treegraph
 
Reported: 2017-08-07 16:45 EDT by Radomir Dopieralski
Modified: 2017-09-26 11:18 EDT (History)
16 users (show)

See Also:
Fixed In Version: python-django-horizon-9.0.1-14.el7ost
Doc Type: Bug Fix
Doc Text:
Cause: Some binary python modules used by Horizon were compiled with a flag that makes them use the simplified GIL state API. Consequence: Since mod_wsgi uses sub-interpreters, and the simplified GIL state API is not re-entrant, this results in the mod_wsgi locking up and hanging, making the dashboard unavailable. Fix: Added "WSGIApplicationGroup %{GLOBAL}" to mod_wsgi configuration, which forces it to always use the main interpreter instead of sub-interpreters. Result: With that option, mod_wsgi will work correctly no matter what options were used to compile the binary python modules. The slight performance penalty is not noticeable.
Story Points: ---
Clone Of: 1479051
: 1479056 (view as bug list)
Environment:
Last Closed: 2017-08-30 10:02:04 EDT
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1573488 None None None 2017-08-07 16:45 EDT
Launchpad 1708655 None None None 2017-08-07 16:45 EDT
OpenStack gerrit 473367 None None None 2017-08-07 16:45 EDT

  None (edit)
Comment 5 errata-xmlrpc 2017-08-30 10:02:04 EDT
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:2555

Note You need to log in before you can comment on or make changes to this bug.