Bug 1479056 - Horizon won't load with OSP11 - Script timed out before returning headers: django.wsgi
Horizon won't load with OSP11 - Script timed out before returning headers: dj...
Status: CLOSED ERRATA
Product: Red Hat OpenStack
Classification: Red Hat
Component: python-django-horizon (Show other bugs)
8.0 (Liberty)
x86_64 Linux
medium Severity medium
: zstream
: 8.0 (Liberty)
Assigned To: Radomir Dopieralski
Ido Ovadia
: Triaged, ZStream
Depends On: 1478042 1479051 1479055 1496173
Blocks: 1478870 1479057 1479058 1479732 1481774 1485889 1485890 1485894
  Show dependency treegraph
 
Reported: 2017-08-07 16:48 EDT by Radomir Dopieralski
Modified: 2017-11-29 11:01 EST (History)
16 users (show)

See Also:
Fixed In Version: python-django-horizon-8.0.1-16.el7ost
Doc Type: Bug Fix
Doc Text:
Previously, some binary Python modules used by Horizon were compiled with a flag that requires them to use the simplified GIL state API. Since mod_wsgi uses sub-interpreters and the simplified GIL state API is not reentrant, it results in the mod_wsgi locking up. Consequently the dashboard is unavailable. With this update, the mod_wsgi configuration was changed, forcing mod_wsgi to use the main interpreter instead of sub-interpreters. As a result, mod_wsgi works correctly.
Story Points: ---
Clone Of: 1479055
: 1479057 (view as bug list)
Environment:
Last Closed: 2017-11-29 11:01:06 EST
Type: Bug
Regression: ---
Mount Type: ---
Documentation: ---
CRM:
Verified Versions:
Category: ---
oVirt Team: ---
RHEL 7.3 requirements from Atomic Host:
Cloudforms Team: ---


Attachments (Terms of Use)


External Trackers
Tracker ID Priority Status Summary Last Updated
Launchpad 1573488 None None None 2017-08-07 16:48 EDT
Launchpad 1708655 None None None 2017-08-07 16:48 EDT
OpenStack gerrit 473367 None None None 2017-08-07 16:48 EDT

  None (edit)
Comment 1 Radomir Dopieralski 2017-09-22 19:19:16 EDT
Installed OSP8 with openstack-puppet-modules-7.1.5-7.el7ost from brew. Verified that it works and that the /etc/httpd/conf.d/15-horizon_vhost.conf file contains the line WSGIApplicationGroup %{GLOBAL}.
Comment 5 errata-xmlrpc 2017-11-29 11:01:06 EST
Since the problem described in this bug report should be
resolved in a recent advisory, it has been closed with a
resolution of ERRATA.

For information on the advisory, and where to find the updated
files, follow the link below.

If the solution does not work for you, open a new bug report.

https://access.redhat.com/errata/RHBA-2017:3286

Note You need to log in before you can comment on or make changes to this bug.